Bug 1585492 - Wayland version does not keep StartupWMClass/shows unrelated icon
Summary: Wayland version does not keep StartupWMClass/shows unrelated icon
Keywords:
Status: CLOSED DUPLICATE of bug 1585369
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-03 15:48 UTC by rugk
Modified: 2018-06-04 11:59 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-04 11:59:04 UTC
Type: Bug


Attachments (Terms of Use)

Description rugk 2018-06-03 15:48:27 UTC
Description of problem: When you start the Wayland version of FF, GNOME thinks that Firefox is the "usual" Firefox, because Firefox itself sets the WMClass to "Firefox" or so.


Version-Release number of selected component (if applicable):
Firefox 60

How reproducible:
Always

Steps to Reproduce:
1. Pin Firefox to Wayland to your favorites (pane) in GNOME.
2. Click on it.

Actual results:
It will start and soon a new entry in your pane will appear with a Firefox logo only labeled "Firefox" instead of "Firefox for Wayland".

Expected results:
Start and keep the icon it used to start. It should be controllable via the existing icon (for minimizing etc.) and not use a new one.

Additional info:

E.g. Tor Browser had the same problem.

To solve:
* In the .desktop file, you can add StartupWMClass to describe what class it should be using when starting.
* Note that this will be overridden by Firefox later, so you may want to add the "--class <startupclass>" to the command line arguments of Firefox. Then Firefox knows what class to use.

IMHO you may just let it use the default Firefox class. In this case adjusting the desktop file should be enough.

Comment 1 Martin Stransky 2018-06-04 11:59:04 UTC
A dupe of Bug 1585369.

*** This bug has been marked as a duplicate of bug 1585369 ***


Note You need to log in before you can comment on or make changes to this bug.