Bug 158551 - hang on ac/dc change in APM mode
hang on ac/dc change in APM mode
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-05-23 10:48 EDT by Bill Waddington
Modified: 2015-01-04 17:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-04 09:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
APM boot log (11.58 KB, text/plain)
2005-05-23 10:51 EDT, Bill Waddington
no flags Details

  None (edit)
Description Bill Waddington 2005-05-23 10:48:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
ThinkPad T43, stock or updated FC3 kernel.  In APM mode when changing from AC to DC power & v/v system "hangs" at next HD write access (this is a guess).  Mouse cursor still live for a while.  Commands like mkdir or sync hang and are insensitive to CTRL-C.

Forced pwr-off reboot always results in a file system check.  Once the fs was so badly damaged that the boot manager refused to boot it and "linux rescue" from the install DVD would not mount it.

In that case, when the error occurred I got a "journalling error" in the console, and a "filesystem write only" when I tried to sync.  Also string of "abnormal status 0x0D on port 0x1F7" messages when I tried to shut down.

Since the HD isn't writeable I haven't been able to save any diagnostic information other than the "recollections" above and the attached boot log
also at http://www.beezmo.com/scratch/t43_fc3/dmesg.apm

WAG: something to do w/SATA.

BTW, in APM mode, there is no cpufreq in /sys/devices/system/cpu/cpu0.

All seems well in ACPI mode, but APM is more desirable with ThinkPads.

Version-Release number of selected component (if applicable):
2.6.9-1.667 & 2.6.11-1.14_FC3

How reproducible:

Steps to Reproduce:
1. Boot in apm mode (apm=on acpi=off).
2. Unplug and re-plug AC adapter.
3. Access HD.

Actual Results:  As described above, system unresponsive.

Expected Results:  Simple switch to DC mode and back to AC mode.

Additional info:
Comment 1 Bill Waddington 2005-05-23 10:51:39 EDT
Created attachment 114718 [details]
APM boot log
Comment 2 Bill Waddington 2005-05-23 10:54:43 EDT
Make that "file system read only" please.
Comment 3 Bill Waddington 2005-05-24 15:22:31 EDT
Another datapoint:

I just loaded FC3 on my older ThinkPad R40 - also a centrino.  The good news is
it does _not_ exhibit the problem.  AC/DC changes dont b0rk the system, and
cpufreq shows up in /sys/devices/system/cpu/cpu0.  Maybe that's also the bad
news.  Looks to be hardware specific (?)

Is there anything else I can do/provide?

Comment 4 Bill Waddington 2005-06-29 13:04:06 EDT
This problem persists whith FC4.

It also introduces another problem at boot time: "The greeter program appears to
be crashing.  I will attempt to use a different one."

I can go on to log in via a strange gui screen and things seem OK until I change
power source.
Comment 5 Dave Jones 2005-07-15 17:53:19 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak

Thank you.
Comment 6 Bill Waddington 2005-07-17 19:26:08 EDT
2.6.12-1.1398_FC4 has the same bad behavior in
APM mode :(
Comment 7 Dave Jones 2005-09-30 02:40:57 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel ( As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Comment 8 Dave Jones 2005-11-10 14:44:49 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 9 Bill Waddington 2006-02-01 15:59:45 EST
Same bad behavior through 2.6.14-1.1656 :(
Comment 10 Dave Jones 2006-02-03 01:57:33 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 11 John Thacker 2006-05-04 09:46:28 EDT
Closing per previous comment.
Comment 12 Bill Waddington 2006-05-04 13:40:06 EDT
Problem persists at least through 2.6.,16-1.2080, but at this point it can stay
closed for all I care.

Note You need to log in before you can comment on or make changes to this bug.