Bug 1585835 - [RFE][Manila] Implement manila-api with httpd
Summary: [RFE][Manila] Implement manila-api with httpd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 15.0 (Stein)
Assignee: Goutham Pacha Ravi
QA Contact: Jason Grosso
Laura Marsh
URL:
Whiteboard:
Depends On:
Blocks: 1484601 1553195
TreeView+ depends on / blocked
 
Reported: 2018-06-04 21:22 UTC by Victoria Martinez de la Cruz
Modified: 2019-09-26 10:45 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.3.1-0.20190308194814.9817bf2.el8ost
Doc Type: Release Note
Doc Text:
The Shared File Systems service (manila) API now runs behind the Apache HTTP Server (httpd). The Apache error and access logs from the Shared File Systems service are available in /var/log/containers/httpd/manila-api on all the nodes that run the manila API container. The log location of the main API service (manila-api) has not changed, and continues to be written on each node in /var/log/containers/manila/.
Clone Of:
Environment:
Last Closed: 2019-09-21 11:16:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 590061 None MERGED Add support to deploy manila-api with Apache/wsgi 2020-04-16 17:27:42 UTC
OpenStack gerrit 591869 None MERGED Support manila-api deployment with Apache 2020-04-16 17:27:42 UTC
OpenStack gerrit 592188 None MERGED Add httpd and tls support to manila-api 2020-04-16 17:27:42 UTC
OpenStack gerrit 594566 None MERGED Switch Manila API to httpd and support TLS 2020-04-16 17:27:42 UTC

Internal Links: 1484601

Description Victoria Martinez de la Cruz 2018-06-04 21:22:41 UTC
manila-api can be deployed using either the built-in server (that depends on eventlet) or the Apache WSGI server. Currently, we are deploying manila with the built-in server and this is a problem for two reasons:

1. We cannot ensure manila py3 compatibility because evenlet is not py3 compatible and it's not clear when there will be a fix for this issues [0]. This blocks BZ#1553195
2. Not being able to use SSL in evenlet blocks BZ#1484601

We need to shift to Apache WSGI so we can ensure py3 compatibility and be able to use TLS for internal services in manila.

[0] http://lists.openstack.org/pipermail/openstack-dev/2018-May/130274.html

Comment 7 Goutham Pacha Ravi 2019-02-15 19:22:02 UTC
All necessary patches have merged upstream.

Comment 10 Jason Grosso 2019-07-16 20:51:42 UTC
I deployed OSP 15 with the latest passed_phase1 with TLS enabled and I have the following results from all the node running manila-api

Under controller nodes  I tailed the following log manila_wsgi_access_ssl.log  under  /var/log/containers/httpd/manila-api  running basic manila commands I see 

172.17.1.73 - - [16/Jul/2019:14:26:46 +0000] "GET /v2/b8c53cdff31241e3bb73ed99bb387b1e/shares/detail?is_public=True HTTP/1.1" 200 40 "-" "manila_ui_plugin_for_horizon"

172.17.1.73 - - [16/Jul/2019:16:23:24 +0000] "GET /v2/b8c53cdff31241e3bb73ed99bb387b1e/shares/detail HTTP/1.1" 200 40 "-" "python-manilaclient"

172.17.1.73 - - [16/Jul/2019:16:23:24 +0000] "GET /v2/b8c53cdff31241e3bb73ed99bb387b1e/shares/detail HTTP/1.1" 200 40 "-" "python-manilaclient"

172.17.1.73 - - [16/Jul/2019:16:28:22 +0000] "POST /v2/b8c53cdff31241e3bb73ed99bb387b1e/types/4eaddf31-b94c-47af-a9d8-39a0bb097838/extra_specs HTTP/1.1" 200 70 "-" "python-manilaclient"

172.17.1.73 - - [16/Jul/2019:16:28:44 +0000] "GET /v2/b8c53cdff31241e3bb73ed99bb387b1e/types?all_tenants=1&is_public=all HTTP/1.1" 200 229 "-" "python-manilaclient"

172.17.1.73 - - [16/Jul/2019:16:28:50 +0000] "GET /v2/b8c53cdff31241e3bb73ed99bb387b1e/types?all_tenants=1&is_public=all HTTP/1.1" 200 245 "-" "python-manilaclient"


[heat-admin@controller-0 ~]$ manila_api_container=$(sudo podman ps | grep manila-api | cut -d " " -f 1) sudo podman top $manila_api_container
USER     PID   PPID   %CPU    ELAPSED              TTY   TIME    COMMAND
root     1     0      0.000   25h7m4.637332585s    ?     0s      dumb-init --single-child -- kolla_start 
root     8     1      0.002   25h7m4.637620482s    ?     2s      /usr/sbin/httpd -DFOREGROUND 
manila   19    8      0.101   25h7m4.63768936s     ?     1m31s   manila_wsgi     -DFOREGROUND 
manila   20    8      0.101   25h7m4.637775124s    ?     1m31s   manila_wsgi     -DFOREGROUND 
manila   21    8      0.102   25h7m4.637886733s    ?     1m32s   manila_wsgi     -DFOREGROUND 
manila   22    8      0.097   25h7m4.637957183s    ?     1m28s   manila_wsgi     -DFOREGROUND 
apache   93    8      0.040   4h51m5.63802395s     ?     7s      /usr/sbin/httpd -DFOREGROUND 
apache   94    8      0.035   4h49m13.638127427s   ?     6s      /usr/sbin/httpd -DFOREGROUND 
apache   95    8      0.035   4h48m41.638214604s   ?     6s      /usr/sbin/httpd -DFOREGROUND 
apache   96    8      0.035   4h44m52.63828155s    ?     6s      /usr/sbin/httpd -DFOREGROUND 
apache   97    8      0.036   4h37m53.638391842s   ?     6s      /usr/sbin/httpd -DFOREGROUND 
apache   98    8      0.037   4h30m46.638476516s   ?     6s      /usr/sbin/httpd -DFOREGROUND 


[heat-admin@controller-2 ~]$ sudo podman top $manila_api_container
USER     PID   PPID   %CPU    ELAPSED               TTY   TIME    COMMAND
root     1     0      0.000   25h19m37.907483882s   ?     0s      dumb-init --single-child -- kolla_start 
root     8     1      0.002   25h19m37.907712337s   ?     2s      /usr/sbin/httpd -DFOREGROUND 
manila   19    8      0.094   25h19m36.907793724s   ?     1m26s   manila_wsgi     -DFOREGROUND 
manila   20    8      0.097   25h19m36.907868434s   ?     1m28s   manila_wsgi     -DFOREGROUND 
manila   21    8      0.099   25h19m36.907938223s   ?     1m30s   manila_wsgi     -DFOREGROUND 
manila   22    8      0.099   25h19m36.90927391s    ?     1m30s   manila_wsgi     -DFOREGROUND 
apache   94    8      0.032   4h17m14.909733527s    ?     5s      /usr/sbin/httpd -DFOREGROUND 
apache   95    8      0.033   4h12m44.909995204s    ?     5s      /usr/sbin/httpd -DFOREGROUND 
apache   98    8      0.033   4h10m8.910413144s     ?     5s      /usr/sbin/httpd -DFOREGROUND 
apache   99    8      0.034   4h4m41.910649388s     ?     5s      /usr/sbin/httpd -DFOREGROUND 
apache   100   8      0.029   3h48m48.911039409s    ?     4s      /usr/sbin/httpd -DFOREGROUND 
apache   101   8      0.031   3h34m27.911198064s    ?     4s      /usr/sbin/httpd -DFOREGROUND 
apache   102   8      0.032   3h27m30.913086877s    ?     4s      /usr/sbin/httpd -DFOREGROUND 


[heat-admin@controller-1 ~]$ sudo podman top $manila_api_container
USER     PID   PPID   %CPU    ELAPSED               TTY   TIME    COMMAND
root     1     0      0.000   25h28m39.608969926s   ?     0s      dumb-init --single-child -- kolla_start 
root     8     1      0.002   25h28m39.609239125s   ?     2s      /usr/sbin/httpd -DFOREGROUND 
manila   19    8      0.099   25h28m39.609309146s   ?     1m31s   manila_wsgi     -DFOREGROUND 
manila   20    8      0.101   25h28m39.609384487s   ?     1m33s   manila_wsgi     -DFOREGROUND 
manila   21    8      0.100   25h28m39.609452934s   ?     1m32s   manila_wsgi     -DFOREGROUND 
manila   22    8      0.101   25h28m39.610587211s   ?     1m33s   manila_wsgi     -DFOREGROUND 
apache   97    8      0.032   4h18m27.61085997s     ?     5s      /usr/sbin/httpd -DFOREGROUND 
apache   98    8      0.033   4h14m43.612245744s    ?     5s      /usr/sbin/httpd -DFOREGROUND 
apache   99    8      0.033   4h11m16.612374552s    ?     5s      /usr/sbin/httpd -DFOREGROUND 
apache   100   8      0.034   4h7m38.612462696s     ?     5s      /usr/sbin/httpd -DFOREGROUND 
apache   101   8      0.034   4h4m31.612532652s     ?     5s      /usr/sbin/httpd -DFOREGROUND 
apache   102   8      0.036   3h3m46.612610693s     ?     4s      /usr/sbin/httpd -DFOREGROUND 
apache   103   8      0.030   2h49m9.612680273s     ?     3s      /usr/sbin/httpd -DFOREGROUND 
apache   104   8      0.000   35m55.612775942s      ?     0s      /usr/sbin/httpd -DFOREGROUND

Comment 11 Aharon Canan 2019-08-14 13:23:42 UTC
Regression only

Comment 13 errata-xmlrpc 2019-09-21 11:16:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.