Bug 158705 - Segfault on loading /usr/lib64/games/uqm/uqm
Segfault on loading /usr/lib64/games/uqm/uqm
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: uqm (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
: 189939 199064 (view as bug list)
Depends On:
Blocks: FE4Target-x86_64
  Show dependency treegraph
 
Reported: 2005-05-24 20:21 EDT by Kyle R Maxwell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-02 10:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle R Maxwell 2005-05-24 20:21:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
When running 'uqm' from the command line, I get the below output (a window appears briefly during the process, then disappears):

The Ur-Quan Masters v0.3 (compiled Mar 18 2005 21:41:12)
This software comes with ABSOLUTELY NO WARRANTY;
for details see the included 'COPYING' file.

Saved games are kept in /home/kylem/.uqm/save/.
Initializing SDL (pure).
SDL driver used: x11
SDL initialized.
Initializing Screen.
Set the resolution to: 640x480x32
Initializing SDL audio subsystem.
SDL audio subsystem initialized.
Initializing MixSDL mixer.
MixSDL using driver 'SDL_audio'
MixSDL Mixer initialized.
    opened arts at 44100 Hz 16 bit stereo, 4096 samples audio buffer
Initializing sound decoders.
Sound decoders initialized.
0 joysticks were found.
        'lbm/title.ani' -- 19 bytes
/usr/bin/uqm: line 15:  7083 Segmentation fault      "/usr/lib64/games/uqm/uqm" "--contentdir=/usr/share/games/uqm/content" $UQM_OPTS "$@"


Version-Release number of selected component (if applicable):
uqm-0.3-4

How reproducible:
Always

Steps to Reproduce:
1. Run 'uqm' from the command line. (Problem also is manifested when starting from menu entry but no diagnostic data will be shown.)
2.
3.
  

Additional info:
Comment 1 Ville Skyttä 2005-05-25 01:44:55 EDT
I have already updated uqm to 0.4.0 in devel CVS and requested a build for it;
it should appear in the repository soon (when the build system awakens again)
provided the build succeeds.  Let's see if it helps.

If you want to build 0.4.0 from CVS before that, see the instructions at
http://cvs.fedora.redhat.com/extras.shtml and check out and build the "uqm" and
"uqm-content" components.

Anyway, when you've tried 0.4.0 one way or the another, please post an update
here and let me know if it works better.
Comment 2 Ville Skyttä 2005-05-26 11:14:27 EDT
0.4.0 is now in the Extras development repository, could you test if it fixes
the problem?
Comment 3 Kyle R Maxwell 2005-05-28 12:43:46 EDT
Nope, still doesn't work:

The Ur-Quan Masters v0.4.0 (compiled May 25 2005 16:54:54)
This software comes with ABSOLUTELY NO WARRANTY;
for details see the included 'COPYING' file.

Initializing base SDL functionality.
Using SDL version 1.2.8 (compiled with 1.2.8)
Initializing Pure-SDL graphics.
SDL driver used: x11
SDL initialized.
Initializing Screen.
Set the resolution to: 640x480x32
0 joysticks were found.
Initializing SDL audio subsystem.
SDL audio subsystem initialized.
Opening SDL audio device.
    using esd at 44100 Hz 16 bit stereo, 4096 samples audio buffer
Initializing mixer.
Mixer initialized.
Initializing sound decoders.
Sound decoders initialized.
        'lbm/title.ani' -- 19 bytes
Segmentation fault

Comment 4 Ville Skyttä 2005-05-28 13:30:08 EDT
Could you generate a backtrace of the crash with gdb as outlined in
http://fedoraproject.org/wiki/StackTraces and attach it here?  The debuginfo
packages for x86_64 development are at
http://fedoraproject.org/extras/development/x86_64/debug/
Comment 5 Ville Skyttä 2005-05-30 14:49:16 EDT
Help appreciated from x86_64 owners...
Comment 6 Warren Togami 2005-06-01 04:12:37 EDT
Not sure how helpful this is...

(gdb) bt
#0  0x0000000000000000 in ?? ()
#1  0x0000000000480098 in load_package (ResHeaderPtr=0xd83630, res_package=1) at
src/sc2code/libs/resource/getres.c:327
#2  0x0000000000480295 in res_GetResource (res=2097156) at
src/sc2code/libs/resource/getres.c:399
#3  0x0000000000498fd8 in LoadStringTableInstance (res=2097156) at
src/sc2code/libs/strings/sresins.c:33
#4  0x0000000000429d24 in LoadKernel (argc=0, argv=0x0) at src/sc2code/setup.c:116
#5  0x0000000000431d08 in Starcon2Main (threadArg=Variable "threadArg" is not
available.
) at src/sc2code/starcon.c:122
#6  0x0000000000499da7 in ThreadHelper (startInfo=0xd7e200) at
src/sc2code/libs/threads/sdl/sdlthreads.c:213
#7  0x000000394d5548bd in SDL_RunThread () from /usr/lib64/libSDL-1.2.so.0
#8  0x000000394d554c39 in SDL_CreateThread () from /usr/lib64/libSDL-1.2.so.0
#9  0x00002aaaaabcc97c in start_thread () from /lib64/libpthread.so.0
#10 0x00002aaaaaf2cc2e in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()
Comment 7 Ville Skyttä 2005-06-01 13:15:36 EDT
Thanks.  "bt full" could be slightly more informative, dunno.

Reported upstream: http://uqm.stack.nl/cgi-bin/bugs/show_bug.cgi?id=741
Comment 8 Warren Togami 2005-06-01 17:43:23 EDT
(gdb) bt full
#0  0x0000000000000000 in ?? ()
No symbol table info available.
#1  0x0000000000480098 in load_package (ResHeaderPtr=0xe80480, res_package=1) at
src/sc2code/libs/resource/getres.c:327
        hData = Variable "hData" is not available.
Comment 9 Ville Skyttä 2005-06-02 10:36:23 EDT
Upstream says: "There are still many issues to resolve before the game will run
on 64 bits systems."

http://uqm.stack.nl/cgi-bin/bugs/show_bug.cgi?id=252
http://uqm.stack.nl/cgi-bin/bugs/show_bug.cgi?id=741

Given that, I'm going to request removal of uqm* from the x86_64 repository.  I
guess the i386 binary could work on x86_64 though.
Comment 10 Konstantin Ryabitsev 2006-04-26 10:13:00 EDT
*** Bug 189939 has been marked as a duplicate of this bug. ***
Comment 11 Konstantin Ryabitsev 2006-07-16 17:01:55 EDT
*** Bug 199064 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.