Bug 1587807 - Cluster admin, click "View Archive" shows no result in Kibana due to default index pattern is ".operation
Summary: Cluster admin, click "View Archive" shows no result in Kibana due to default ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.11.0
Assignee: Josef Karasek
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks: 1598305 1624406
TreeView+ depends on / blocked
 
Reported: 2018-06-06 07:04 UTC by Junqi Zhao
Modified: 2018-12-21 15:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Kibana index pattern seeding was modified to reduce the number of entries in the droplist that were visible to cluster admins. Consequence: Cluster-admin's navigating to Kibana for logging from the web console were no longer sent to the correct URL. Fix: Take into consideration a user's cluster-admin role when creating the web console link to pod logs in Kibana Result: The link is created correctly.
Clone Of:
: 1598305 1624406 (view as bug list)
Environment:
Last Closed: 2018-12-21 15:16:29 UTC


Attachments (Terms of Use)
default index pattern is ".operations.*" (104.41 KB, image/png)
2018-06-06 07:04 UTC, Junqi Zhao
no flags Details
logs could be found if change default index pattern to project.* (130.88 KB, image/png)
2018-06-06 07:07 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift origin-web-console pull 3060 None None None 2018-08-31 13:30:33 UTC

Description Junqi Zhao 2018-06-06 07:04:52 UTC
Created attachment 1448129 [details]
default index pattern is ".operations.*"

Description of problem:
Cluster admin, create pods under namespace and click "View Archive" to redirect to kibana, 
there is not log could be found, and there is one warning in page
Discover: "project.foo.5942205d-694f-11e8-ba82-fa163ec39bd9.*" is not a configured pattern. Using the default index pattern: ".operations.*"

Change the default index pattern to .all or project.* from Kibana "Settings" tab,
although there is still warning info, but logs could be found
Discover: "project.foo.5942205d-694f-11e8-ba82-fa163ec39bd9.*" is not a configured pattern. Using the default index pattern: "project.*"

Version-Release number of selected component (if applicable):
logging images version: v3.10.0-0.60.0.0

How reproducible:
Always

Steps to Reproduce:
1. oc new-project foo; oc new-app centos/ruby-22-centos7~https://github.com/openshift/ruby-ex.git
2. Click "View Archive" from pod's "Logs" tab
3.

Actual results:
There is not log could be found since default index pattern is ".operations.*"

Expected results:


Additional info:

Comment 1 Junqi Zhao 2018-06-06 07:07:07 UTC
Created attachment 1448130 [details]
logs could be found if change default index pattern to  project.*

Comment 2 Junqi Zhao 2018-06-06 07:07:36 UTC
# oc get project openshift-logging -o yaml
apiVersion: project.openshift.io/v1
kind: Project
metadata:
  annotations:
    openshift.io/description: ""
    openshift.io/display-name: ""
    openshift.io/logging.data.prefix: .operations
    openshift.io/node-selector: ""
    openshift.io/sa.scc.mcs: s0:c9,c4
    openshift.io/sa.scc.supplemental-groups: 1000080000/10000
    openshift.io/sa.scc.uid-range: 1000080000/10000
    quota.openshift.io/cluster-resource-override-enabled: "false"
  creationTimestamp: 2018-06-06T00:31:40Z
  name: openshift-logging
  resourceVersion: "23393"
  selfLink: /apis/project.openshift.io/v1/projects/openshift-logging
  uid: fb1b8a5d-6920-11e8-ba82-fa163ec39bd9
spec:
  finalizers:
  - openshift.io/origin
  - kubernetes
status:
  phase: Active

Comment 4 Jeff Cantrill 2018-06-07 13:25:54 UTC
Ignore comment #c2.  Moving to 3.10.z as this is not a blocker.

Comment 7 Jeff Cantrill 2018-09-04 16:49:12 UTC
Needs 3.11 image rebuild of origin-web-console

Comment 8 Anping Li 2018-09-07 07:05:48 UTC
Verified pass with v3.11.0-0.28.0

Comment 9 Luke Meyer 2018-12-21 15:16:29 UTC
Closing bugs that were verified and targeted for GA but for some reason were not picked up by errata. This bug fix should be present in current 3.11 release content.


Note You need to log in before you can comment on or make changes to this bug.