Bug 1598305 - [3.9]Cluster admin, click "View Archive" shows no result in Kibana due to default index pattern is ".operations.*"
Summary: [3.9]Cluster admin, click "View Archive" shows no result in Kibana due to def...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.9.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
: 1603549 (view as bug list)
Depends On: 1587807 1624406
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-05 04:26 UTC by Junqi Zhao
Modified: 2018-12-13 19:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Kibana index pattern seeding was modified to reduce the number of entries in the droplist that were visible to cluster admins. Consequence: Cluster-admin's navigating to Kibana for logging from the web console were no longer sent to the correct URL. Fix: Take into consideration a user's cluster-admin role when creating the web console link to pod logs in Kibana Result: The link is created correctly.
Clone Of: 1587807
Environment:
Last Closed: 2018-12-13 19:26:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3748 None None None 2018-12-13 19:27:10 UTC
Github openshift origin-web-console pull 3088 None None None 2018-10-19 20:39:27 UTC

Comment 1 Jeff Cantrill 2018-07-23 13:14:43 UTC
*** Bug 1603549 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Cantrill 2018-09-04 15:33:18 UTC
Work around is to go straight to Kibana and choose the correct index pattern or link from the web console and choose the appropriate index pattern

Comment 8 Qiaoling Tang 2018-11-29 03:33:55 UTC
Verified in ose-web-console-v3.9.55-1.

Comment 10 errata-xmlrpc 2018-12-13 19:26:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3748


Note You need to log in before you can comment on or make changes to this bug.