Bug 1588434 - [UI] Clicking Manage roles fails to load role list if overcloud plan is deleted
Summary: [UI] Clicking Manage roles fails to load role list if overcloud plan is deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ga
: 13.0 (Queens)
Assignee: Jason E. Rist
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-07 10:51 UTC by Gurenko Alex
Modified: 2018-06-27 13:58 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-common-8.6.1-20.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:57:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:58:15 UTC

Description Gurenko Alex 2018-06-07 10:51:55 UTC
Description of problem: It's not possible to manage roles if you don't have plan called overcloud.


Version-Release number of selected component (if applicable): 2018-06-01.1


How reproducible: 100%


Steps to Reproduce:
1. Login to UI
2. Delete plan called overcloud
3. Upload a new plan with a different name
4. Click Manage Roles inside new plan

Actual results:

Error message shows that Roles cannot be loaded


Expected results:

List of roles displayed


Additional info:

Comment 1 Jason E. Rist 2018-06-13 15:05:11 UTC
This is fixed by this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1573965

Comment 6 Dan Trainor 2018-06-19 17:54:29 UTC
Verified this works without error according to the steps specified when the bz was opened.

Also, note the bug referenced in this bug[0], which was supposed to fix this bug, was also VERIFIED yesterday.

---

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1573965

Comment 8 errata-xmlrpc 2018-06-27 13:57:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.