Bug 1591027 - Update rhui-debug.py to collect information for RHUI 3+
Summary: Update rhui-debug.py to collect information for RHUI 3+
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 3.0.4
: 3.0.x
Assignee: RHUI Bug List
QA Contact: Radek Bíba
URL:
Whiteboard:
Depends On: 1578678
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-13 22:41 UTC by Craig Donnelly
Modified: 2018-07-10 16:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-10 16:00:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Update rhui-debug for RHUI 3 (10.64 KB, patch)
2018-06-13 22:51 UTC, Craig Donnelly
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2153 None None None 2018-07-10 16:00:57 UTC

Description Craig Donnelly 2018-06-13 22:41:08 UTC
Description of problem:
rhui-debug.py that was shipped in RHUI 3 is the same as RHUI 2.
Since it was not updated, we receive no information in a rhui-debug from RHUI 3+.

Version-Release number of selected component (if applicable): 3.0+


How reproducible: 100%


Steps to Reproduce:
1. Run rhui-debug.py

Actual results:
No useful data collected.

Expected results:
Full rhui-debug with data pertinent to RHUI 3.

Additional info:
Have created a patch to work with RHUI 3 useful information, plus a few additional new features for one-off rhui-debug runs. (Can grab mongodb logs and auto-xz compress the debug into a tar.)

Will add patch here after BZ creation.

Comment 3 Craig Donnelly 2018-06-13 22:51:28 UTC
Created attachment 1451074 [details]
Update rhui-debug for RHUI 3

Comment 7 Radek Bíba 2018-06-27 06:37:24 UTC
The problem is that in RHUI 3 the /usr/share/rh-rhua/rhui-debug.py script is part of the rh-rhui-tools package, which is NOT installed on CDS nodes. Therefore, "sosreport -o rhui" only produces:

[root@cds01 sosreport-cds01.example.com-20180627053658]# find
.
./sos_commands
./sos_commands/rhui
./sos_commands/rhui/rhui-debug
./sos_logs
./sos_logs/sos.log
./sos_logs/ui.log
./sos_reports
./sos_reports/sos.html
./sos_reports/sos.txt
./version.txt

And:

# cat sos_commands/rhui/rhui-debug
python: can't open file '/usr/share/rh-rhua/rhui-debug.py': [Errno 2] No such file or directory

It's not really feasible to want to install rh-rhui-tools by hand in order to be able to get nice sos reports from the CDS as there's a pretty wild dependency tree, including pulp-rpm-plugins, which tries to touch /var/lib/pulp, which is a symlink to a read-only filesystem on the CDS, so the installation fails.

Moreover, /usr/lib/python2.7/site-packages/sos/plugins/rhui.py (from the sos package) reads:

        if self.is_installed("pulp-cds"):
            cds = "--cds"
        else:
            cds = ""

But there's no pulp-cds in RHUI 3 anymore. When I hack this part of rhui.py and also copy rhui-debug.py to the CDS by hand, I get a tarball with a collection of the expected files. So it seems we need an update of sos and I guess we'll have to move debug.py to the rh-rhui-tools-libs, which IS installed on the CDS.

(This is not a regression in the updated debug.py file as the root cause is in rhui.py, so I think we can move on for now.)

Comment 8 Radek Bíba 2018-06-27 09:00:37 UTC
I think I should add that everything is fine on the RHUA node. I also tried running debug.py directly (outside of sos) and with -m, and got a collection including mongodb config files and log.

Comment 12 errata-xmlrpc 2018-07-10 16:00:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2153


Note You need to log in before you can comment on or make changes to this bug.