Bug 15911 - pulse fails to correctly restart
pulse fails to correctly restart
Status: CLOSED DUPLICATE of bug 57654
Product: Red Hat High Availability Server
Classification: Retired
Component: piranha (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Phil Copeland
Phil Copeland
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 04:39 EDT by David D.W. Downey
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-05 16:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-08-10 04:39:07 EDT
Problem: According to the documentation, you should be able to run '/etc/rc.d/init.d/pulse restart'.  Running it with the restart command 
fails to clean up the old  pid file causing pulse to complainthat it is still running or that you need to make sure you are running the command 
as root even if you ARE root. It also leaves lvs and nanny running and does not kill them off.

Workaround: run the command as '/etc/rc.d/init.d/pulse stop ; /etc/rc.d/init.d/pulse start' though this too does NOT kill lvs or nanny. You 
end up having to run killall -9 lvs; killall -9 nanny in between the stop and start commands to pulse. According to the docs, the accepted way 
to restart the LVS software is to run either pulse stop and start or use restart. (unless I'm reading this wrong
Comment 1 Red Hat Bugzilla 2000-08-10 14:32:00 EDT
This strikes me as very likely being a real bug as I do not believe it was
included in formal testing. I will investigate.

Comment 2 Red Hat Bugzilla 2000-08-10 14:34:53 EDT
Accidentally flagged as resolved instead of accepted
Comment 3 Red Hat Bugzilla 2000-08-14 17:27:42 EDT
Update: Because of LWE, no personnel are availabel to investigate this problem
until after 8/21.
Comment 4 Red Hat Bugzilla 2000-08-14 17:31:05 EDT
Additional information on the work-around. stop does indeed stop lvs. anny, and
all other piranha components. It is possible that because the stop and starts
are back-to-back, with no testing logic, that a delay is needed between the 2
commands.

Also, performing a "kill -s SIGTERM xxx" to nanny or lvs would be better than
-9, as this should cause all the children to terminate properly.
Comment 5 Red Hat Bugzilla 2000-08-17 08:59:13 EDT
I have verified this problem, the issue is that depending on the number of
virtual and real servers, the time to stop can be pretty long.  (Therefore a
simple sleep will not be a safe answer).  I see that there is some actual reload
code being worked on (As opposed to stop/start).

-- Keith Moore
Comment 6 Red Hat Bugzilla 2000-08-17 14:56:15 EDT
Understood. It will be looked at.
Comment 7 Red Hat Bugzilla 2002-01-17 17:03:59 EST

*** This bug has been marked as a duplicate of 57654 ***

Note You need to log in before you can comment on or make changes to this bug.