Bug 1631093 - Anaconda installer doesn't start VNC after entering VNC password
Summary: Anaconda installer doesn't start VNC after entering VNC password
Status: CLOSED DUPLICATE of bug 1592686
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: ppc64le
OS: Linux
high
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2018-09-19 21:00 UTC by IBM Bug Proxy
Modified: 2018-09-28 12:40 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-09-20 16:25:59 UTC


Attachments (Terms of Use)
.treeinfo from Fedora rawhide of 2018-09-19 (1.18 KB, application/octet-stream)
2018-09-19 21:00 UTC, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 171592 None None None 2018-09-19 21:00 UTC

Description IBM Bug Proxy 2018-09-19 21:00:20 UTC

Comment 1 IBM Bug Proxy 2018-09-19 21:00:37 UTC
Description of problem:

Anaconda installer doesn't start VNC after entering VNC password.
If password is left empty (by just pressing Enter twice), VNC starts successfully.



Version-Release number of selected component (if applicable):

anaconda 30.3-1.fc30



How reproducible:
Always.



Steps to Reproduce:

1. Netboot Fedora rawhide ppc64le

  label ppc64le fedora rawhide (dl.fedoraproject.org)
    kernel http://dl.fedoraproject.org/pub/fedora-secondary/development/rawhide/Everything/ppc64le/os/ppc/ppc64/vmlinuz
    initrd http://dl.fedoraproject.org/pub/fedora-secondary/development/rawhide/Everything/ppc64le/os/ppc/ppc64/initrd.img
    append repo=http://dl.fedoraproject.org/pub/fedora-secondary/development/rawhide/Everything/ppc64le/os ip=9.40.193.189::9.40.193.1:255.255.255.0:ltc-boston74.aus.stglabs.ibm.com:enP1p9s0f0:none nameserver=9.3.1.200 verbose console=hvc0

2. Wait for installer to load and select "1) Start VNC"

3. Enter password twice, e.g.: "passw0rd"

3. Prompt will display "Starting VNC..." and VNC won't be started.



Actual results:

Anaconda text interface displays:

  Starting VNC...

but VNC isn't started at all.



Expected results:

VNC should have started successfully.


Additional info:

Fedora 28 works:
anaconda 28.22.10-1.fc28

Fedora 29 fails:
anaconda 29.24.1-1.fc29

Fedora rawhide fails:
anaconda 30.3-1.fc30

[anaconda root@ltc-boston74 ~]# uname -a
Linux ltc-boston74.aus.stglabs.ibm.com 4.19.0-0.rc3.git3.1.fc30.ppc64le #1 SMP Fri Sep 14 18:33:14 UTC 2018 ppc64le ppc64le ppc64le GNU/Linux

[anaconda root@ltc-boston74 ~]# grep -i anaconda lorax-packages.log
libreport-anaconda-2.9.5-4.fc29.ppc64le
anaconda-user-help-26.1-8.fc29.noarch
anaconda-gui-30.3-1.fc30.ppc64le
anaconda-core-30.3-1.fc30.ppc64le
anaconda-install-env-deps-30.3-1.fc30.ppc64le
anaconda-widgets-30.3-1.fc30.ppc64le
anaconda-30.3-1.fc30.ppc64le
anaconda-dracut-30.3-1.fc30.ppc64le
anaconda-tui-30.3-1.fc30.ppc64le
kdump-anaconda-addon-005-2.20180730git966223e.fc29.noarch
docker-anaconda-addon-0.4-9.fc29.ppc64le


vncpasswd process seems to be stuck:

[anaconda root@ltc-boston74 ~]# ps -ef | grep -i vnc
root       8825   7367  0 15:07 pts/0    00:00:00 vncpasswd -f

Comment 2 IBM Bug Proxy 2018-09-19 21:00:44 UTC
Created attachment 1484918 [details]
.treeinfo from Fedora rawhide of 2018-09-19

Comment 3 Vendula Poncova 2018-09-20 16:25:59 UTC

*** This bug has been marked as a duplicate of bug 1592686 ***


Note You need to log in before you can comment on or make changes to this bug.