Bug 159381 - hi_IN and ta_IN translation incomplete
Summary: hi_IN and ta_IN translation incomplete
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rajesh Ranjan
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: Indic
TreeView+ depends on / blocked
 
Reported: 2005-06-02 06:30 UTC by Lawrence Lim
Modified: 2015-04-21 04:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 20:07:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hindi character dialog (38.31 KB, image/png)
2005-06-02 08:21 UTC, Caolan McNamara
no flags Details
tamil character dialog (48.40 KB, image/png)
2005-06-02 08:23 UTC, Caolan McNamara
no flags Details
ta_IN UI when writer starts (140.62 KB, image/png)
2005-06-02 08:39 UTC, Lawrence Lim
no flags Details
this should be ok (526.92 KB, application/x-bzip)
2005-11-02 11:57 UTC, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 57107 None None None Never

Description Lawrence Lim 2005-06-02 06:30:53 UTC
Description of problem:
When trying to run OOo in hi_IN and ta_IN locale, the UI is in en_US even though
the LANG pack has been installed.

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.104-2
openoffice.org-langpack-hi_IN-1.9.104-2
openoffice.org-langpack-ta_IN-1.9.104-2

How reproducible:
Always

Steps to Reproduce:
1.LANG=hi_IN.UTF-8 oowriter OR LANG=ta_IN.UTF-8 oowriter
2.
3.
  
Actual results:
UI is in english

Expected results:
Localised UI

Additional info:

Comment 1 Caolan McNamara 2005-06-02 08:21:17 UTC
Created attachment 115076 [details]
hindi character dialog

Comment 2 Caolan McNamara 2005-06-02 08:23:04 UTC
Created attachment 115077 [details]
tamil character dialog

Comment 3 Caolan McNamara 2005-06-02 08:26:42 UTC
These are some screenshots of the writer character dialog under each LANG with
the langpacks installed. So is the problem "indic translations not complete"
leaving many english menu entries which I can't do anything about, unless there
are new updated 2.0 hi_IN.GSI or ta_IN.GSI files somewhere not in the upstream
HEAD? Or something different than what is seen in the screenshots above ?

Comment 4 Lawrence Lim 2005-06-02 08:38:36 UTC
Oh my bad. I should have gone a bit "deeper" as I only went through the top
level of the menu items very quickly. I see what you meant though, the indic
translations are indeed incomplete.

Can we leave the bug open for tracking the status of the translation? I will try
to get input from our India Localisation counterpart. :-)


Thanks.



Comment 5 Lawrence Lim 2005-06-02 08:39:57 UTC
Created attachment 115078 [details]
ta_IN UI when writer starts

Comment 6 Caolan McNamara 2005-07-04 11:07:56 UTC
<ivo> caolan, I got no hindi translations for the OOo 2.0 , only for 1.1.x
branch some times ago
<ivo> caolan, I guess writer / calc menus are moved to officecfg from 1.1.x to
2.0 , so there is no translation yet

Comment 9 Sarah Wang 2005-10-04 09:54:25 UTC
Rajesh, can you point out the location for Hindi OO translation pack here?
Thanks.

Comment 10 Rajesh Ranjan 2005-10-06 04:24:44 UTC
I will try to finish translation with review by three weeks. Translation is near
to complete but it needs proofread and review because it is previously done by
community and so need to check the consistancy.

Comment 11 Caolan McNamara 2005-10-25 11:26:23 UTC
The 3rd of November 2005 is the cut-off for 2.0.1 btw. Getting hi_IN in before
then would make upstream 2.0.1, otherwise 2.0.2 is in February. No big problem
as we can always add the translations to our own packages. Just to pass that
information on

Comment 13 Rajesh Ranjan 2005-10-31 15:18:52 UTC
My front is clear now, now  it is OO developer's turn :-)..

Following is the location for OO translated pack--

http://punlinux.sourceforge.net/lang/



Comment 14 Caolan McNamara 2005-11-02 08:34:06 UTC
I think that the lines of e.g.
xmlsecurity     source\component\warnbox.src    0       warningbox     
RID_XMLSECWB_NO_MOZILLA_PROFILE                    0       27...

should actually be

xmlsecurity     source\component\warnbox.src    0       warningbox     
RID_XMLSECWB_NO_MOZILLA_PROFILE                    0       hi-IN...

i.e. i get errors of e.g. 

Text[ 27 ] = "रदà¥à¤¦ à¤à¤°à¥à¤ (~C)";
        ^
f640: "../../unxlngi6.pro/misc/euro/euro.src", line 73: Error: syntax error


Comment 15 Caolan McNamara 2005-11-02 11:57:21 UTC
Created attachment 120636 [details]
this should be ok

I converted it from numberic phone code style to new lang string style. This
should be ok

Comment 16 Caolan McNamara 2005-11-03 15:13:54 UTC
accepted for 2.0.1, good stuff

Comment 17 Caolan McNamara 2005-12-02 08:14:34 UTC
*** Bug 174788 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.