Bug 1595411 - ara FTBFS with Python 3.7
Summary: ara FTBFS with Python 3.7
Keywords:
Status: CLOSED DUPLICATE of bug 1603394
Alias: None
Product: Fedora
Classification: Fedora
Component: ara
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Moreau Simard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON37
TreeView+ depends on / blocked
 
Reported: 2018-06-26 21:35 UTC by Miro Hrončok
Modified: 2019-12-30 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-23 13:50:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2018-06-26 21:35:20 UTC
Description of problem:

async is now a keyword:

  File "/usr/lib/python3.7/site-packages/ara/tests/unit/test_ara_record.py", line 161
    task.async = 0
             ^
SyntaxError: invalid syntax

https://koji.fedoraproject.org/koji/taskinfo?taskID=27887600

See https://docs.python.org/3.7/whatsnew/3.7.html#summary-release-highlights

Version-Release number of selected component (if applicable): ara-0.14.6-2.fc29 but also 0.15.0.0rc1


How reproducible: fedpkg build --target=f29-python


Actual results: Build fails.


Expected results: Builds fine.


Additional info: When you fix this, please build in the side tag: fedpkg build --target=f29-python

Comment 1 David Moreau Simard 2018-06-26 21:51:21 UTC
Thanks, I'll look into it.

Comment 2 Miro Hrončok 2018-07-02 18:19:49 UTC
The side tag is no more. Once fixed, build in regular rawhide.

Comment 3 Miro Hrončok 2018-07-17 12:34:02 UTC
David?

Comment 4 Miro Hrončok 2018-07-23 13:50:55 UTC

*** This bug has been marked as a duplicate of bug 1603394 ***


Note You need to log in before you can comment on or make changes to this bug.