Bug 1603394 - ara: FTBFS in Fedora rawhide
Summary: ara: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ara
Version: 29
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: David Moreau Simard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1595411 (view as bug list)
Depends On:
Blocks: F29FTBFS F29BetaFreezeException PYTHON37
TreeView+ depends on / blocked
 
Reported: 2018-07-19 14:42 UTC by Mohan Boddu
Modified: 2018-09-21 05:32 UTC (History)
4 users (show)

Fixed In Version: ara-0.16.1-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-21 05:32:54 UTC


Attachments (Terms of Use)
build.log (1.00 KB, text/plain)
2018-07-19 14:42 UTC, Mohan Boddu
no flags Details
root.log (1.00 KB, text/plain)
2018-07-19 14:42 UTC, Mohan Boddu
no flags Details
state.log (607 bytes, text/plain)
2018-07-19 14:42 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-19 14:42:13 UTC
ara failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28166398


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix ara at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
ara will be orphaned. Before branching of Fedora 30,
ara will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-19 14:42:20 UTC
Created attachment 1460461 [details]
build.log

file build.log too big, will only attach last 1024 bytes

Comment 2 Mohan Boddu 2018-07-19 14:42:26 UTC
Created attachment 1460462 [details]
root.log

file root.log too big, will only attach last 1024 bytes

Comment 3 Mohan Boddu 2018-07-19 14:42:28 UTC
Created attachment 1460463 [details]
state.log

Comment 4 Miro Hrončok 2018-07-23 13:50:55 UTC
*** Bug 1595411 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2018-07-23 14:19:01 UTC
David, I intent to start a nonresponsive maintainer procedure since this was ignored for a month (incl. the duplicate bz). Let me know if I shall not.

Comment 6 Miro Hrončok 2018-07-25 09:26:28 UTC
(This is a mass bug update. Forgive me if things are not 100% accurate for this one.)

At this moment, your package still requires Python 3.6. This will cause broken upgrades to Fedora 29. Please prioritize this rebuild.

Let me know if you need help from the Python maintenance team figuring out why the package FTBFS.

Consider orphaning the package if you don't have time for it.

Consider retiring the package if upstream is dead and nothing depends on it in Fedora.

If you are blocked by other packages (I've recently tried to set the Bugzilla metadata to reflect that), consider helping there as well. Thank you.

Comment 7 Miro Hrončok 2018-08-06 10:22:19 UTC
This is another friendly reminder.

Please take action.

Comment 8 Miro Hrončok 2018-08-10 13:47:14 UTC
Note that I requested an approval from FESCo to retire leaf packages that still require Python 3.6 at beta freeze and their bugs are in NEW state. (This package might not necessarily be leaf at this moment, but I'm updating all the bugs in case the dependencies change in the meantime.)

More info at https://pagure.io/fesco/issue/1965

Comment 9 Miro Hrončok 2018-08-13 11:59:22 UTC
Another bulk reminder. Please take action. Your package doesn't install on Fedora 29. Fix it or retire it.

Comment 10 Jan Kurik 2018-08-14 10:28:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 11 Miro Hrončok 2018-08-16 12:30:53 UTC
Do something now! (This is the unfriendly reminder.)

Comment 12 Miro Hrončok 2018-08-16 15:13:47 UTC
I apologize if my unfriendly reminder was too harsh. It was intended to be stronger than the previous friendly reminders, not to hurt anyone.

That said, this still needs to be taken care of.

Comment 13 Miro Hrončok 2018-08-17 11:49:29 UTC
Leaf packages that still require Python 3.6 one week before Fedora 29 Beta Freeze ([0]) and their FTBFS bug remains in NEW state, will be mass retired. Packages marked as blocked by non-FTBFS bug are excluded from this. [1]

[0] https://fedoraproject.org/wiki/Releases/29/Schedule
[1] https://pagure.io/fesco/issue/1965

Comment 14 hguemar 2018-08-20 13:53:57 UTC
Since the deadline is tomorrow and that David is quite busy with other things, I'm taking over this ticket too.

Comment 15 Miro Hrončok 2018-09-03 17:17:05 UTC
Any news on ara?

Comment 16 David Moreau Simard 2018-09-05 01:13:36 UTC
@Miro, I've tagged a new versions of ARA this week (0.16.0 and 0.16.1) which contains the fixes for py37.

Sorry for lacking on the maintenance, I'm the author of ARA and I was hoping to release a major refactor which would have an impact on the packaging -- the major refactor is now >1yr in the making :(

I'll address the situation now.

Comment 17 Fedora Blocker Bugs Application 2018-09-07 10:31:25 UTC
Proposed as a Freeze Exception for 29-beta by Fedora user churchyard using the blocker tracking app because:

 Old version blocks update to Fedora 29, requires Python 3.6.

Comment 18 Adam Williamson 2018-09-10 23:25:28 UTC
Discussed at 2018-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-10/f29-blocker-review.2018-09-10-16.01.html . Accepted (under the block vote at the end of the meeting) as a freeze exception issue as this can prevent upgrades working without the potentially-dangerous --allowerasing , and upgrades typically run without updates-testing so there is a benefit to pushing this stable for folks trying to upgrade at present.

Comment 19 David Moreau Simard 2018-09-11 02:11:24 UTC
I'm still working on this...

There was a lot of catching up to do but that's my fault:
- ARA 0.14.6 -> 0.16.1
- Ansible 2.4.0.0 -> Ansible 2.6.4

Scratch build for f28: https://koji.fedoraproject.org/koji/taskinfo?taskID=29608533
Scratch build for f29: https://koji.fedoraproject.org/koji/taskinfo?taskID=29608573

I'll be committing and pushing changes up for a build ASAP.

Comment 20 David Moreau Simard 2018-09-11 03:36:58 UTC
Candidate build for f29: https://koji.fedoraproject.org/koji/taskinfo?taskID=29609339

I need to do a bit more testing before tagging it, it'll wait until at least tomorrow.

Comment 21 Fedora Update System 2018-09-11 17:31:19 UTC
ara-0.16.1-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c749bffdfa

Comment 22 David Moreau Simard 2018-09-11 18:15:33 UTC
@Miro, @Haikel, package in f29 is tagged pending-testing [1] and it's built in rawhide [2].

I'll work on f28 soon but my understanding is that this should be unblocked now, please let me know if I am mistaken.

[1]: https://koji.fedoraproject.org/koji/taskinfo?taskID=29619771
[2]: https://koji.fedoraproject.org/koji/taskinfo?taskID=29619774

Comment 23 Fedora Update System 2018-09-13 03:31:49 UTC
ara-0.16.1-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c749bffdfa

Comment 24 Fedora Update System 2018-09-21 05:32:54 UTC
ara-0.16.1-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.