Bug 15957 - Version of ash provided with Red hat Linux is obsolete
Version of ash provided with Red hat Linux is obsolete
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ash (Show other bugs)
6.2
All Linux
high Severity high
: ---
: ---
Assigned To: Preston Brown
:
: 16087 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 18:24 EDT by juhtolv
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 11:36:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description juhtolv 2000-08-10 18:24:47 EDT
juhtolv@verso:/st/94/kaksoset/juhtolv % cat /etc/redhat-release 
Red Hat Linux release 6.2 (Zoot)
juhtolv@verso:/st/94/kaksoset/juhtolv % rpm -qi ash
Name        : ash                          Relocations: (not relocateable)
Version     : 0.2                               Vendor: Red Hat, Inc.
(major clip)
juhtolv@verso:/st/94/kaksoset/juhtolv % ash
%S%s%n@%m:%/ %# set +o noclobber
set: Illegal option -o
%S%s%n@%m:%/ %# set -o noclobber
set: Illegal option -o
%S%s%n@%m:%/ %# 

If you don't know, how to find new version of ash, consult maintainer of
Debian-package of ash:

juhtolv@heresy:/home/juhtolv % dpkg --status ash
Package: ash
Status: install ok installed
Priority: optional
Section: shells
Installed-Size: 130
Maintainer: Herbert Xu <herbert@debian.org>
Version: 0.3.6-5
Depends: libc6 (>= 2.1.2)
Description: NetBSD /bin/sh
 "ash" is a POSIX compliant shell that is much smaller than "bash".
 We take advantage of that by making it the shell on the installation
 root floppy, where space is at a premium.
 .
 It can be usefully installed as /bin/sh (because it executes scripts
 somewhat faster than "bash"), or as the default shell either of root
 or of a second user with a userid of 0 (because it depends on fewer
 libraries, and is therefore less likely to be affected by an upgrade
 problem or a disk failure).  It is also useful for checking that a
 script uses only POSIX syntax.
 .
 "bash" is a better shell for most users, since it has some nice
 features absent from "ash", and is a required part of the system.

juhtolv@heresy:/home/juhtolv % cat /usr/share/doc/ash/copyright 
This package was debianized by Mark W. Eichin eichin@kitten.gen.ma.us on
Mon, 24 Feb 1997 16:00:16 -0500.

This package was re-ported from NetBSD and debianized by
Herbert Xu herbert@debian.org on Thu, 19 Jun 1997 19:29:16 +1000.

It was downloaded from ftp.netbsd.org.
(Major Clip)

I have this bookmark in my ncftp, but I think there is some better place
inside ftp.netbsd.org:

ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-current/src/bin/sh/
Comment 1 Pavel Roskin 2000-10-03 13:32:05 EDT
I believe it's the Debian maintainer who keeps porting ash from NetBSD.
I could find version 0.3.7:
ftp://ftp.debian.org/debian/dists/woody/main/source/shells/ash_0.3.7.orig.tar.gz

By the way, there are other critical bugs. Consider this program:

# !/bin/ash
(`exit 1`; echo "I'm alive")
false || foo=bar || echo "Still false!"
echo ${FOO=`echo BAR`}

ash-0.2:
Still false!
Segmentation fault

ash-0.3.7 and bash-2.0.4:
I'm alive
BAR

All three bugs demonstrated here prompted fixes in Autoconf. But not every program can be made so careful about those bugs!
"configure" in Automake-1.4-based projects will fail to find file "missing" when run under ash-0.2
Comment 2 Bill Nottingham 2000-10-04 11:36:25 EDT
*** Bug 16087 has been marked as a duplicate of this bug. ***
Comment 3 Preston Brown 2001-01-08 15:59:54 EST
rawhide now contains  (or will shortly) ash 0.3.7; as a bonus a newer pmake was
ported so that it could be compiled.

Note You need to log in before you can comment on or make changes to this bug.