Bug 16087 - ash is buggy
Summary: ash is buggy
Status: CLOSED DUPLICATE of bug 15957
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ash   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-13 01:13 UTC by juhtolv
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 18:28:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description juhtolv 2000-08-13 01:13:19 UTC
Today I realised, that ash of Red Hat Linux SuX0r more than I could expect: 

This works fine in my Debian GNU/Linux 2.2 (Potato): 

#!/bin/ash

BEATHOUR=$(date -u +%H)

BEATHOUR=$(( ${BEATHOUR} + 1 ))


But In Red Hat Linux 6.2 I needed to hack it like this: 


#!/bin/ash

BEATHOUR=$(date -u +%k | sed 's/\ //')

if test "${BEATHOUR}" = "0"
then
 BEATHOUR=1
else
 BEATHOUR=$((${BEATHOUR}+1))
fi

Comment 1 Pavel Roskin 2000-10-03 18:28:28 UTC
"ash" is buggy because it's obsolete.
The above script works perfectly with ash-0.3.7
This bug is a DUPLICATE of the bug 15957:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=15957
Please mark it as such.


Comment 2 Bill Nottingham 2000-10-04 15:36:27 UTC

*** This bug has been marked as a duplicate of 15957 ***


Note You need to log in before you can comment on or make changes to this bug.