Bug 1596377 - [RFE] When deleting a provider with associated Migration Plan or Infrastructure mapping, the plan and mappings should also be deleted
Summary: [RFE] When deleting a provider with associated Migration Plan or Infrastructu...
Keywords:
Status: CLOSED DUPLICATE of bug 1612154
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.9.4
Assignee: Brett Thurber
QA Contact: Kedar Kulkarni
URL:
Whiteboard: v2v
: 1596374 (view as bug list)
Depends On:
Blocks: 1598476 1601090
TreeView+ depends on / blocked
 
Reported: 2018-06-28 17:56 UTC by Kedar Kulkarni
Modified: 2018-08-08 14:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1598476 (view as bug list)
Environment:
Last Closed: 2018-08-08 14:34:28 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
kkulkarn: automate_bug+


Attachments (Terms of Use)

Description Kedar Kulkarni 2018-06-28 17:56:34 UTC
Description of problem:
Infra Mappings and Migration Plans should be deleted if any of the associated provider(RHV or VMware) is deleted, because 
1)if you delete a provider and add it back, the mappings and plans associated with it previously may not work. 
2)if there is no provider, then migration is not possible



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dave Johnson 2018-06-28 18:02:15 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Sudhir Mallamprabhakara 2018-07-03 19:45:55 UTC
*** Bug 1596374 has been marked as a duplicate of this bug. ***

Comment 5 Sudhir Mallamprabhakara 2018-08-08 14:34:28 UTC

*** This bug has been marked as a duplicate of bug 1612154 ***


Note You need to log in before you can comment on or make changes to this bug.