Bug 1596858 - Non-clustered ESX hosts, no longer appear in host creation
Summary: Non-clustered ESX hosts, no longer appear in host creation
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources - VMWare   
(Show other bugs)
Version: 6.3.1
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Perry Gagne
URL: https://projects.theforeman.org/issue...
Whiteboard:
Keywords: Regression, Triaged, UserExperience
: 1142878 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-29 19:53 UTC by Chris Roberts
Modified: 2019-04-01 20:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-16 19:32:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 23580 None None None 2018-06-29 19:53 UTC

Description Chris Roberts 2018-06-29 19:53:33 UTC
We are seeing a new issue with Foreman 1.17 and ESX 6.5, that previously worked on Foreman 1.16.

ESX hosts that are non clustered, no longer show up as an option in the Virtual Machine tab. It used to be that you could choose any host within an ESX DataCenter, regardless if it was part of a cluster or not. 
We have numerous vcenters, many with dozens of hosts that are non-clustered.

It would be nice if the previous methodology worked, as it supported both clustered and non-clustered ESX hosts.

Comment 1 Chris Roberts 2018-06-29 19:54:47 UTC
https://github.com/fog/fog-vsphere/pull/149

Comment 7 Perry Gagne 2018-09-21 18:01:44 UTC
Verified fix in Sat 6.4 snap 22 

Was able to create a vm with a VMware hypervisor, that was not part of a cluster.

Comment 8 Chris Roberts 2018-09-24 15:10:23 UTC
*** Bug 1142878 has been marked as a duplicate of this bug. ***

Comment 9 Bryan Kearney 2018-10-16 19:32:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:2927


Note You need to log in before you can comment on or make changes to this bug.