Bug 1597425 - RHCS 3 - Ceph Luminous - PG's stuck activating
Summary: RHCS 3 - Ceph Luminous - PG's stuck activating
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 3.0
Hardware: x86_64
OS: Linux
low
high
Target Milestone: z1
: 3.1
Assignee: Josh Durgin
QA Contact: ceph-qe-bugs
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1584264 1633426
TreeView+ depends on / blocked
 
Reported: 2018-07-02 22:27 UTC by Vikhyat Umrao
Modified: 2018-11-09 01:00 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-12.2.5-46.el7cp Ubuntu: ceph_12.2.5-31redhat1
Doc Type: Bug Fix
Doc Text:
.The default limit on PGs per OSD has been increased In some situations, such as widely varying disk sizes, the default limit on placement groups (PGs) per OSD could prevent PGs from becoming active. These limits have been increased by default to make this scenario less likely.
Clone Of:
: 1633426 (view as bug list)
Environment:
Last Closed: 2018-11-09 00:59:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 24356 None None None 2018-07-04 00:32:49 UTC
Github ceph ceph pull 22592 'None' 'closed' 'luminous: osd: increase default hard pg limit' 2019-11-28 02:11:14 UTC
Github ceph ceph pull 23862 'None' 'closed' 'luminous: core: osd,mon: increase mon_max_pg_per_osd to 250' 2019-11-28 02:11:14 UTC
Red Hat Knowledge Base (Solution) 3526531 None None None 2018-07-11 00:00:54 UTC
Red Hat Product Errata RHBA-2018:3530 None None None 2018-11-09 01:00:30 UTC

Description Vikhyat Umrao 2018-07-02 22:27:46 UTC
Description of problem:
Changing replication size to 3 to one of the pool causing this pool's pgs to stuck activating

Version-Release number of selected component (if applicable):
Red Hat Ceph Storage 3.0.z3
ceph-osd-12.2.4-10.el7cp.x86_64

How reproducible:
Always reproducible in the customer environment.

Comment 23 errata-xmlrpc 2018-11-09 00:59:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3530


Note You need to log in before you can comment on or make changes to this bug.