Bug 1597568 - Mark brick online after port registration even for brick-mux cases
Summary: Mark brick online after port registration even for brick-mux cases
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1598356
TreeView+ depends on / blocked
 
Reported: 2018-07-03 08:51 UTC by Pranith Kumar K
Modified: 2018-10-23 15:12 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:12:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2018-07-03 08:51:28 UTC
Description of problem:
    glusterd: show brick online after port registration even in brick-mux
    
    Problem:
    With brick-mux even before brick attach is complete on the bricks
    glusterd marks them as online. This can lead to a race where
    scripts that check if the bricks are online to assume that the
    brick is online before it is completely online.
    
    Fix:
    Wait for the callback from the brick before marking the port
    as registered so that volume status will show the correct status
    of the brick.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-07-03 09:02:31 UTC
REVIEW: https://review.gluster.org/20451 (glusterd: show brick online after port registration even in brick-mux) posted (#1) for review on master by Pranith Kumar Karampuri

Comment 2 Worker Ant 2018-07-05 07:56:41 UTC
COMMIT: https://review.gluster.org/20451 committed in master by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- glusterd: show brick online after port registration even in brick-mux

Problem:
With brick-mux even before brick attach is complete on the bricks
glusterd marks them as online. This can lead to a race where
scripts that check if the bricks are online to assume that the
brick is online before it is completely online.

Fix:
Wait for the callback from the brick before marking the port
as registered so that volume status will show the correct status
of the brick.

fixes bz#1597568
Change-Id: Icd3dc62506af0cf75195e96746695db823312051
Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:12:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.