Bug 1598055 - new version of libidn want to remove AdobeReader_enu
Summary: new version of libidn want to remove AdobeReader_enu
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libidn
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1646699 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-04 08:52 UTC by Zdenek Kabelac
Modified: 2018-11-19 21:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 21:55:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Zdenek Kabelac 2018-07-04 08:52:34 UTC
Description of problem:

New libidn package  1.35-2.fc29 - seem to be causing problems with
my installed AdobeReader_enu.

If the library is meant to be compatible (which I'd expect from just 'minor' library version change) it should provide all symbols needed.

If the library becomes incompatible - major version should change.

# dnf upgrade --best --allowerasing libidn

==========================================================================================================================================
 Package                                      Arch                     Version                           Repository                  Size
==========================================================================================================================================
Upgrading:
 ghostscript                                  x86_64                   9.23-4.fc29                       rawhide                     77 k
 ghostscript-core                             x86_64                   9.23-4.fc29                       rawhide                     49 k
 ghostscript-tools-fonts                      x86_64                   9.23-4.fc29                       rawhide                     53 k
 ghostscript-tools-printing                   x86_64                   9.23-4.fc29                       rawhide                     53 k
 ghostscript-x11                              x86_64                   9.23-4.fc29                       rawhide                     77 k
 hesiod                                       x86_64                   3.2.1-12.fc29                     rawhide                     34 k
 libgs                                        x86_64                   9.23-4.fc29                       rawhide                    3.0 M
 libidn                                       i686                     1.35-2.fc29                       rawhide                    240 k
 libidn                                       x86_64                   1.35-2.fc29                       rawhide                    239 k
 libidn-devel                                 x86_64                   1.35-2.fc29                       rawhide                    135 k
 libpurple                                    x86_64                   2.13.0-2.fc29                     rawhide                    5.3 M
 loudmouth                                    x86_64                   1.5.3-5.fc29                      rawhide                     77 k
 pidgin                                       x86_64                   2.13.0-2.fc29                     rawhide                    1.5 M
Removing dependent packages:
 AdobeReader_enu                              i486                     9.5.5-1                           @System                    135 M
 tgif                                         x86_64                   4.2.5-15.fc28                     @rawhide                   3.5 M


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Miroslav Lichvar 2018-07-04 09:01:59 UTC
There was an ABI break in libidn-1.34/1.35, so the soname of the library has changed. Ideally, the application should be rebuilt against the new version. If it doesn't use the stringprep features of libidn, a symlink pointing to the new version could work.

Comment 2 Zdenek Kabelac 2018-07-04 09:06:48 UTC
Acrobat can't be recompiled - there are no sources and there will be no new version available.

Libraries can't just randomly change their ABI and pretend they are same libraries - clearly the main point of library upgrade is - to preserve ABI and fix bugs.

So if there is unavoidable change for new library user - you can still use symbol versioning. But this also means - library has to provide  compatible function for older compiled binaries.

Also there is NO 100% replacement for Adobe Acrobat on linux - so IMHO worth to keep it installable.

Comment 3 Jan Kurik 2018-08-14 09:55:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 4 Miroslav Lichvar 2018-11-05 12:45:29 UTC
*** Bug 1646343 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Lichvar 2018-11-06 08:42:18 UTC
*** Bug 1646699 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2018-11-19 11:19:11 UTC
libidn1.34-1.34-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-fd7095527b

Comment 7 Fedora Update System 2018-11-19 21:55:36 UTC
libidn1.34-1.34-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.