Bug 1646343 - nothing provides libidn.so.11()(64bit) needed by google-musicmanager-beta-1.0.467.4929-0.x86_64
Summary: nothing provides libidn.so.11()(64bit) needed by google-musicmanager-beta-1.0...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libidn
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-05 12:26 UTC by Shakib
Modified: 2018-11-21 15:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-05 12:45:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Shakib 2018-11-05 12:26:26 UTC
Description of problem:
Can not install Google Music Manager in Fedora 29 Workstation. (Works fine in Fedora 28 Workstation)
When I am trying to install google-musicmanager-beta_current_x86_64.rpm from command line, is says - 

Problem: conflicting requests
  - nothing provides libidn.so.11()(64bit) needed by google-musicmanager-beta-1.0.467.4929-0.x86_64



Version-Release number of selected component (if applicable):
[INFO OF libidn]
Name         : libidn
Version      : 1.35
Release      : 3.fc29
Arch         : x86_64
Size         : 699 k
Source       : libidn-1.35-3.fc29.src.rpm
Repo         : @System


[INFO OF Google Music Manager]
Name         : google-musicmanager-beta
Version      : 1.0.467.4929


Steps to Reproduce:
[1] Download google-musicmanager-beta_current_x86_64.rpm from https://dl.google.com/linux/direct/google-musicmanager-beta_current_x86_64.rpm
[2] Now, try to install with sudo dnf install ./google-musicmanager-beta_current_x86_64.rpm


Actual results:
sudo dnf install ./google-musicmanager-beta_current_x86_64.rpm
Last metadata expiration check: 0:07:07 ago on Mon 05 Nov 2018 06:15:42 PM +06.
Error: 
 Problem: conflicting requests
  - nothing provides libidn.so.11()(64bit) needed by google-musicmanager-beta-1.0.467.4929-0.x86_64


Expected results:
Google Music Manager installing successfully.

Additional info:
[1] uname -a
Linux bellatrix 4.18.16-300.fc29.x86_64 #1 SMP Sat Oct 20 23:24:08 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

[2] sudo updatedb
[3] locate libidn
/usr/lib64/libidn.so.12
/usr/lib64/libidn.so.12.6.0
/usr/lib64/libidn2.so.0
/usr/lib64/libidn2.so.0.3.4

Comment 1 Miroslav Lichvar 2018-11-05 12:45:29 UTC
This seems to be similar to bug #1598055, where a different proprietary software is built against an older version of libidn.

A symlink libidn.so.11 -> libidn.so.12 might be a workaround if the binary doesn't use a stringprep symbol.

*** This bug has been marked as a duplicate of bug 1598055 ***

Comment 2 Fedora Update System 2018-11-19 11:21:31 UTC
libidn1.34-1.34-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-fd7095527b

Comment 3 Fedora Update System 2018-11-19 21:55:41 UTC
libidn1.34-1.34-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Shakib 2018-11-21 15:10:04 UTC
Problem solved!


Note You need to log in before you can comment on or make changes to this bug.