Bug 1598210 - Backport some features to 2.8 in RHEL 7.5 [rhel-7.5.z]
Summary: Backport some features to 2.8 in RHEL 7.5 [rhel-7.5.z]
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-guest-agent
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Wainer dos Santos Moschetta
QA Contact: FuXiangChun
URL:
Whiteboard:
Keywords: FutureFeature, Rebase, ZStream
Depends On: 1569013
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-04 16:37 UTC by Oneata Mircea Teodor
Modified: 2018-09-04 13:52 UTC (History)
14 users (show)

(edit)
To maintain qemu-guest-agents compatibility with the latest version of VDSM, a number of features have been backported from the most recent upstream version. These include the addition of qemu-get-host-name, qemu-get-users, qemu-get-osinfo, and qemu-get-timezone commands.
Clone Of: 1569013
(edit)
Last Closed: 2018-08-16 14:20:44 UTC


Attachments (Terms of Use)
automation result (6.73 KB, text/plain)
2018-07-27 07:57 UTC, FuXiangChun
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2460 None None None 2018-08-16 14:20 UTC

Description Oneata Mircea Teodor 2018-07-04 16:37:44 UTC
This bug has been copied from bug #1569013 and has been proposed to be backported to 7.5 z-stream (EUS).

Comment 3 Wainer dos Santos Moschetta 2018-07-13 19:08:04 UTC
This bug has been addressed by Miroslav Rezanina <mrezanin@redhat.com>, with the following series:
[RHEL-7.5.z qemu-guest-agent PATCH 0/7] Add querry commands necessary for vdsm

Comment 4 Wainer dos Santos Moschetta 2018-07-17 20:58:35 UTC
Fix in qemu-guest-agent-2.8.0-2.el7_5.1

Comment 6 Tomáš Golembiovský 2018-07-26 07:33:43 UTC
I suggest you remove the mention of utmpx.h from the doc_text.

Comment 7 FuXiangChun 2018-07-27 07:56:13 UTC
Verified bug with qemu-guest-agent-2.8.0-2.el7_5.1.

1)qemu-guest-agent test run
https://polarion.engineering.redhat.com/polarion/#/project/RedHatEnterpriseLinux7/testrun?id=virtqe-qemu-guest-agent-RHEL7-5-z%20-%20qemu-guest-agent-RHEL7-5-z%20guest

no found regression and blocker bug.

2) new agent command work.

{"execute": "guest-get-osinfo"}
{"return": {"name": "Red Hat Enterprise Linux Server", "kernel-release": "3.10.0-862.el7.x86_64", "version": "7.5 (Maipo)", "variant": "Server", "pretty-name": "Red Hat Enterprise Linux Server 7.5 (Maipo)", "version-id": "7.5", "variant-id": "server", "kernel-version": "#1 SMP Wed Mar 21 18:14:51 EDT 2018", "machine": "x86_64", "id": "rhel"}}

{"execute": "guest-get-host-name"}
{"return": {"host-name": "vm-74-10.lab.eng.pek2.redhat.com"}}

{"execute": "guest-get-users"}
{"return": []}

{"execute": "guest-get-timezone"}
{"return": {"zone": "CST", "offset": 28800}}

3. automation test pass.  Result is in attachment.

Comment 8 FuXiangChun 2018-07-27 07:57 UTC
Created attachment 1471006 [details]
automation result

Comment 9 FuXiangChun 2018-07-27 07:57:55 UTC
Base on comment7 and comment8, set this bug as verified.

Comment 11 errata-xmlrpc 2018-08-16 14:20:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2460


Note You need to log in before you can comment on or make changes to this bug.