Bug 15985 - Netscape crashes on double-clicking name from address book
Netscape crashes on double-clicking name from address book
Status: CLOSED DUPLICATE of bug 10433
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-11 09:50 EDT by James Slater
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-11 10:07:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Slater 2000-08-11 09:50:00 EDT
This happens in both netscape 4.7.4 and 4.7.2. Installed rather than
upgraded to 7.0 beta. Imported an address book previously created on redhat
6.0. Import works fine. However, name recognition doesn't work when an
email address is typed in the To: field and, opening up the address book &
double clicking kills the app. strace shows:

2928  gettimeofday({966001144, 472011}, NULL) = 0
2928  gettimeofday({966001144, 472115}, NULL) = 0
2928  rt_sigprocmask(SIG_BLOCK, NULL, [], 8) = 0
2928  gettimeofday({966001144, 472352}, NULL) = 0
2928  rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
2928  gettimeofday({966001144, 472596}, NULL) = 0
2928  ioctl(8, FIONREAD, [64])          = 0
2928  read(8,
"\f\3676|`\r\0\2\0\0\10\0D\0*\0\0\0\0\0*\0D\0\230\367\377"..., 64) = 64
2928  write(8,
"8\1\4\0P\r\0\2\4\0\0\0\377\377\377\0F\0\5\0N\r\0\2P\r\0"..., 532) = 532
2928  --- SIGSEGV (Segmentation fault) ---
2928  getpid()                          = 2928
2928  kill(2928, SIGBUS)                = 0
2928  --- SIGBUS (Bus error) ---
Comment 1 Bill Nottingham 2000-08-11 09:56:55 EDT
What does 'grep locale ~/.netscape/*.js' say?
Comment 2 James Slater 2000-08-11 10:01:13 EDT
.netscape/liprefs.js:user_pref("ldap_2.servers.pab.locale", "en_US");
.netscape/preferences.js:user_pref("ldap_2.servers.pab.locale", "en_US");
Comment 3 Bill Nottingham 2000-08-11 10:07:03 EDT
Remove those lines; they were added by a previous (4.7, IIRC)
buggy netscape.

*** This bug has been marked as a duplicate of 10433 ***
Comment 4 James Slater 2000-08-11 10:13:51 EDT
Copied back *.js files from backup, no more crashes.

Cheers,

James.

Note You need to log in before you can comment on or make changes to this bug.