Bug 10433 - communicator 4.72 address book does not work
communicator 4.72 address book does not work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
: 10890 11575 13017 13183 14508 14950 15985 16923 18732 19197 19406 20782 21228 22996 25167 29488 36984 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-30 04:32 EST by Kai Kumpf
Modified: 2014-03-16 22:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 14:12:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Kumpf 2000-03-30 04:32:55 EST
When upgrading from communicator 4.61, the address book of 4.72 does not
allow any of the following with most address cards:
-deletion
-editing property window
-automatic name completion when composing a new message

In addition, group names don't show any more.
Even exporting from 4.61 into an *ldif file and subsequent importing into
4.72 does not help.
Comment 1 Bill Nottingham 2000-03-30 12:04:59 EST
I can't reproduce this here; all three items work for me
with the netscape-4.72-6 package.

Is it causing netscape to crash, or are you noticing
other failures?
Comment 2 John McBride 2000-04-05 21:52:59 EDT
same thing on this end. the ldif import "looks" okay, but right clicking on an
entry and "delete"-ing it often doesn't work

even worse, when composing a new email, it used to auto-complete the email
address from the address book really well, now it says things like:

Joe Blow@<multiple matches found>

...when there is only one "Joe Blow".

4.61 worked fine. i can't even send email through this thing. i tried it on two
RH6.2 machines, same problem.

---
John
Comment 3 Anonymous 2000-04-11 23:27:59 EDT
I am also having the same problem, and can duplicate all the symptoms.  I've
also tried remove the addressbook file then re-import the ldif file but to no
avail.  I can provide system details as needed (it's a recently upgraded 6.2
system).
Comment 4 cnhr 2000-04-15 13:29:59 EDT
Again same thing here. I've had real fun on this one. I've tried the original
source from Netscape (e.g. the .tar.gz file from netscape.com etc.) and I get
the same thing:
1) No auto-completion of names
2) I can not delete any of the names from the address book
3) Groups do not show.

I've also tried going back to 4.61 & 4.7, same problem again. Exporting to .ldif
and then re-importing has no affect whatsoever. I seem to recall that the
address book worked fine under RedHat 6.0 & 6.1. Could it be a problem with the
libraries in 6.2 e.g. glibc?
Comment 5 cnhr 2000-04-15 13:35:59 EDT
Oops forgot one other thing. If you click on "New Message" -> "Select Adresses"
and then try to view the properties of someone, Netscape crashes with a "Bus
error". Sometimes the address book does not allow you to view the properties
anyway. I hope this helps.
Comment 6 Bill Nottingham 2000-04-18 12:22:59 EDT
Can you post a (moderately small) .ldif file that shows
the problem?  I can't reproduce problems with the address
book here.

Also, are these upgrades or fresh installs?
Comment 7 Emmanuel Druon 2000-04-19 07:08:59 EDT
Same symptoms here.

I've tried this with two machines.

Installed  a new version of the system and tried to import previous abook.nab
(from 6.1) from users' backup.

The mailing list are srewed up. I can edit some entries but can't others. Some
can be used with New message others can't. Some changes generate a bus error.
Comment 8 cnhr 2000-04-19 08:46:59 EDT
I am using a fresh install of RedHat 6.2, not an upgrade.
Comment 9 Bill Nottingham 2000-04-19 11:21:59 EDT
Hm... what locale are you running under?

What does 'grep locale' $HOME/.netscape/*.js' say?

Again, do you have a small addressbook (.ldif) file you can
post that reproduces this, because we can't reproduce this here.
Comment 10 Bill Nottingham 2000-04-19 11:25:59 EDT
*** Bug 10890 has been marked as a duplicate of this bug. ***
Comment 11 cnhr 2000-04-19 11:52:59 EDT
I think the exported .ldif file is alright, possibly the pab.na2 file gets
corrupted.
Comment 12 Bill Nottingham 2000-04-19 14:15:59 EDT
(to recap part of an off-line discussion)

> grep locale $HOME/.netscape/*.js says:
>
> /home/cnhr/.netscape/liprefs.js:user_pref("ldap_2.servers.pab.locale",
"en_US");
> /home/cnhr/.netscape/preferences.js:user_pref("ldap_2.servers.pab.locale",
"en_US");

Close all netscape windows, and remove these lines from those files; that
should solve the problem in this case.
Comment 13 Emmanuel Druon 2000-04-20 05:05:59 EDT
It seems to improve things a lot (no more crashes so far and editing & sending
features).

However, when a given person was in multiple mailing lists (in the imported
address book), the entry is duplicated in the main address book.
Comment 14 John McBride 2000-04-21 02:51:59 EDT
Deleting the "locales" from the .js files appears to have stopped the crashing
here. I can delete addresses and pass them into and out of the Messenger client.

The two machines I tried were fresh installs. I notice that "locale" entries get
inserted into the .js files the first time the address book is launched; not by
the import.

Still get the annoying "<Multiple Matches Found>" when I try to auto-complete
email addresses, even though there is but a single matching address.

Also, note that SUSEs lastest release (6.4) already has a fat patch/update for
Netscape 4.72 due to a compiler issue.
Comment 15 Anonymous 2000-04-21 12:14:59 EDT
Removing the entries are only a temporary solution.
I am having the same problem again.
Netscape keeps putting the entry back in.

"Netscape User Preferences.
This is a generated file! Do not edit."

The files .netscape/liprefs.js and .netscape/preferences.js keep getting
regenerated by Netscape.
It keeps readding the entry: user_pref("ldap_2.servers.pab.locale","en_US").

How do I prevent Netscape from readding this entry????
Comment 16 Bill Nottingham 2000-04-21 15:13:59 EDT
Netscape 4.72 shouldn't put those entries back. Are you sure that:
a) all netscape windows are closed when you edit the files
b) you are running netscape 4.72, and not an earlier version?
Comment 17 Anonymous 2000-04-22 13:23:59 EDT
Positive on both counts.

Once I added a new entry to my address book, it cleared up the problem.

Thank you.
Comment 18 Piet E Barber 2000-04-23 19:45:59 EDT
(to recap part of an off-line discussion)

>> grep locale $HOME/.netscape/*.js says:
>>
>> /home/cnhr/.netscape/liprefs.js:user_pref("ldap_2.servers.pab.locale",
>> "en_US");
>> /home/cnhr/.netscape/preferences.js:user_pref("ldap_2.servers.pab.locale",
>> "en_US");

> Close all netscape windows, and remove these lines from those files; that
> should solve the problem in this case.

I experienced this bug, exactly as described by jmcbride, I followed the
recommendations from notting@redhat.com, and the problem is gone.

I would call this a good workaround.
Comment 19 Rex Dieter 2000-05-12 14:09:59 EDT
I can further verify that removing all pab.locale entries from ~/.netscape/*.js
files works, but also replacing en_US with en works too.

As previously noted, netscape must not be running when you edit the *.js files.
Comment 20 Bill Nottingham 2000-05-22 14:12:59 EDT
*** Bug 11575 has been marked as a duplicate of this bug. ***I'm resolving this bug; it's not something we can
intrinsically 'fix' in netscape, and removing the
locale settings does solve the problem.
Comment 21 Bill Nottingham 2000-06-26 13:51:20 EDT
*** Bug 13017 has been marked as a duplicate of this bug. ***
Comment 22 Bill Nottingham 2000-06-28 12:38:50 EDT
*** Bug 13183 has been marked as a duplicate of this bug. ***
Comment 23 sbh1 2000-07-10 17:28:37 EDT
I had the same fault with 6.2 and Netscape 4.73 (freshly installed). Tried
deleting the two lines as instructed. Result was that Netscape crashed whenever
I attempted to open the address book. Then tried deleting $HOME/.netscape to get
a fresh start. Opened address book, but entered nothing. Closed Netscape and
edited the two lines, this time only replacing "en_US" with "en" as suggested
by  rdieter@math.unl.edu .  This worked.
Comment 24 Bill Nottingham 2000-07-24 12:28:55 EDT
*** Bug 14508 has been marked as a duplicate of this bug. ***
Comment 25 Bill Nottingham 2000-08-07 00:00:15 EDT
*** Bug 14950 has been marked as a duplicate of this bug. ***
Comment 26 Bill Nottingham 2000-08-11 10:07:00 EDT
*** Bug 15985 has been marked as a duplicate of this bug. ***
Comment 27 Bill Nottingham 2000-08-30 15:58:13 EDT
*** Bug 16923 has been marked as a duplicate of this bug. ***
Comment 28 Bill Nottingham 2000-10-16 12:50:17 EDT
*** Bug 18732 has been marked as a duplicate of this bug. ***
Comment 29 Bill Nottingham 2000-10-18 02:34:58 EDT
*** Bug 19197 has been marked as a duplicate of this bug. ***
Comment 30 Bill Nottingham 2000-10-19 19:56:16 EDT
*** Bug 19406 has been marked as a duplicate of this bug. ***
Comment 31 Bill Nottingham 2000-11-13 15:07:18 EST
*** Bug 20782 has been marked as a duplicate of this bug. ***
Comment 32 Bill Nottingham 2000-11-22 16:11:55 EST
*** Bug 21228 has been marked as a duplicate of this bug. ***
Comment 33 Bill Nottingham 2000-12-29 16:42:40 EST
*** Bug 22996 has been marked as a duplicate of this bug. ***
Comment 34 Bill Nottingham 2001-01-07 12:51:32 EST
*** Bug 23538 has been marked as a duplicate of this bug. ***
Comment 35 Bryce Nesbitt 2001-01-07 21:46:23 EST
Just deleting the lines, as notting@redhat.com suggests won't do it.  Netscape
rewrites them (at least 4.76 does).

To "fix" this bug, edit all *.js lines in your .netscape directory, changing the
locale from en_US to en:

< user_pref("ldap_2.servers.pab.locale", "en_US");
> user_pref("ldap_2.servers.pab.locale", "en");

< user_pref("ldap_2.servers.pab.locale", "en_US");
> user_pref("ldap_2.servers.pab.locale", "en");

As a packager, redhat should certainly be doing this for us poor user slobs who
just want a stable machine.
Comment 36 Bryce Nesbitt 2001-01-08 11:35:30 EST
Note that in contrast to previous reports, this happens with a fresh install
also.  Blow away the complete .netscape directory, and netscape creates a new
one with the bug present (As of netscape 4.76).  Delete the locale lines (if
that works for you) or change the locale to "en" from "en_US".
Comment 37 John J. Germs 2001-01-11 21:01:15 EST
I changed the "en_US" to "C" and everything has been fine. I guess I assumed the
problem was being Canadian .....hehe.

...G...
Comment 38 Bill Nottingham 2001-01-28 22:13:05 EST
*** Bug 25167 has been marked as a duplicate of this bug. ***
Comment 39 Bill Nottingham 2001-02-25 19:14:38 EST
*** Bug 29488 has been marked as a duplicate of this bug. ***
Comment 40 Bill Nottingham 2001-04-21 16:06:27 EDT
*** Bug 36984 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.