Bug 1598922 - memtest86+ restarts after a few seconds on some machines (affects F28 and later)
Summary: memtest86+ restarts after a few seconds on some machines (affects F28 and later)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: memtest86+
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1661844 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-06 21:03 UTC by sotnikov123
Modified: 2019-02-16 01:24 UTC (History)
10 users (show)

Fixed In Version: memtest86+-5.01-24.fc29 memtest86+-5.01-24.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-16 01:24:26 UTC


Attachments (Terms of Use)
hardware (149.62 KB, image/jpeg)
2018-07-06 21:03 UTC, sotnikov123
no flags Details

Description sotnikov123 2018-07-06 21:03:02 UTC
Created attachment 1457090 [details]
hardware

Description of problem:
memtest86+ is not work from live DVD


Version-Release number of selected component (if applicable):
RFRemix-Workstation-Live-x86_64-28-1.3.iso


How reproducible:
Start memtest from live DVD
Troubleshooting > Run a memory test


Steps to Reproduce:
1. Start from live DVD
2. Select Troubleshooting
3. Select Run a memory test

Actual results:
System going to reboot after few seconds


Expected results:
Running test


Additional info:
See working test from http://www.memtest.org foto

Comment 1 sotnikov123 2018-07-06 21:08:10 UTC
Sorry. Of cource
Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-28-1.1.iso

Comment 2 Vitaly Zaitsev 2018-07-06 21:09:53 UTC
I can confirm this issue. Same problem on my Intel 8th-gen CPU.

Comment 3 cornel panceac 2018-07-31 14:55:38 UTC
This happens on an installed system also:

memtest86+-5.01-20.fc28.x86_64

Intel(R) Core(TM) i3-4130 CPU @ 3.40GHz

8GB of RAM

4.17.9-200.fc28.x86_64

Is launched from GRUB. 
Microsoft Windows Memory Diagnostics founds no problem.

Comment 4 Andre Robatino 2018-10-24 07:31:01 UTC
Me too. Runs fine on two of my F28 machines, reboots after a few seconds on the third. Don't know how long the problem has existed since this is the first time I attempted to run memtest for more than a few seconds since installing F28. There were no errors on one pass on the same machine about 6 months ago (running the F27 version).

memtest86+-5.01-20.fc28.x86_64

Intel® Core™2 Duo CPU E8400 @ 3.00GHz × 2

16 GiB RAM

Comment 5 Andre Robatino 2018-10-24 09:09:46 UTC
On the same machine, works from the F27 Live image, broken in the F28 Live image.

Comment 6 Andre Robatino 2018-10-24 21:08:39 UTC
The problem still exists with Fedora-Workstation-netinst-x86_64-29-20181024.n.0.iso, so F29 will be affected as well.

Comment 7 Andre Robatino 2018-10-27 18:31:12 UTC
Confirmed that it affects F29 RC 1.2 (Final Gold). From comments 3 and 4, it looks like this may mostly affect 64-bit Intel CPUs. I have two other machines, one a 64-bit Athlon, and the other an old 32-bit Intel Celeron, that aren't affected.

Comment 8 Jaroslav Škarvada 2019-01-30 10:07:42 UTC
Thanks for info, unfortunately upstream is not much helpful with this kind of issues. I think it could be related to the new gcc - we have fixed several such issues in the past and each new gcc release comes with new surprises.

Please try the following testing build and let me know.
https://jskarvad.fedorapeople.org/memtest86+/memtest86+-5.01-22.fc29.x86_64.rpm

Comment 9 Andre Robatino 2019-01-30 17:47:25 UTC
(In reply to Jaroslav Škarvada from comment #8)

> Please try the following testing build and let me know.
> https://jskarvad.fedorapeople.org/memtest86+/memtest86+-5.01-22.fc29.x86_64.
> rpm

This build works properly without restarting (though I only tested it on the one machine where I had the problem before). What is the difference?

Comment 10 Jaroslav Škarvada 2019-01-30 17:57:15 UTC
(In reply to Andre Robatino from comment #9)
> (In reply to Jaroslav Škarvada from comment #8)
> 
> > Please try the following testing build and let me know.
> > https://jskarvad.fedorapeople.org/memtest86+/memtest86+-5.01-22.fc29.x86_64.
> > rpm
> 
> This build works properly without restarting (though I only tested it on the
> one machine where I had the problem before). What is the difference?

It's built with the gcc-34. Now the harder part - to find out what's causing the problem with the gcc-8.2.1. The --std=gnu89 doesn't seem to help. Could you try playing with the configuration (especially the 'c' key) whether enforcing specific test or limiting the tested memory, disabling SMP or failsafe mode helps?

Comment 11 Andre Robatino 2019-01-30 18:26:42 UTC
I'm not the best person to ask because I normally only use the defaults. I tried F1 (Failsafe) which didn't help (I had tried that before as well). The default is SMP disabled. I tried F2 to force multi-threading, which didn't help. When I forced a specific test (#6) it seemed to run okay for a while, but restarted eventually before the test was complete. I tried putting a lower limit on the tested memory (1M) and again it seemed to run longer but eventually restarted. Someone who is more familiar with the config menu might be able to find something that works.

Comment 12 Jaroslav Škarvada 2019-01-30 18:35:47 UTC
(In reply to Andre Robatino from comment #11)
> I'm not the best person to ask because I normally only use the defaults. I
> tried F1 (Failsafe) which didn't help (I had tried that before as well). The
> default is SMP disabled. I tried F2 to force multi-threading, which didn't
> help. When I forced a specific test (#6) it seemed to run okay for a while,
> but restarted eventually before the test was complete. I tried putting a
> lower limit on the tested memory (1M) and again it seemed to run longer but
> eventually restarted. Someone who is more familiar with the config menu
> might be able to find something that works.

Thanks for info. I will try to get one of the affected machines. But debugging of such problems can take very very long time. As a short term workaround I will probably switch to gcc34.

Comment 13 Andre Robatino 2019-01-30 21:01:26 UTC
From the comments, it looks like any 64-bit Intel Core machine would be likely to be affected. My two machines that aren't affected are an old 32-bit Intel Celeron and a 64-bit AMD. The original reporter didn't say what hardware they had (other than it being 64-bit).

Comment 14 Andre Robatino 2019-01-30 21:04:11 UTC
Actually, in the attachment the reporter did show their hardware (Intel Core 2 Duo E7500).

Comment 15 Jaroslav Škarvada 2019-02-05 14:35:40 UTC
*** Bug 1661844 has been marked as a duplicate of this bug. ***

Comment 16 Jaroslav Škarvada 2019-02-05 14:37:09 UTC
I temporally workaround this problem by switching to compat-gcc-34.

Comment 17 Fedora Update System 2019-02-05 14:55:01 UTC
memtest86+-5.01-24.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9540e5a8fc

Comment 18 Fedora Update System 2019-02-05 15:02:07 UTC
memtest86+-5.01-24.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-461428280e

Comment 19 Fedora Update System 2019-02-06 04:35:17 UTC
memtest86+-5.01-24.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9540e5a8fc

Comment 20 Fedora Update System 2019-02-08 02:15:29 UTC
memtest86+-5.01-24.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-461428280e

Comment 21 Fedora Update System 2019-02-09 02:13:29 UTC
memtest86+-5.01-24.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2019-02-16 01:24:26 UTC
memtest86+-5.01-24.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.