Bug 1661844 - Starting with memtest86+-5.01-19.fc28, hang while testing Lenovo T460p
Summary: Starting with memtest86+-5.01-19.fc28, hang while testing Lenovo T460p
Keywords:
Status: CLOSED DUPLICATE of bug 1598922
Alias: None
Product: Fedora
Classification: Fedora
Component: memtest86+
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-24 01:53 UTC by Denys Vlasenko
Modified: 2019-02-05 14:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-05 14:35:40 UTC


Attachments (Terms of Use)
The working binary (178.42 KB, application/octet-stream)
2018-12-24 01:55 UTC, Denys Vlasenko
no flags Details

Description Denys Vlasenko 2018-12-24 01:53:29 UTC
When you boot a "Live CD" image, in "Troubleshooting >" submenu there is an entry "Run a memory test". (Note: it will not appear if you boot in UEFI mode, boot in legacy BIOS mode to git it).

This option loads special tool. Its code resides in the file /isolinux/memtest in ISO image.

The problem is, this tool works in soem cases, but does not work on many machines (including Lenovo ThinkPad T460p, and my home machine): it either hangs or reboots very soon after starting the test.

The same situation was with Fedora 28 ISO image sometime ago, I assumed it had an old version of memtest, but apparently F29 is still affected.

I have another binary of the same size which DOES WORK in all those cases. I don't remember where I got it.

The versions of all three are reported to be the same: 5.01

My theory is that the Memtest86+ project had bug fix releases but did not bump the version up.

All versions of the file are 182704 bytes long.
Here are the md5sum's of these files:
40ac4378d22e586569bb6cdfc972d910  memtest86+-5.01.GOOD
eb876e54e676bb656e9b50e0d122fa12  memtest.BAD.f29iso (it's from memtest86+-5.01-22.fc29 pkg)
dba9634de855bbb1f2b80561615dacc9  memtest.BAD.f28iso (it's from memtest86+-5.01-19.fc28 pkg)

I examined a few recent memtest86+ packages in Koji and md5sum'med their /boot/memtest86+-5.01 files:
dba9634de855bbb1f2b80561615dacc9  memtest86+-5.01-19.fc28 - bad
dc5fd23361a6cc6750e7b43a15c3b419  memtest86+-5.01-20.fc28 - not tried
d0f80576d92621bd2ffd4ef63424e086  memtest86+-5.01-20.fc29 - not tried
eb876e54e676bb656e9b50e0d122fa12  memtest86+-5.01-22.fc29 - bad

Still no idea where did I get my "good" one.... I'm attaching it to this bz.

Comment 1 Denys Vlasenko 2018-12-24 01:55:46 UTC
Created attachment 1516470 [details]
The working binary

Comment 2 Denys Vlasenko 2018-12-28 14:23:33 UTC
I found where the working tool comes from - it's from F25.
Tested a few versions, here's what I found:

md5sum__________________________  _______________version_
40ac4378d22e586569bb6cdfc972d910  memtest86+-5.01-15.fc25 - works on Lenovo T460p
5bc4055964fcb4c9bbce66c8e181651f  memtest86+-5.01-16.fc26 - works on Lenovo T460p
dba9634de855bbb1f2b80561615dacc9  memtest86+-5.01-19.fc28 - hangs soon after test starts

From changelog (-17 and -18 versions do not exist as binaries, they failed to build in Koji):

* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.01-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.01-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.01-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild

* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.01-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

* Tue Apr 05 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 5.01-15
- Various improvements to memtest-setup, e.g. now exits with error if
  run by non root user

Comment 3 Jaroslav Škarvada 2019-01-02 10:25:56 UTC
Could you try:
https://koji.fedoraproject.org/koji/taskinfo?taskID=31769965

Comment 4 Denys Vlasenko 2019-01-03 09:43:35 UTC
> Could you try:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=31769965

Yes, it worked. Specifically, I booted the ELF version:

$ md5sum elf-memtest86+-5.01
e54426b5404c44458dc0e063d7be1354  elf-memtest86+-5.01

and it did not hang on T460p.

I also tried to build memtest86+ from Fedora's git via
"rpmbuildlocal -bc memtest86+.spec", and the resulting binary
does NOT work - hangs very soon in the first testing pass.

Comment 5 Jaroslav Škarvada 2019-01-03 10:56:18 UTC
(In reply to Denys Vlasenko from comment #4)
> > Could you try:
> > https://koji.fedoraproject.org/koji/taskinfo?taskID=31769965
> 
> Yes, it worked. Specifically, I booted the ELF version:
> 
> $ md5sum elf-memtest86+-5.01
> e54426b5404c44458dc0e063d7be1354  elf-memtest86+-5.01
> 
> and it did not hang on T460p.
> 
> I also tried to build memtest86+ from Fedora's git via
> "rpmbuildlocal -bc memtest86+.spec", and the resulting binary
> does NOT work - hangs very soon in the first testing pass.

Thanks for info. It seems the problem is new gcc and their still more and more strict interpretation of new C standards. We patched a lot related things in the memtest86+ in the past, but with every new gcc version there are more and more surprises. Unfortunately, memtest86+ upstream is not much helpful here. I will prepare another test build which could workaround the problem in short-term. For long-term solution I will have to dig more deep.

Comment 6 Jaroslav Škarvada 2019-01-03 11:24:49 UTC
Please try the following build and let me know:
https://koji.fedoraproject.org/koji/taskinfo?taskID=31789707

Comment 7 Denys Vlasenko 2019-01-15 10:33:03 UTC
(In reply to Jaroslav Škarvada from comment #6)
> Please try the following build and let me know:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=31789707

This one does NOT work - hangs or reboots (different behavior on two machines)

Comment 8 Jaroslav Škarvada 2019-01-16 14:32:24 UTC
(In reply to Denys Vlasenko from comment #7)
> (In reply to Jaroslav Škarvada from comment #6)
> > Please try the following build and let me know:
> > https://koji.fedoraproject.org/koji/taskinfo?taskID=31789707
> 
> This one does NOT work - hangs or reboots (different behavior on two
> machines)

Does it help to lower the upper memory limit to be tested? Hit 'c', then '2', '2', try e.g. 4000M, finally '0' to continue. This could help me diagnose the problem.

Comment 9 Jaroslav Škarvada 2019-02-05 14:35:40 UTC
I am closing this one as a dupe of bug 1598922 and I will try to temporally workaround this problem by switching to compat-gcc-34.

*** This bug has been marked as a duplicate of bug 1598922 ***


Note You need to log in before you can comment on or make changes to this bug.