Bug 1602944 - ZRAM support for ARM images
Summary: ZRAM support for ARM images
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact:
URL:
Whiteboard:
: 1602946 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-18 20:53 UTC by Ben Cotton
Modified: 2019-02-10 17:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-10 17:58:12 UTC
Type: ---


Attachments (Terms of Use)

Description Ben Cotton 2018-07-18 20:53:05 UTC
This is a tracking bug for Change: ZRAM support for ARM images
For more details, see: https://fedoraproject.org/wiki/Changes/ZRAMforARMimages

Enable ZRAM for swap on ARMv7 and aarch64 pre generated images to improve performance and reliability on ARM Single Board Computers such a the Raspberry Pi.

Comment 1 Ben Cotton 2018-07-18 20:56:12 UTC
*** Bug 1602946 has been marked as a duplicate of this bug. ***

Comment 2 Peter Robinson 2018-07-19 11:39:09 UTC
zram package review: https://bugzilla.redhat.com/show_bug.cgi?id=1602846

PR to enable zram in images: https://pagure.io/fedora-kickstarts/pull-request/409

Comment 3 Peter Robinson 2018-08-07 21:38:02 UTC
Enabled in all ARM/aarch64 images by default.

Comment 4 Jan Kurik 2018-08-14 11:16:34 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Ben Cotton 2018-08-23 20:13:05 UTC
Correcting the assignee

Comment 6 Ben Cotton 2018-08-28 13:54:11 UTC
Today is the '100% code complete deadline' Change Checkpoint[1], meaning that Fedora 29 Changes must now be code complete. All the code required to enable to the new change should now be finished. If your Change is code complete, please update the status of this tracker back to "ON_QA". The change does not have to be fully tested by this deadline.

We have now reached the Beta freeze. If your Change is not code complete, you need to request a Freeze Exception[2] or invoke the contingency plan.

[1] https://fedoraproject.org/wiki/Changes/Policy#Beta_deadline.2Faccepted_changes_100.25_complete

[2] https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

Comment 7 Peter Robinson 2018-08-28 13:56:25 UTC
Complete and has been in testing for some time


Note You need to log in before you can comment on or make changes to this bug.