Bug 160420 - X11 server (vesa) not working, was working on FC3 on the same machine
X11 server (vesa) not working, was working on FC3 on the same machine
Status: CLOSED DUPLICATE of bug 163331
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 160901 164975 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 19:52 EDT by dann
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-12 11:21:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvn (11.37 KB, text/plain)
2005-06-21 15:30 EDT, dann
no flags Details
xorg.conf (1.97 KB, text/plain)
2005-06-21 15:31 EDT, dann
no flags Details
Xorg.0.log (49.68 KB, text/plain)
2005-06-21 15:31 EDT, dann
no flags Details
xorg.conf that worked for FC3 on the same machine (2.81 KB, text/plain)
2005-06-21 17:42 EDT, dann
no flags Details
Xorg.0.log corresponding to xorg.conf from attachment #115782 (49.30 KB, text/plain)
2005-06-21 17:44 EDT, dann
no flags Details
spec file (188.04 KB, text/plain)
2005-07-14 11:14 EDT, Carlos Martín
no flags Details

  None (edit)
Description dann 2005-06-14 19:52:56 EDT
Description of problem:
I just installed FC4 on a Dell PowerEdge SC420 machine. 
It has an Intel Corporation E7221 Integrated Graphics Controller.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37

How reproducible:
Using "startx" to start X11 does not work, just a few pixels at the top of the
screen are colored blue and nothing else happens. 
After pressing C-A-Backspace a message is displayed:

(WW) VESA(0): Failed to set up write-combining range (0x26400000,0x7b0000)

Changing the display driver to "vga" makes the X server work, but the VGA
resolution is not that useful.

The machine worked just fine with FC3.
Comment 1 Mike A. Harris 2005-06-21 12:55:36 EDT
Attach your X server log and config file as individual uncompressed
file attachments to the report using the link below.  Also please
attach the output of "lspci -vvn"
Comment 2 Mike A. Harris 2005-06-21 14:01:13 EDT
> (WW) VESA(0): Failed to set up write-combining range (0x26400000,0x7b0000)

This message is a harmless warning.  Technically it shouldn't even be a warning,
but instead just an informational message.  It's been changed in CVS head
to do just that, as people often think this warning is a serious error of
some sort which is causing the problem they're experiencing, when it is
not a problem at all in general.

Hope this clarifies that one.
Comment 3 Mike A. Harris 2005-06-21 14:14:12 EDT
Here's another test which would be useful.  Please download libvgahw.a
from my ftp site:  ftp://people.redhat.com/mharris/libvgahw.a

Make a backup copy of /usr/X11R6/lib/modules/libvgahw.a on your system,
and then replace it with the one from the URL above.  Then try restarting
the X server to see if it works.  It might be a good idea to reboot the
system to reset the video hardware also.  Please indicate if this changes
anything or not.  If it doesn't change anything, restore the original
module back.

TIA
Comment 4 dann 2005-06-21 15:30:31 EDT
Created attachment 115774 [details]
lspci -vvn
Comment 5 dann 2005-06-21 15:31:18 EDT
Created attachment 115775 [details]
xorg.conf
Comment 6 dann 2005-06-21 15:31:56 EDT
Created attachment 115776 [details]
Xorg.0.log
Comment 7 dann 2005-06-21 15:33:08 EDT
(In reply to comment #1)
> Attach your X server log and config file as individual uncompressed
> file attachments to the report using the link below.  Also please
> attach the output of "lspci -vvn"

Done.
The xorg.conf file was created using 
X -configure
Comment 8 dann 2005-06-21 15:34:29 EDT
(In reply to comment #3)
> Here's another test which would be useful.  Please download libvgahw.a
> from my ftp site:  ftp://people.redhat.com/mharris/libvgahw.a
> 
> Make a backup copy of /usr/X11R6/lib/modules/libvgahw.a on your system,
> and then replace it with the one from the URL above.  Then try restarting
> the X server to see if it works.  It might be a good idea to reboot the
> system to reset the video hardware also.  Please indicate if this changes
> anything or not.  If it doesn't change anything, restore the original
> module back.

This did not change anything.

Comment 9 Mike A. Harris 2005-06-21 16:52:05 EDT
Please use "system-config-display --reconfig" exclusively to configure the
X server, as "X -configure" is very unreliable and often generates invalid
or suboptimal configurations.  Looking at your attached config file, it is
clear to me that X -configure has left out a number of important configuration
items.

After reconfiguring with our supported config tool as per above, please attach
the new config and log file, and retest the libvgahw.a change.

TIA
Comment 10 dann 2005-06-21 17:42:52 EDT
Created attachment 115782 [details]
xorg.conf that worked for FC3 on the same machine
Comment 11 dann 2005-06-21 17:44:25 EDT
Created attachment 115783 [details]
Xorg.0.log corresponding to xorg.conf from attachment #115782 [details]
Comment 12 dann 2005-06-21 17:46:17 EDT
(In reply to comment #9)
> Please use "system-config-display --reconfig" exclusively to configure the
> X server, as "X -configure" is very unreliable and often generates invalid
> or suboptimal configurations.  Looking at your attached config file, it is
> clear to me that X -configure has left out a number of important configuration
> items.

Sorry, I should have said that the reason I did not use system-config-display is
because it does not work. It starts a non-working X server, and it does not
write a new xorg.conf file....

I have tried again using the xorg.conf file that worked on the same machine with 
FC3. I attached the xorg.conf file and the X log file

> After reconfiguring with our supported config tool as per above, please attach
> the new config and log file, and retest the libvgahw.a change.

libvgahw.a does not seem to make a difference.

Please let me know if you want me to try something else.
Comment 13 Mike A. Harris 2005-06-22 16:51:30 EDT
(In reply to comment #12)
> (In reply to comment #9)
> > Please use "system-config-display --reconfig" exclusively to configure the
> > X server, as "X -configure" is very unreliable and often generates invalid
> > or suboptimal configurations.  Looking at your attached config file, it is
> > clear to me that X -configure has left out a number of important configuration
> > items.
> 
> Sorry, I should have said that the reason I did not use system-config-display is
> because it does not work. It starts a non-working X server, and it does not
> write a new xorg.conf file....

"system-config-display --reconfig" forces a reconfiguration of the X
server and a new config file to be written.  If this does not happen, please
file a bug report against system-config-display, as it is expected to
write out a config file.



> I have tried again using the xorg.conf file that worked on the same machine
> with FC3. I attached the xorg.conf file and the X log file

I've examined the new config file and log file. The config file looks
correct for using the vesa driver.  The log file is of the appearance
of an X server that has properly started.  There are no errors or warnings
in the log that indicate any problems.

There really isnt enough diagnostic information to go on so far, and this
hardware is currently not yet supported.
 

> > After reconfiguring with our supported config tool as per above, please
> > attach the new config and log file, and retest the libvgahw.a change.
> 
> libvgahw.a does not seem to make a difference.

That helps to eliminate that from the problem domain.

> Please let me know if you want me to try something else.

At this point, since the hardware is unsupported, I recommend filing a bug
report to X.Org directly, at http://bugs.freedesktop.org in the "xorg"
component.  The X developers responsible for Intel video support will then
be able to assess the issue, attempt to reproduce it on the same hardware,
and hopefully provide a solution we can use for the future.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO", awaiting X.Org bug URL for tracking.

Comment 14 dann 2005-06-23 15:20:34 EDT
(In reply to comment #13)
> (In reply to comment #12)
> > (In reply to comment #9)
> At this point, since the hardware is unsupported, I recommend filing a bug
> report to X.Org directly, at http://bugs.freedesktop.org in the "xorg"
> component.  The X developers responsible for Intel video support will then
> be able to assess the issue, attempt to reproduce it on the same hardware,
> and hopefully provide a solution we can use for the future.

There was a bug report at freedesktop.org that the i810 driver does not support 
the E7721 controller. Newer versions of the i810 driver sort of work: the X
server works, but when exiting the server the text console does not work
anymore, nothing is displayed.

See: https://bugs.freedesktop.org/show_bug.cgi?id=2585

Note that when the above freedesktop.org bug is fixed the machine will work
with the i810 driver, not the vesa driver (that used  to work on FC3). 
That's probably not very important as long as the X server works on the machine... 
Comment 15 dann 2005-06-25 16:46:37 EDT
Using the i810 driver from 
http://www.fairlite.demon.co.uk/intel.html
and libvgahw.a from a FC3 machine the X server works correctly.

https://bugs.freedesktop.org/show_bug.cgi?id=2585 says that the i810 code is now
in CVS.

Before replacing libvgahw.a the text console was not working after killing the X
server.
Comment 16 Carlos Martín 2005-07-14 10:37:16 EDT
Hi. I have the same problem with a Supermicro P8SCT wich has an E7221 graphics
controler. I can get X to work if previously logins as root and invoke vbetest.
Dann could you test if this work for you? 
Comment 17 Carlos Martín 2005-07-14 11:14:32 EDT
Created attachment 116758 [details]
spec file

Mike, this spec compiles an 6.8.99.8 X development series tar file which has
E7221 support. This doesn't work too, nor with vesa or i810 drivers. May be a
gcc4 problem?
Comment 18 Olivier Baudron 2005-08-09 11:53:42 EDT
This may be the same problem as in bug #163331.
Would you please test xorg-x11-6.8.2-45 with the vesa driver ?
Comment 19 Carlos Martín 2005-08-11 11:33:46 EDT
Hi Oliver.
I've a -43 release without pciscan working for my since a couple of weeks, so is
probably that this will be a duplicate of bug 163331. I'll try to compile -45
release from Rawhide wit FC4 glibc and give it a chance.
Comment 20 Olivier Baudron 2005-08-11 11:45:20 EDT
*** Bug 164975 has been marked as a duplicate of this bug. ***
Comment 21 Olivier Baudron 2005-08-11 11:48:35 EDT
*** Bug 160901 has been marked as a duplicate of this bug. ***
Comment 22 Olivier Baudron 2005-08-11 11:59:07 EDT
Carlos, thanks for your tests. I'm waiting your -45 report to close this bug.
Comment 23 Carlos Martín 2005-08-12 11:09:26 EDT
Hi Oliver.
New -pciscan patch works ok for me. I'only have a warning from X of type 'failed
to set up write-combinig range on (0xc0400000,0x3b0000)', but this one also
occurrs when -pciscan patch was disabled.

 
Comment 24 Olivier Baudron 2005-08-12 11:21:11 EDT
Dont't worry, this is not an error, and may not be displayed in future releases.
Thanks for the tests with E7221.

*** This bug has been marked as a duplicate of 163331 ***

Note You need to log in before you can comment on or make changes to this bug.