Bug 1604351 - hxtools: FTBFS in Fedora 29: C++ preprocessor "/lib/cpp" fails sanity check
Summary: hxtools: FTBFS in Fedora 29: C++ preprocessor "/lib/cpp" fails sanity check
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hxtools
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1675119 (view as bug list)
Depends On:
Blocks: F29FTBFS F30FTBFS 1551327
TreeView+ depends on / blocked
 
Reported: 2018-07-19 22:15 UTC by Mohan Boddu
Modified: 2019-07-26 01:51 UTC (History)
3 users (show)

Fixed In Version: hxtools-20150304-8.fc31 hxtools-20150304-8.fc30 hxtools-20150304-7.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-26 01:00:04 UTC


Attachments (Terms of Use)
build.log (9.33 KB, text/plain)
2018-07-19 22:15 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-19 22:15 UTC, Mohan Boddu
no flags Details
state.log (631 bytes, text/plain)
2018-07-19 22:15 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-19 22:15:46 UTC
hxtools failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28189058


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix hxtools at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
hxtools will be orphaned. Before branching of Fedora 30,
hxtools will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-19 22:15:52 UTC
Created attachment 1462943 [details]
build.log

Comment 2 Mohan Boddu 2018-07-19 22:15:55 UTC
Created attachment 1462944 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-19 22:15:58 UTC
Created attachment 1462945 [details]
state.log

Comment 4 Till Maas 2018-08-10 14:30:19 UTC
Igor, will you automatically fix bugs like these or do we now need to do it manually?

Comment 5 Jan Kurik 2018-08-14 09:33:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 6 Petr Pisar 2019-07-17 10:54:01 UTC
*** Bug 1675119 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2019-07-17 11:18:40 UTC
FEDORA-2019-f014c152b3 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f014c152b3

Comment 8 Fedora Update System 2019-07-17 11:18:53 UTC
FEDORA-2019-e4d0728e9b has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e4d0728e9b

Comment 9 Fedora Update System 2019-07-18 00:42:40 UTC
hxtools-20150304-8.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f014c152b3

Comment 10 Fedora Update System 2019-07-18 03:35:55 UTC
hxtools-20150304-7.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e4d0728e9b

Comment 11 Fedora Update System 2019-07-26 01:00:04 UTC
hxtools-20150304-8.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-07-26 01:51:08 UTC
hxtools-20150304-7.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.