Bug 160500 - X freezes (white screen) on start and corrupts entire display (even non X stuff)
X freezes (white screen) on start and corrupts entire display (even non X stuff)
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On: libvgahw
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 10:15 EDT by Matthew D'Albert
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-23 13:21:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg LOGFILE (38.83 KB, text/plain)
2005-06-15 10:17 EDT, Matthew D'Albert
no flags Details
Xorg.0.log (39.50 KB, application/octet-stream)
2005-06-15 12:26 EDT, Kevin Gottsman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 2976 None None None Never

  None (edit)
Description Matthew D'Albert 2005-06-15 10:15:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
White screen of death
---------------------

This was first experienced when trying to install FC4, when it comes to the point of starting X, the black mouse pointer shows as normal, then the screen goes white and stays like that, the mouse pointer disappears. I have tried leaving it like this and nothing happens, changing to the consoles shows a corrupt display with white horizontal lines. 

I installed via text install and now experience the same thing anytime X loads (even rhgb) the only way I can use fc4 is by disabling rhgb and using runlevel 3

FEDORA CORE 3,2 and 1 worked fine with X and the trident drivers etc. I have tried updating to xorg-x11-6.8.2-37 and the same thing happens.

Please note that the whole machine does not crash, just display is useless.

Version-Release number of selected component (if applicable):

xorg-x11-6.8.2-31, xorg-x11-6.8.2-37


How reproducible:
Always

Steps to Reproduce:
1. Run X

  

Additional info:

I have a Toshiba Satellite 1800-314 laptop:

[root@lappy ~]# lspci
00:00.0 Host bridge: ALi Corporation M1644/M1644T Northbridge+Trident (rev 01)
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:04.0 IDE interface: ALi Corporation M5229 IDE (rev c3)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 01)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:11.0 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus Bridge with ZV Support (rev 32)
00:11.1 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus Bridge with ZV Support (rev 32)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade XPAi1 (rev 82)
02:00.0 Ethernet controller: Accton Technology Corporation SMC2-1211TX (rev 10)
Comment 1 Matthew D'Albert 2005-06-15 10:17:26 EDT
Created attachment 115481 [details]
Xorg LOGFILE

Xorg LOGFILE
Comment 2 Kevin Gottsman 2005-06-15 12:26:02 EDT
Created attachment 115487 [details]
Xorg.0.log
Comment 3 Kevin Gottsman 2005-06-15 12:27:22 EDT
I get the same thing as the original poster.

System is Toshiba Satelitte 1405-S151

[kevin@mikachan ~]$ /sbin/lspci
00:00.0 Host bridge: ALi Corporation M1644/M1644T Northbridge+Trident (rev 01)
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:04.0 IDE interface: ALi Corporation M5229 IDE (rev c3)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 01)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:0a.0 Ethernet controller: Intel Corporation 82551QM Ethernet Controller (rev 10)
00:11.0 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus
Bridge with ZV Support (rev 32)
00:11.1 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus
Bridge with ZV Support (rev 32)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade XPAi1 (rev 82)
[kevin@mikachan ~]$
Comment 4 Matthew D'Albert 2005-06-15 12:37:19 EDT
Just to confirm; the issue is not present in xorg-x11-6.8.2-1.FC3.13 (the latest
FC3 version) as I have had to downgrade to run X on fc4.
Comment 5 Tom H 2005-06-15 18:11:18 EDT
I too have the same exact problem, on a Toshiba Satellite 1805-S274.  Fedora
Core 1 worked fine, but I haven't tried 2 or 3 because my CD-ROM drive is broken
and I only now have gone to the trouble of installing via other methods.

00:00.0 Host bridge: ALi Corporation M1644/M1644T Northbridge+Trident (rev 01)
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:04.0 IDE interface: ALi Corporation M5229 IDE (rev c3)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 01)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:0a.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 0d)
00:11.0 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus
Bridge with ZV Support (rev 32)
00:11.1 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus
Bridge with ZV Support (rev 32)
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade XPAi1 (rev 82)
06:00.0 FireWire (IEEE 1394): NEC Corporation IEEE 1394 [OrangeLink] Host
Controller (rev 03)
Comment 6 Mikko V 2005-06-17 18:40:11 EDT
I have the EXACT same problem. My system is:

Hardware: Fujitsu-Siemens Lifebook C Series C-6135
Graphics card: Trident Cyber 9525
Mouse: Synaptics Touchpad

Fedora Core 3 had NO problems installing on this laptop.
Comment 7 Alex Lancaster 2005-06-20 14:26:34 EDT
Same problem using Trident Cyber 9525 (rev 73) on a Fujitsu Lifebook S4542.  Again, no problems with Fedora's 1,2,3.  Now X whites out the whole display.  Also doesn't seem to be a new upstream version relative to FC3, so what's up with the patches to the package?  Has some regression bug slipped in?  This is most frustrating to have a perfectly good X setup gone south.  I have tried the "switch to CRT" and back again "trick", but it doesn't work for me.  Anything, even a hacky workaround would be gratefully appreciated...
Comment 8 Alex Lancaster 2005-06-21 01:04:18 EDT
This appears to be a duplicate of bug #151688.  It appears to be an upstream
error in xorg, the upstream bug is:
https://bugs.freedesktop.org/show_bug.cgi?id=2976.

The workaround of replacing the "trident" driver with "vesa" in
/etc/X11/xorg.conf listed in comment #7 of the freedesktop bug appears to work
for me.

Apparently 6.8.2-37 package included in FC4 includes patches from the xorg CVS,
so it isn't really the same version of xorg as included in FC3.
Comment 9 Mike A. Harris 2005-06-22 17:17:29 EDT
Please review bug #161242 everyone, and try using the libvgahw.a module
that is linked to from that bug report.  This is just a hunch I'd like
to test to see if the problem reported on Matrox and Intel hardware is also
causing problems on Trident and other hardware.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242

Anyone who can test this and provide feedback, would be greatly appreciated.

Thanks in advance.

Comment 10 Matthew D'Albert 2005-06-22 21:37:15 EDT
(In reply to comment #9)
> Please review libvgahw everyone, and try using the libvgahw.a module
> that is linked to from that bug report.  This is just a hunch I'd like
> to test to see if the problem reported on Matrox and Intel hardware is also
> causing problems on Trident and other hardware.
> 
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161242
> 
> Anyone who can test this and provide feedback, would be greatly appreciated.
> 
> Thanks in advance.
> 
> 


I have tried xorg-x11-6.8.2-37 with the linked version of libvgahw.a and this
FIXES the problem, so it seems your hunch was correct.

01:00.0 VGA compatible controller: Trident Microsystems CyberBlade XPAi1 (rev 82)
Comment 11 Alex Lancaster 2005-06-23 06:50:34 EDT
Another confirmation that this works for me with xorg-x11-6.8.2-37 with the
libvgahw.a listed above on my Trident Cyber 9525 (rev 73).
Comment 12 Mike A. Harris 2005-06-23 13:21:01 EDT
Thanks guys for confirming my suspicions!  We're edging closer now...



*** This bug has been marked as a duplicate of 161242 ***

Note You need to log in before you can comment on or make changes to this bug.