Bug 160611 - unable to display document title when russian characters is used
Summary: unable to display document title when russian characters is used
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openmotif (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
: 155512 (view as bug list)
Depends On:
Blocks: Russian
TreeView+ depends on / blocked
 
Reported: 2005-06-16 02:27 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 15:27:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unalbe to display russian characters (71.85 KB, image/png)
2005-06-16 02:27 UTC, Lawrence Lim
no flags Details
sample pdf file (150.82 KB, application/pdf)
2005-06-16 02:28 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2005-06-16 02:27:14 UTC
Description of problem:
When russain characters are used for labelling the title of the document, xpdf
is not able to display the russian characters properly. Please see attached
screenshot.

Version-Release number of selected component (if applicable):
xpdf-3.00-11.5

How reproducible:
Always

Steps to Reproduce:
1.pls open the attached pdf document
2.
3.
  
Actual results:
title of the document cannot be displayed

Expected results:
able to display the title of the document

Additional info:

Comment 1 Lawrence Lim 2005-06-16 02:27:15 UTC
Created attachment 115517 [details]
unalbe to display russian characters

Comment 2 Lawrence Lim 2005-06-16 02:28:03 UTC
Created attachment 115518 [details]
sample pdf file

Comment 3 Ngo Than 2005-06-16 12:40:51 UTC
it's a problem in motif, which does not handle utf8 correctly ATM.

Comment 4 Ngo Than 2005-08-02 10:47:55 UTC
*** Bug 155512 has been marked as a duplicate of this bug. ***

Comment 5 Thomas Woerner 2006-01-20 15:42:00 UTC
Please have a look at the new openmotif in Fedora Core development. This is a
beta release of the upcoming openmotif-2.3.0 with UTF-8 support.

At the moment it is not possible to use UTF-8 with the current openmotif versions.

Does this version fixes your problems? Please remember, that the new library
version is 4. 

Comment 6 Horst H. von Brand 2006-01-20 22:43:39 UTC
Just checked the attached file with openmotif-2.3.0-0.1.2, xpdf-3.01-10. Looks
fine to me.

Comment 7 Thomas Woerner 2007-07-23 12:27:53 UTC
The problem is that the openmotif version in RHEL-4 is not UTF-8 capable. The
change to the 2.3 verison is not possible, because of a library version change.
Is it ok for you to use the 2.3 test package?

Comment 8 Horst H. von Brand 2007-07-23 13:47:57 UTC
I see no openmotif packages in Fedora rawhide right now...

Comment 9 Thomas Woerner 2007-07-23 13:52:34 UTC
openmotif has been dropped from Fedora completely. Please use the RHEL-5 package
instead.

Comment 10 Horst H. von Brand 2007-07-23 20:08:20 UTC
This is quite bad, as all Fedora is moving to UTF-8, and I'd prefer not to have
foreign packages installed (plus RHEL will be left behind by rawhide quite
soon...). Does this mean xpdf is on the "to be deleted" list for Fedora?

Comment 11 Thomas Woerner 2007-07-24 10:17:37 UTC
Yes, maybe. But currently it is using lesstif.

Comment 13 Jens Petersen 2008-05-01 04:17:25 UTC
If there are no plans to fix this then yes let's close it.

Comment 14 Thomas Woerner 2008-07-09 15:27:47 UTC
A very big patch is needed to fix the UTF-8 problem in this old OpenMotif version. 
This also means lots of API changes.

Therefore I have to close this as CANTFIX.


Note You need to log in before you can comment on or make changes to this bug.