Bug 160647 - Installer hangs when loading glibc-common-2.3.5-10.i386 with kernel panic
Installer hangs when loading glibc-common-2.3.5-10.i386 with kernel panic
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks: FCMETA_INSTALL
  Show dependency treegraph
 
Reported: 2005-06-16 06:56 EDT by Manoj Kumar Singh
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 05:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manoj Kumar Singh 2005-06-16 06:56:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I am trying to install fc4 on a pc with PIII processor and 810e chipset motherboard. Installer hangs when installing glibc-common-2.3.5-10.i386 with kernel panic and following message:

Kernel panic- not syncing: drivers/ide/pci/piix.c:232: spin_lock(drivers/ide/ide.c:c03de66) already locked by drivers/ide/ide-iops.c/1235. ( not tainted)

Please note that i have installed fc1, fc2, fc3 on this very hardware successfully.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot with fc4 cd 1 with linux text option
2.select the custom mode and softwares to load
3.start the installation. hen installing globc-common with kernel panic with the same message everytime.
  

Actual Results:  system freezes when installing glibc-common with kernel panic with following message
:Kernel panic- not syncing: drivers/ide/pci/piix.c:232: spin_lock(drivers/ide/ide.c:c03de66) already locked by drivers/ide/ide-iops.c/1235. ( not tainted)

Expected Results:  Installation would have continued without problem like in fc3.

Additional info:
Comment 1 R Regan 2005-06-16 21:59:32 EDT
I am having the same problem. I found a work around in bug 144743, by 
installing with "linux ide=nodma" at the prompt from cd-1. But this isn't a 
real solution for running after the install as the machine hangs a lot during 
disk access.
Comment 2 Dave Jones 2005-07-08 18:50:29 EDT
This is the FC4 variant of bug 159372
That code looks unchanged since the 2.6.11 FC3 kernel.
Comment 3 Dave Jones 2005-07-15 17:14:16 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 4 Dave Jones 2005-09-30 05:34:52 EDT
we lack the mechanism to provide a new boot kernel for the installer easily, so
this isn't fixable until FC5.

The actual bug did get fixed in later FC4 errata kernels, so if you manage to
get it to install (try "linux acpi=off" on the cd boot command line) you should
be able to update to it, and boot without problems.
Comment 5 Dave Jones 2005-09-30 19:51:34 EDT
http://fedora.isphuset.no/ contains an unofficial Fedora 4.1, which may get you
up and running, as it has a install kernel based on one of the errata kernels.

Note You need to log in before you can comment on or make changes to this bug.