Bug 160776 - evolution-exchange-storage crashes when starting Evolution
evolution-exchange-storage crashes when starting Evolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 160946 (view as bug list)
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-06-17 04:27 EDT by Fred New
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 15:21:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
typescript file (570 bytes, text/plain)
2005-06-17 04:32 EDT, Fred New
no flags Details
Extra messages created by previously mentioned commands (39.67 KB, text/plain)
2005-06-17 04:36 EDT, Fred New
no flags Details
Original typescript file (40.71 KB, text/plain)
2005-06-17 05:14 EDT, Fred New
no flags Details
Stack trace (3.79 KB, text/plain)
2005-06-17 13:19 EDT, Fred New
no flags Details
Another stack trace, more debuginfo, locally executed (3.27 KB, text/plain)
2005-06-20 03:11 EDT, Fred New
no flags Details

  None (edit)
Description Fred New 2005-06-17 04:27:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Everytime I try to open Evolution to access my mailbox on an Exchange server, I get an error window stating, "The Application "evolution-exchange-storage" has quit unexpectedly.

"You can inform the developers of what happened to help them fix it.  Or you can restart the application right now."



Version-Release number of selected component (if applicable):
evolution-connector-2.2.2-5

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 with Evolution
2. Install evolution-connector
3. Start Evolution to configure the email account on Exchange server.
  

Actual Results:  A crash with the above message.  Evolution starts after clicking "close", but I cannot access my Exchange account.

Expected Results:  Something more satisfying. :)

Additional info:

This may be a configuration error on my part; I haven't been able to get Evolution to work since I installed FC4 yesterday.  I started with a new home directory after installing FC4.
Comment 1 Fred New 2005-06-17 04:32:43 EDT
Created attachment 115596 [details]
typescript file

This file was created by opening a terminal and entering the following commands
(after looking at RH bug 157226):

script
evolution --force-shutdown
export E2K_DEBUG=4
/usr/libexec/evolution/2.2/evolution-exchange-storage > ev-exch-stg-debug 2>&1
&
exit
Comment 2 Fred New 2005-06-17 04:36:34 EDT
Created attachment 115597 [details]
Extra messages created by previously mentioned commands

The results of

/usr/libexec/evolution/2.2/evolution-exchange-storage > ev-exch-stg-debug 2>&1
&
Comment 3 Fred New 2005-06-17 05:14:25 EDT
Created attachment 115599 [details]
Original typescript file

This typescript file looks like it has a lot more information in it.  It is
from the first time I ran the commands above.  During that first run, I saw a
huge number of messages go by and decided to capture them.  So the preceding
two files (typescript and messages) were from the second time I tried to run
the commands.
Comment 4 Tim Fournet 2005-06-17 12:26:25 EDT
I also experience the exact same behavior. As soon as I configure Evolution to
connect to exchange, the crash occurs. 
Comment 5 Dave Malcolm 2005-06-17 12:32:05 EDT
Thanks - from the typescript file I can see that Evolution is successfully
authenticating with the Exchange server, and is getting data back.

Please can you install the evolution-connector-debuginfo package and then try to
reproduce this bug.  Once this is done, please attach the backtrace from the
crash to this bug.  You can get this by clicking on the "Inform Developers"
button and sshowing the debugging details.  You can get more information on this
here:
http://fedora.linux.duke.edu/wiki/StackTraces
Comment 6 Fred New 2005-06-17 13:19:30 EDT
Created attachment 115622 [details]
Stack trace

I think this is the stack trace you asked for.	The computer where I encounter
this problem is at work and I am at home, so I had to use ssh -Y to get there,
install the debug RPM and start evolution.
Comment 7 Mike Polhemus 2005-06-17 14:15:51 EDT
I'm having this also.  If I click on the calendar button, it's also crashing
evolution-tasks is crashing if I select calendars.
Comment 8 Fred New 2005-06-20 03:11:02 EDT
Created attachment 115674 [details]
Another stack trace, more debuginfo, locally executed

I am back at work now, so I executed Evolution on the offending machine
locally.  Before executing Evolution, I installed debuginfo for
evolution-data-server and glibc.
Comment 9 Dave Malcolm 2005-06-22 12:03:58 EDT
Thanks.

(Looking at the stack trace in comment #8, it looks like
e_source_group_peek_source_by_name is being called with a NULL group from
add_esource in storage/exchange-config-listener.c , and that this ought not to
be possible looking at the source code).

Comment 10 Fred New 2005-06-27 17:09:38 EDT
This code looks like it is trying to figure out something about my contacts. 
I've always had problems configuring my contacts in Exchange.

If you want me to insert some printf commands into
storage/exchange-config-listener.c to get some extra debug information, just
tell me what you need (like line number, variable name and format).
Comment 11 Dave Malcolm 2005-06-28 11:56:48 EDT
*** Bug 160946 has been marked as a duplicate of this bug. ***
Comment 12 Need Real Name 2005-06-30 03:08:22 EDT
I get loads of these two, probably about four crashes per day.
Using the Contacts chooser after clicking the "To:" button in an e-mail is one
good way to make it crash.
Comment 13 Need Real Name 2005-06-30 03:19:56 EDT
"I get loads of these too".
Comment 14 Scott Thistle 2005-07-16 22:34:26 EDT
I am getting the same issue with a fresh install of FC4 (x86). The error I find
when running in debug mode (after it retrieves the XML of my mailbox) is:

(evolution-exchange-storage:7457): GLib-GObject-WARNING **: invalid unclassed
pointer in cast to `ESource'

(evolution-exchange-storage:7457): e-data-server-CRITICAL **:
e_source_peek_name: assertion `E_IS_SOURCE (source)' failed


We have Exchange 2000.
Comment 15 Tom Miller 2005-07-19 14:00:30 EDT
I am getting the same errors.  Running Suse93 Pro latest revs on evolution and
ximian connector.  Is there an automated way to determine if this bug has been
fixed.  Using Firefox to access my owa on exch 2003 box, not good.  What I have
observed is the very first time you open evolution it will work, however, after
that everytime I get the error mentioned above.
Comment 16 Fred New 2005-08-15 05:12:25 EDT
Out of curiousity, I updated all of my evolution packages to the latest Rawhide
versions.  This problem seems to have been fixed in Rawhide with
evolution-connector-2.3.7-1.
Comment 17 Fred New 2005-10-12 05:07:22 EDT
My system is running FC4 (no Rawhide) again, and I just installed
evolution-connector-2.2.3-1.fc4 from the updates-testing repository.  This
version connects successfully to my Exchange server, too.  The fix seems to have
been sitting around since June 29.  Is there some reason it hasn't been promoted
to the "production" updates-released repo?
Comment 18 Rodney Lancaster 2005-11-10 17:11:57 EST
I am getting the same error on one workstation but not on another.  The
workstation that gets the error every time is:
OS: FC4 - Updated from FC3 - Current as of 11/10/2005 around 1pm CST.
Hardware: Intel server with 2 - 700MHZ PIII and 2GB of memory.
Evolution has been removed and reinstalled with yum to make sure that all the
packages were loaded.

The server where evolution is working is:
OS: FC4 - Full install, not an upgrade -Current as of 11/10/2005 around 1pm CST.
Hardware - Dell 2450 with 2 - 866 PIII and 1GB of memory.
Evolution worked right out of the "box".

I have noticed that the Full install FC4 runs a perl script for spamd where the
Updated OS does not.

At least I can read my mail on one workstation.
Comment 19 Scott Thistle 2005-11-17 23:42:35 EST
I am still getting this, and now trying SuSE 10.0. The products I am using are:

evolution-exchange-2.4.0-5
multisync-evolution-0.82+cvs-8
evolution-devel-2.4.0-3.2
evolution-data-server-devel-1.4.0-5.2
evolution-2.4.0-3.2
evolution-data-server-1.4.0-5.2
evolution-sharp-0.10.1-4
evolution-webcal-2.4.0.1-3
evolution-pilot-2.4.0-3.2

The output from gdb /opt/gnome/bin/evolution is:

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-suse-linux"...(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".

(gdb) run
Starting program: /opt/gnome/bin/evolution
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1096994528 (LWP 31644)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

(evolution:31644): GLib-GObject-WARNING **: gsignal.c:1069: unable to lookup
signal "show" of unloaded type `GtkMessageDialog'

(evolution:31644): GLib-GObject-CRITICAL **: g_signal_add_emission_hook:
assertion `signal_id > 0' failed
adding hook target 'source'

(evolution:31644): camel-WARNING **: camel_exception_get_id called with NULL
parameter.
[New Thread 1127373744 (LWP 31654)]
[New Thread 1129868208 (LWP 31655)]
[New Thread 1132112816 (LWP 31656)]
[New Thread 1134214064 (LWP 31657)]

(evolution:31644): Gdk-CRITICAL **: gdk_gc_set_foreground: assertion `GDK_IS_GC
(gc)' failed
[New Thread 1157458864 (LWP 31676)]
[New Thread 1159953328 (LWP 31690)]
[Thread 1129868208 (LWP 31655) exited]

(evolution:31644): evolution-mail-WARNING **: Error occurred while existing
dialogue active:
Lost connection to Evolution Exchange backend process

(evolution:31644): evolution-mail-WARNING **: Error occurred while existing
dialogue active:
Lost connection to Evolution Exchange backend process
[New Thread 1162054576 (LWP 31694)]

Is anyone actively working on this? I have tried FC3 and FC4, SuSE 9.3 and 10.
Same result. If there is anything I can do to help, please drop me a line. I
really want to switch to linux full time, but need my email. Webmail sucks, and
running Outlook sucks more. 

Thanks
Comment 21 Matthew Barnes 2006-07-31 11:00:59 EDT
Is this bug still present in the latest Rawhide release?

evolution-2.7.4-3
evolution-connector-2.7.4-1.1
evolution-data-server-1.7.4-2
Comment 22 Scott Thistle 2006-07-31 11:19:00 EDT
I have been unable to use the product anymore since it no longer works with our
newer Exchange 2003 environment. I am now forced to use Outlook under Wine or
via terminal server.
Comment 23 Need Real Name 2006-08-04 14:54:02 EDT
Same here. Evolution is completely unusable with Exchange.
It might work for a few minutes, but then evolution hogs the cpu, my pc sounds
like an airplane taking off, then I have to killall evol.

I'll try rawhide Monday, but I'm not looking forward to it.

Thank goodness for rdesktop :)
Comment 24 Matthew Barnes 2006-08-04 15:21:05 EDT
The stated crash in the problem description no longer occurs with the latest
Rawhide packages.  I was able to successfully connect to an Exchange server
today and did not observe any crashes or excessive resource usage.  If you are
still experiencing this problem while using evolution-connector-2.7.4, please
reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.