Bug 160946 - Evolution Connector crashes on startup
Evolution Connector crashes on startup
Status: CLOSED DUPLICATE of bug 160776
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
http://vsharma.net/ljpics/fc4-evoluti...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-18 23:36 EDT by VaibhaV Sharma
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-28 11:56:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description VaibhaV Sharma 2005-06-18 23:36:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Fresh installation of FC4, configured an exchange account just like I had it working on FC3. The Authentication check etc. everything went through without any errors. Starting evolution crashes evolution-exchange-storage.


Version-Release number of selected component (if applicable):
evolution-connector-2.2.2-5

How reproducible:
Always

Steps to Reproduce:
1. Configure a new exchange account in evolution
2. Save settings
3. Restart evolution
  

Actual Results:  Evolution-exchange-storage crashes everytime, rendering the respective exchange account unusable.

Expected Results:  A list of exchange folders should have been displayed.

Additional info:
Comment 1 VaibhaV Sharma 2005-06-18 23:38:33 EDT
http://vsharma.net/ljpics/fc4-evolution-connector-crash-screenshot-1.png

Not able to "Inform Developers" using bugbuddy when the crash happens. This is
the bugbuddy dump trace -

-----------------------------------
Backtrace was generated from '/usr/libexec/evolution-exchange-storage'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208776224 (LWP 4804)]
[New Thread -1210901584 (LWP 4805)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x009c3402 in ?? ()
#0  0x009c3402 in ?? ()
#1  0x00a19fbb in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x0034a080 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x07923f68 in strcmp () from /lib/libc.so.6
#5  0x03f726a8 in e_source_group_peek_source_by_name ()
   from /usr/lib/libedataserver-1.2.so.4
#6  0x0806c5d0 in add_esource ()
#7  0x0806d09c in remove_esource ()
#8  0x00784186 in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
#9  0x00777d9b in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#10 0x00778285 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#11 0x00786917 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#12 0x00787ee0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#13 0x00788254 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#14 0x03f66541 in e_account_list_get_type ()
   from /usr/lib/libedataserver-1.2.so.4
#15 0x03f66780 in e_account_list_construct ()
   from /usr/lib/libedataserver-1.2.so.4
#16 0x0806d6db in remove_esource ()
#17 0x00a46650 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#18 0x00a443ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#19 0x00a473f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#20 0x00a476e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#21 0x00839625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#22 0x080795d4 in main ()

Thread 2 (Thread -1210901584 (LWP 4805)):
#0  0x009c3402 in ?? ()
No symbol table info available.
#1  0x0797acec in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x00a47248 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x00a476e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x009a23de in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x00a5fe9a in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00a14b80 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x07984dee in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1208776224 (LWP 4804)):
#0  0x009c3402 in ?? ()
No symbol table info available.
#1  0x00a19fbb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0034a080 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x07923f68 in strcmp () from /lib/libc.so.6
No symbol table info available.
#5  0x03f726a8 in e_source_group_peek_source_by_name ()
   from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#6  0x0806c5d0 in add_esource ()
No symbol table info available.
#7  0x0806d09c in remove_esource ()
No symbol table info available.
#8  0x00784186 in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#9  0x00777d9b in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#10 0x00778285 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#11 0x00786917 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#12 0x00787ee0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#13 0x00788254 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#14 0x03f66541 in e_account_list_get_type ()
   from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#15 0x03f66780 in e_account_list_construct ()
   from /usr/lib/libedataserver-1.2.so.4
No symbol table info available.
#16 0x0806d6db in remove_esource ()
No symbol table info available.
#17 0x00a46650 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#18 0x00a443ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#19 0x00a473f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#20 0x00a476e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#21 0x00839625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#22 0x080795d4 in main ()
No symbol table info available.
Comment 2 Dave Malcolm 2005-06-22 12:28:45 EDT
Thanks for this report.

Please can you install debuginfo packages for evolution, evolution-data-server
and evolution-connector, and supply another backtrace.  More information on
doing this can be found here:
http://fedora.linux.duke.edu/wiki/StackTraces

Thanks.

This looks very similar to bug #160776 though I want to see a richer backtrace
before deciding for sure.
Comment 3 VaibhaV Sharma 2005-06-28 10:26:39 EDT
Backtrace was generated from '/usr/libexec/evolution-exchange-storage'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208751648 (LWP 3408)]
[New Thread -1210877008 (LWP 3409)]
0x004d1402 in ?? ()
#0  0x004d1402 in ?? ()
#1  0x00573fbb in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x07768080 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0037ef68 in strcmp () from /lib/libc.so.6
#5  0x07902188 in e_source_group_peek_source_by_name (group=0x0,
    name=0x982f638 "Calendar") at e-source-group.c:570
#6  0x0806c5d0 in add_esource (account=0x9800ce8,
    folder_type=EXCHANGE_CALENDAR_FOLDER, folder_name=0x982f638 "Calendar",
    physical_uri=0x9836ed8
"exchange://vsharma@exchange.ishisystems.com/personal/PocketMirror/Conflicts/Calendar",
source_list=0xbf969788)
    at exchange-config-listener.c:278
#7  0x0806d09c in account_added (account_list=0x97d3cf8, account=0x9800a20)
    at exchange-config-listener.c:370
#8  0x0085d186 in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
#9  0x00850d9b in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#10 0x00851285 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#11 0x0085f917 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#12 0x00860ee0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#13 0x00861254 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#14 0x078f6021 in gconf_accounts_changed (client=0x0, cnxn_id=1409286148,
    entry=0x0, user_data=0x97d3cf8) at e-account-list.c:201
#15 0x078f6260 in e_account_list_construct (account_list=0x97d3cf8,
    gconf=0x97cf330) at e-account-list.c:279
#16 0x0806d6db in idle_construct (data=0x97d3cf8)
    at exchange-config-listener.c:837
#17 0x006bb650 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#18 0x006b93ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#19 0x006bc3f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#20 0x006bc6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#21 0x076b2625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#22 0x080795d4 in main (argc=159577656, argv=0x982f638) at main.c:225

Thread 2 (Thread -1210877008 (LWP 3409)):
#0  0x004d1402 in ?? ()
No symbol table info available.
#1  0x003d5cec in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x006bc248 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x006bc6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x002cd3de in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x006d4e9a in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x0056eb80 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x003dfdee in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1208751648 (LWP 3408)):
#0  0x004d1402 in ?? ()
No symbol table info available.
#1  0x00573fbb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x07768080 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x0037ef68 in strcmp () from /lib/libc.so.6
No symbol table info available.
#5  0x07902188 in e_source_group_peek_source_by_name (group=0x0,
    name=0x982f638 "Calendar") at e-source-group.c:570
        p = (GSList *) 0x98287c8
#6  0x0806c5d0 in add_esource (account=0x9800ce8,
    folder_type=EXCHANGE_CALENDAR_FOLDER, folder_name=0x982f638 "Calendar",
    physical_uri=0x9836ed8
"exchange://vsharma@exchange.ishisystems.com/personal/PocketMirror/Conflicts/Calendar",
source_list=0xbf969788)
    at exchange-config-listener.c:278
        source =
Comment 4 Dave Malcolm 2005-06-28 11:56:45 EDT
Thanks for supplying this updated backtrace.

It's crashing in the same way as in bug 160776, so I'm going to mark this as a
duplicate of that bug.

*** This bug has been marked as a duplicate of 160776 ***

Note You need to log in before you can comment on or make changes to this bug.