Bug 1608778 - qemu/migration: migrate failed from RHEL.7.6 to RHEL.7.5 with e1000-82540em
Summary: qemu/migration: migrate failed from RHEL.7.6 to RHEL.7.5 with e1000-82540em
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Dr. David Alan Gilbert
QA Contact: jingzhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-26 09:39 UTC by jingzhao
Modified: 2018-11-08 03:22 UTC (History)
7 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-9.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 11:13:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3443 None None None 2018-11-01 11:15:34 UTC

Description jingzhao 2018-07-26 09:39:17 UTC
Description of problem:
migrate failed from RHEL.7.6 to RHEL.7.5 with e1000-82540em

Version-Release number of selected component (if applicable):
RHEL.7.6: qemu-kvm-rhev-2.12.0-7.el7.x86_64
RHEL.7.5: qemu-kvm-rhev-2.10.0-21.el7_5.4.x86_64

How reproducible:
3.3

Steps to Reproduce:
1. Boot guest with e1000-82540em on src and dest host
2. migrate from src(rhel7.6) to dest (rhel7.5)


Actual results:
migrate failed
qemu-kvm: error while loading state for instance 0x0 of device '0000:00:15.0/e1000'
qemu-kvm: warning: TSC frequency mismatch between VM (2397223 kHz) and host (3392144 kHz), and TSC scaling unavailable
qemu-kvm: load of migration failed: No such file or directory


Expected results:
migrate successfully


Additional info:

Comment 2 Dr. David Alan Gilbert 2018-07-26 09:41:45 UTC
recreated on my test boxes

Comment 3 Dr. David Alan Gilbert 2018-07-26 12:20:10 UTC
Fix brewing;  we've got different aliases for e1000 than upstream, whenever there's a compatibility fix for e1000 we need to make the same fix for 82540em
(see bz 1353070)

Comment 7 Miroslav Rezanina 2018-08-01 17:23:04 UTC
Fix included in qemu-kvm-rhev-2.12.0-9.el7

Comment 9 jingzhao 2018-08-02 05:54:58 UTC
Reproduced it with qemu-kvm-rhev-2.12.0-7.el7 and verified it with qemu-kvm-rhev-2.12.0-9.el7

Detailed:

1. Boot e1000-82540em device both in src and dest 

/usr/libexec/qemu-kvm -M pc-i440fx-rhel7.5.0 -device e1000-82540em,netdev=tap11,mac=00:52:68:26:32:03,id=net1 -netdev tap,id=tap11 -monitor stdio

2. migrate from RHEL7.6 host to RHEL7.5 host
(qemu) migrate -d tcp:destip:5800

3. migrate successfully
(qemu) info migrate
globals:
store-global-state: on
only-migratable: off
send-configuration: on
send-section-footer: on
decompress-error-check: off
capabilities: xbzrle: off rdma-pin-all: off auto-converge: off zero-blocks: off compress: off events: off postcopy-ram: off x-colo: off release-ram: off return-path: off pause-before-switchover: off x-multifd: off dirty-bitmaps: off late-block-activate: off 
Migration status: completed
total time: 28 milliseconds
downtime: 7 milliseconds
setup: 2 milliseconds
transferred ram: 1469 kbytes
throughput: 523.55 mbps
remaining ram: 0 kbytes
total ram: 148296 kbytes
duplicate: 36810 pages
skipped: 0 pages
normal: 286 pages
normal bytes: 1144 kbytes
dirty sync count: 2
page size: 4 kbytes


According to above test result, changed to verified

Comment 10 errata-xmlrpc 2018-11-01 11:13:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.