Bug 16099 - packages with pre scripts not installed (2)
packages with pre scripts not installed (2)
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 2000-08-13 10:48 EDT by Michael Redinger
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-10-24 11:31:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-08-13 10:48:41 EDT
This adds additional information for bug #11410 (which is not restricted to
beta; therefore I put this in a seperate bug report).

(To repeat the argumentation in the above bug - yes, I did some
modification and did something that was not intended/tested by Red Hat;
however, there is a bug. And I do find this feature quite important -
especially for big customers; ie. IBM does earn quite a lot of money with
things like that.)

The methods used where identical to those mentioned in the above bug.

Text mode install now doesn't crash anymore (RC1 with update image
included; it did crash in Pinstripe).

However, packages with pre scripts are still not installed, and post
scripts are not executed. install.log still looks ok (some minor ldconfig
messages which don't do any harm). No error messages for those packages
that where not installed.

Packages not installed (ie. all those who do contain pre scripts):


I tried to remove the pre scripts from some of this packages. If there's no
pre script, the package gets installed.
Comment 1 Erik Troan 2000-08-17 14:23:16 EDT
We can't reproduce this at all.
Comment 2 Michael Redinger 2000-08-17 15:38:45 EDT
I'm reopening this one more time. Partly because I do have some further
information, partly because I'd like to know if you did change any package
when testing this and because I'd like to know if you did experience any
of the other errors noted below. Please feel free to close this again ...
(I have tried this really often, so this is definitely reproduceable for
me ....)

I've found some new things. My setup didn't work at all with Pinstripe.
RC1 didn't look very well at first either (that was the point when I filed
this bug), but after some time I found out more about this whole thing. New

- I did only modify the dev (no pre script for adding the floppy group)
  and the  filesystem script (don't try to create the /usr directory tree).
- also modified todo.py to mount the /usr filesystem as described in the
  first bug
- modified rpm/macros (%_netsharedpath /usr).
- everything else is untouched (other adaptions done in %post install scripts).
- I do know that when I'm not modifying anything, things still go terribly
  wrong. I will have do some testing tomorrow or saturday to see if I can
  leave one of the two packages unchanged.

Things now kind of work. However, still some problems:

File attributes aren't set correctly in the filesystem package. Seems like
%attr doesn't work yet (note that this does work later on - that is, in the
next package using %attr - think this was procps - everything's okay). For
now, /tmp, /root and others don't have proper permissions (while other
directories in the filesystem package do - will have to do some further
testing here ...
Also, the directory /var/subsys isn't created - well, it is later on, but
not during filesystem installation. Noticed this because /var/lock/subsys
was missing. Could be the same error, as /var/lock/subsys is created with
something like this: %dir %attr(775, root, uucp) /var/lock . No other
package in filesystem uses %dir %attr. Some further testing needed here,
too ...

The other error I noticed is that X configuration is not done (did only
try this in text installation). The dialog which states which card has
been found does show up, but after package installation Xconfigurator is
not started (however, you can start it manually if doing a chroot or if
you use %post in kickstart). kickstart X configuration works.

The last error I noticed is that amanda-client says that /root/.amandahosts
doesn't exist (doesn't happen in normal install) and rootfiles complains
that /root doesn't exist (but installs fine anyway) (messages do go to

Well, the rest are just things I did expect: scripts that do complain that
they cannot write /usr (which isn't necessary; /usr is taken from a
RC1 install and therefore contains all the necessary changes. /usr is
mounted read-only (well, the mount that comes with the installer doesn't seem
to know the read-only options (neither -r nor -o ro), but it is exported
Comment 3 Michael Redinger 2000-08-18 09:18:00 EDT
Ok, started over again, rebuilding this installation method from scratch. Same
as above. Did you use parts newer than RC1? What packages did you change?
Comment 4 Michael Redinger 2000-08-24 14:43:01 EDT
Same tests with R2 (did even reuse my changed filesystem package as the version
number did not change). No problems now installing the dev package (ie. did not
remove the script for generating the floppy group - it was properly created
nevertheless). The only difference on my side was that I did use a RHAT 6.2
(insted of 7.0 RC1) NFS server, and that I did add no_root_squash to the export
options (therefore exporting read-only, but not doing a root squash).
Rest of the problems (/var/lock/subsys missing, wrong permissions, no X config
dialog, anaconda errors) remain.
Comment 5 Michael Redinger 2000-08-24 14:44:26 EDT
Oops, ^anaconda^amanda
Comment 6 Michael Fulbright 2000-10-24 11:31:22 EDT
Since you are using a modified boot disk there really is no way for us to
reproduce this problem.

The redhat-devel mailing list would be a place to talk with other people who
have "rolled" their own distribution based on Red Hat Linux. You can get more
info at http://www.redhat.com/mailing-lists.

Note You need to log in before you can comment on or make changes to this bug.