Bug 161004 - Fedora Core 4 won't install; fails in anaconda and when reading packages
Fedora Core 4 won't install; fails in anaconda and when reading packages
Status: CLOSED DUPLICATE of bug 160693
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-19 13:28 EDT by Charles Elliott
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 13:52:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Elliott 2005-06-19 13:28:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
I received the following exception when trying to install Fedora Core 4:

(unhandled) Exception occurred 
File "/usr/lib/anaconda/gui/py", line 1137, in handleRender callback
  self.currentWindow.renderCallback()
File "/usr/lib/anaconda/rw/progress_gui.py", line 244, in 
   renderCallback self.intf.icw.nextClicked()
...
8 more lines of this stuff
...
System error: pvcreate failed for fsset.partitionDevice instance at 0x2aaaaf137170

I tried it again, and it failed trying to install mozilla.  Then I tried it again and it failed trying to install 4Suite-1.0-8.b1.x86.64.

Each time I had to restart completely anew; it should not have had to re-partition the hard disk, but it would not continue unless I did.

I downloaded FC4-x86_64-disc1 thru 5, and tested all of them, but received the above errors anyway.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot into FC4-x86_64-disc1
2. Allow the installer to automatically partition the disk
3. The first time the above error appears, but if that is circumvented the installation still fails trying to install a component.
  

Actual Results:  Failed trying to install a specific program, such as mozilla or 4Suite

Expected Results:  Install and run.

Additional info:

Fedora is not ready for prime time.
Comment 1 Jeremy Katz 2005-06-20 14:12:27 EDT
Can you provide the complete traceback you received?
Comment 2 Charles Elliott 2005-06-20 21:44:54 EDT
 Exception occurred 
report to http://bugzilla.redhat.com/bugzilla under anaconda
File "/usr/lib/anaconda/gui/py", line 1137, in handleRender callback
  self.currentWindow.renderCallback()
File "/usr/lib/anaconda/rw/progress_gui.py", line 244, in 
   renderCallback self.intf.icw.nextClicked()
File "/usr/lib/anaconda/dispatch.py", line 242 in moveStep
   rc=apply(kune, self.bindArgs(args)) // kune may be wrong; can't read own 
writing
File "/usr/lib/anaconda/packages.py", line 582, in turnOnFileSystems
  thefsset, createLogicalVolumes(instPath)
File "/usr/lib/anaconda/fsset.py", line 2066 in setupDevice
   raise SystemError, pvcreate failed for %S %(volume,)

System Error: pvcreate failed for fsset.partitionDevice instance at 
0x2aaaaf137170
Comment 3 Nikita Shulga 2005-06-21 06:23:09 EDT
Almost the same situation in my case. I'm trying to install FC4_x86_64 on Fujistsu-Siemens  RX200-S2, 
select automatic disk partitioning, and have almost the same backtrace, although ending with 
SystemError: lvmremove failed
Backtrace:
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 576, in turnOnFilesystems
    partitions.doMetaDeletes(diskset)
  File "/usr/lib/anaconda/partitions.py", line 1285, in doMetaDeletes
    lvm.lvremove(name, vg)
  File "/usr/lib/anaconda/lvm.py", line 143, in lvremove
    raise SystemError, "lvremove failed"
SystemError: lvremove failed

Local variables in innermost frame:
lvname: LogVol00
vgname: VolGroup00
args: ['lvm', 'lvremove', '-f', '/dev/VolGroup00/LogVol00']
dev: /dev/VolGroup00/LogVol00
rc: 1280
 
Comment 4 Nikita Shulga 2005-06-21 06:42:05 EDT
Find workaround for this problem:
Before it goes to partioning, switch to console and using fdisk remove all existing partitions
Then, when choose 'Autocreate partitions", but does not allow installer to remove all existing partitions
(since there are no partitions existing at the moment), and choose "occupy free or unallocated space"
Comment 5 Charles Elliott 2005-06-21 07:27:40 EDT
The suggestion from Nikita Shulga may well work, because if one runs the 
install twice, it gets by this step on the second try without using any 
workarounds.  But after proceeding for awhile my install failed twice -- once 
when it was trying install Mozilla and once when installing 4Suite.  Has anyone 
seen the FC4-x86_64 Fedora Core 4 installation go to completion?  If so, did 
they do anything special to get there?
Comment 6 Nikita Shulga 2005-06-21 07:36:29 EDT
I choose "Server type" of installation, and after this workaround, I had a host running FC4-x86_64.
After that I installed all the missing components using 'yum'(like xorg-x11, mozilla, etc)
Comment 7 Johann 2005-06-22 16:38:53 EDT
Same problem exactly.
I used Disk Druid to partition as follows and all worked fine afterward:
laptop with ~380MB RAM
partitions for the single hard drive:
/boot ext ~100MB
<swap> ~700MB (2x the RAM size)
/ ext =rest of disk
then, I selected "Server type" and went in and changed all the packages the way
I wanted them and started the install.
Comment 8 Charles Elliott 2005-06-23 13:30:34 EDT
I took Johann's suggestion and the install got further than it ever had before, 
but still no joy.  After Druid, it partitioned the disk and installed a file 
system.  Then it started loading packages.  At one point it said it could not 
read the CD, but offered a retry option, which worked.  Then after many minutes 
and many programs loaded, including the Linux kernel, it tried to load a 
graphical program to allow one to change the root password; the progress bar 
said the install was about 1/2 done.  The system locked up at that point.  The 
mouse was still functional, but the disk light was off and the CD-ROM drive 
door would not open.  I let it sit like that for about 10 minutes, then hit 
reset.  I tried to restart the install using the acpi=off option; the install 
said it completed successfully, but it loaded no programs, and upon reboot, the 
BIOS said there was no operating system on the disk.  As stated above, I tested 
the CD before trying the install, and it said it was OK.
Comment 9 Chris Lumens 2005-06-24 15:38:57 EDT
Charles - I believe the initial problem in your bug report is caused by a file
descriptor leak described in bug 160693 and fixed in Rawhide.  As for the
problems with loading packages off the CD, this generally indicates either bad
media (though you said the media was tested, which should rule this out), a bad
burn (perhaps burned too fast for the media, etc.), or some sort of hardware
problem.

Can you check the messages on /dev/tty3 and /dev/tty4 as well as the output of
the dmesg command to see if there are any errors reported?
Comment 10 Charles Elliott 2005-06-24 21:43:36 EDT
I agree that the problem with reading the CD is probably HW.  I am planning to 
copy the ISO files to a different hard disk and try loading from that.

What does "fixed in Rawhide" mean?

There is not enough O/S on the HD to read the messages on /dev/tty3 
or /dev/tty4 or the output of the dmesg command to see if there are any errors 
reported.  I don't have another Linux installation I can use to read the HD.

Thanks for your help.
Comment 11 Chris Lumens 2005-06-27 11:00:43 EDT
It means I've committed a fix to our development tree in CVS that I believe
fixes your problem.

You can check the messages on tty3 and tty4 by pressing ctrl-alt-f3 to get away
from X and onto tty3, then just alt-f4 to see tty4.  You can run dmesg by
switching to tty2 via a similar fashion.
Comment 12 Charles Elliott 2005-07-01 13:09:10 EDT
I tried the install again, but without success, though it got much further.  I 
verifed the first two *.iso images by downloading a copy from the Fedora cite 
and comparing them.  Then I copied them to a hard disk (HD), and placed that  
HD and another with 4.2 GB capacity on a motherboard with an AMD 64 installed.  
Then I started the install from HD using the askmethod method and Disk Druid.  
I believe the basic install procedure completed because the main progress bar 
went completely to the right side.  Although I was not watching it at the time, 
what must then have happened was that the install posted a new dialog box 
saying "Performing Post Install Configuration ... XY%."  The mouse pointer had 
changed to an hour glass and was turning upside down occasionally.  XY = 90.  
The main install program had posted a message: "Installing openldap-clients-
2.2.23-5.x86-64 (332 KB)
Client programs for openLDAP."

I let it run like that for over one-half hour, but the Post Install 
Configuratin never terminated.  I hit reset and the system rebooted; the BIOS 
loader must have found a boot record on the HD, because it said it was looking, 
then OK.  But then a message posted saying "missing operating system."  By the 
time Disk Druid had finished there was 3.8 GB on the HD on which I intended to 
install the Server version of Linux, with almost no extras.  Unless that space 
is not enough I cannot think what could be wrong.  I did not think to type crtl-
alt-f3 or alt-f4 to look at tty3, tty4, or dmesg.
Comment 13 Ari Finkelman 2005-07-08 00:36:41 EDT
I have the exact same problem on 2 different machines.  I played around with
deleting and creating partitions before I saw this post with no luck.  Just an FYI.
Comment 14 Ari Finkelman 2005-07-08 00:50:29 EDT
Update, I ended up using a free tool from seagate that wipes the hard drive. 
After I did that and reran the installer, fedora installed fine.  FYI, I had
win2k installled previously, but i never had problems installing over it with
previous versions of fedora.
Comment 15 Marcus Smith 2005-07-16 15:13:54 EDT
i used fdisk to wipe my partitions then told fc4 to use automatic 
partitioning, then use existing free space, installation was successful.
Comment 16 Charles Elliott 2005-07-17 11:41:32 EDT
I finally got FC4 to install.  As far as I know all I did was remove all HD 
partitions, repartition, and change the network setup from specifying an IP 
address to use DHCP, and the whole install process went off without a hitch -- 
EXCEPT it would not install the Grub loader.  Essentially, I ran the install 
over and over again with different options until it copied the loader to the 
HD.  I don't think the installation is any good though.  It puts out a message 
every time I boot it saying the clock is missing interrupts and probably some 
driver is hogging interrupts.  I continued to try to use it though, because it 
did not seem slow.  As I was using the Samba configuration program to get Samba 
running, the system froze.  I have officially given up, permanently.  Until I 
am prepared to come up with the $179 for a version that works, I cannot put any 
more time into it.  All I wanted to do was run the optimized version of 
Seti@Home; for the few seconds per WU that Linux would save, it just is not 
worth it.
Comment 17 Shimizu Miki 2005-07-22 01:19:08 EDT
My soln. was to install FC3 for the first time and then upgrade it through FC4
install DVD. 
In the HDD of mine Windows XP had been installed. I tried many ways of
partitioning on installation of FC4 and got the same error " File
"/usr/lib/anaconda/gui.py......"
 But FC3 had no problem at all with the same HDD. Oh I have to add I did 
"auto-partitioning" of installer selecting to delete all existing partitions.
Once FC3 was installed, upgrading to FC4 was completed.
It's easy, all I had to do was to make installation twice, to wait for doubled
time. 
But I could not be so happy about what was successful with FC3 was not with the
"upgraded" version.
Comment 18 Eric Wood 2005-08-19 03:22:36 EDT
I've had this same problem with FC4 and an original iMac with 96 MB RAM. I will now be trying wiping the 
hard drive completely before the installation!
Comment 19 Charles Elliott 2005-09-15 10:27:38 EDT
I needed the hard disk I used for this project for a windows installation.  I 
repartitioned the hard disk with Windows, but the grub loader still ran on 
boot.  This was true even after I installed DOS 6.22.  When I installed this 
disk and another in the system, the master boot record on the first disk 
appears to have been clobbered.  The first sector contains a message "Invalid 
boot record.  No operating system."  Subsequent sectors contain all zeros.  
Does anyone know if it is possible to restore the partition table on the first 
disk, or must I repartition it and start anew?
Comment 20 Jeremy Katz 2005-09-19 13:52:04 EDT

*** This bug has been marked as a duplicate of 160693 ***

Note You need to log in before you can comment on or make changes to this bug.