Bug 160693 - file descriptor leak for /tmp/biosdev, maybe causing partition table related failures
file descriptor leak for /tmp/biosdev, maybe causing partition table related ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 160387 160838 161004 161994 162149 162488 162811 162820 163225 163617 163790 164214 164360 Badd_Badd_Buggy 164967 164994 166376 166703 167198 167550 167855 167861 168366 168521 168629 168900 169354 169375 169591 169630 170104 170209 170240 170246 170255 170496 170957 171087 171095 171673 172827 173310 173765 174003 174091 174256 174610 174622 174878 174960 175041 175069 175678 175679 176668 176748 177193 178635 178693 178987 179833 180004 180752 181589 181620 181978 183532 184046 184062 184093 184218 185159 185684 185790 186328 193466 196683 197756 220801 (view as bug list)
Depends On:
Blocks: 160719 160720
  Show dependency treegraph
 
Reported: 2005-06-16 13:42 EDT by Jon Burgess
Modified: 2009-12-16 02:28 EST (History)
74 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 11:15:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Close FD leak (268 bytes, patch)
2005-06-16 13:45 EDT, Jon Burgess
no flags Details | Diff
Anaconda dump file (842.67 KB, text/plain)
2005-06-17 14:26 EDT, Jon Burgess
no flags Details
Anaconda log file (10.39 KB, text/plain)
2005-06-17 14:26 EDT, Jon Burgess
no flags Details
Part table written correctly by anaconda, but kernel update fails (1.00 KB, text/plain)
2005-06-17 14:28 EDT, Jon Burgess
no flags Details
fdisk partition table prior to install (392 bytes, text/plain)
2005-06-17 14:29 EDT, Jon Burgess
no flags Details
/proc/partitions prior to install attempt (219 bytes, text/plain)
2005-06-17 14:30 EDT, Jon Burgess
no flags Details
Process listing after anaconda fails (2.42 KB, text/plain)
2005-06-17 14:32 EDT, Jon Burgess
no flags Details
Anaconda fd's after failure, shows /tmp/biosdev & /tmp/disk left open (1.70 KB, text/plain)
2005-06-17 14:33 EDT, Jon Burgess
no flags Details
parted/libparted/linux.c (43.21 KB, text/plain)
2005-06-17 14:47 EDT, Jon Burgess
no flags Details
Anaconda Dump (841.08 KB, text/plain)
2005-10-13 22:03 EDT, Frank Bowman
no flags Details
Micro Howto update Anaconda Install system (1.80 KB, text/plain)
2006-01-21 02:38 EST, Terry Barnaby
no flags Details

  None (edit)
Description Jon Burgess 2005-06-16 13:42:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I experienced an Anaconda traceback while performing the pvcreate step and tried to debug why the pvcreate failed.
To cut a long story short, I think it may be due to a file descriptor leak in the edd code. The attached patch should fix the leak. 

I noticed that this function also leaves doesn't delete the /tmp/biosdev in several of the error cases, I don't see this causing any visible problems at the moment but perhaps the whole function should be restructured to avoid this kind of error.


Version-Release number of selected component (if applicable):
anaconda-10.2.1.5-2

How reproducible:
Always

Steps to Reproduce:
1. Installed kubuntu on the hard disk. 
2. Tried to install FC4 with all default options
3. Traceback when reaching pvcreate stage
  

Additional info:

Looking at /proc/partitions showed that the hdc2 partition which pvcreate was trying to access was only 1 block long which didn't match the new partition table (this was the size of the old partition on the disk).

It seems that the "re-read partition table" phase of the partition table update failed due to an open reference to an /dev/hdcX device.

I proved this was the problem by firing up fdisk manually and re-writing the partition table. This showed that new partition table had been written to the disk OK, but that the kernel couldn't re-read the partitions.

I couldn't find any mount point references to /dev/hdc or obvious FD'd (ls /proc/*/fd | grep hdc). 
Then I noticed that Anaconda had several open file descriptors listed for "/tmp/biosdev (deleted). It seems quite likely that this leaked file descriptor could be the thing preventing an update of the kernel partition info. 

Perhaps anaconda / parted should through an exception when it fails to re-read the partition table (fdisk manages to detect this condition)?

It looks like many of the currently open bugs could be caused by this.
It is easily worked around by simply rebooting and performing the install again (since the disk will already have the "correct" partition table).

I don't have the debug info I collected at hand to attach to the bug at the moment. Let me know if you'd like me to provide the open file descriptor lists, traceback etc.
Comment 1 Jon Burgess 2005-06-16 13:45:36 EDT
Created attachment 115557 [details]
Close FD leak 

Here is a patch which should fix the FD leak. I've not actually tested it, but
it should be fairly obvious (famous last words). The patch was generated
against an old anaconda tree, but I checked that the same problem exists in the
FC4 src RPM and it should apply cleanly.
Comment 2 Chris Lumens 2005-06-16 14:09:39 EDT
If it would be possible for you to also attach the traceback, that'd be very
helpful.  I think you're right in that this could fix a lot of the currently
open bugs (I know I've seen the problem where it crashes the first time through
partitioning but works on the second) and having the traceback would help in
finding the other bugs that could be fixed by this.
Comment 3 Jon Burgess 2005-06-17 14:26:02 EDT
Created attachment 115624 [details]
Anaconda dump file
Comment 4 Jon Burgess 2005-06-17 14:26:34 EDT
Created attachment 115625 [details]
Anaconda log file
Comment 5 Jon Burgess 2005-06-17 14:28:06 EDT
Created attachment 115626 [details]
Part table written correctly by anaconda, but kernel update fails
Comment 6 Jon Burgess 2005-06-17 14:29:41 EDT
Created attachment 115627 [details]
fdisk partition table prior to install
Comment 7 Jon Burgess 2005-06-17 14:30:51 EDT
Created attachment 115628 [details]
/proc/partitions prior to install attempt
Comment 8 Jon Burgess 2005-06-17 14:32:15 EDT
Created attachment 115629 [details]
Process listing after anaconda fails
Comment 9 Jon Burgess 2005-06-17 14:33:54 EDT
Created attachment 115630 [details]
Anaconda fd's after failure, shows /tmp/biosdev & /tmp/disk left open
Comment 10 Jon Burgess 2005-06-17 14:46:34 EDT
I tried searching through the parted code to try an locate the reason why
anaconda doesn't get told about the failure to updatre the kernel /proc/partions
and I think the problem is in the parted/libparted/linux.c  _disk_sync_part_table() 

I've attached a copy for reference.

If I understand the algorithm of this routine correctly it tries removing all
the partitions and notes any errors. It then re-adds the new partitions, but
ignores any errors with adding partitions which failed to be removed. 

In our case the /dev/hdc2 partition is busy so it ignores the request to update
the /proc/partitions and the pvcreate fails on the 512 byte /dev/hdc2 device.

Comment 11 Jon Burgess 2005-06-17 14:47:39 EDT
Created attachment 115631 [details]
parted/libparted/linux.c
Comment 12 Jeremy Katz 2005-07-08 14:22:38 EDT
*** Bug 161994 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2005-07-08 14:33:05 EDT
*** Bug 162149 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2005-07-08 14:48:12 EDT
*** Bug 162488 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Katz 2005-07-08 17:54:39 EDT
*** Bug 162811 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Katz 2005-07-12 11:12:44 EDT
*** Bug 162820 has been marked as a duplicate of this bug. ***
Comment 17 Jeremy Katz 2005-07-15 07:36:55 EDT
*** Bug 163225 has been marked as a duplicate of this bug. ***
Comment 18 Jeremy Katz 2005-07-26 00:02:51 EDT
*** Bug 163617 has been marked as a duplicate of this bug. ***
Comment 19 Jeremy Katz 2005-07-26 00:07:43 EDT
*** Bug 163790 has been marked as a duplicate of this bug. ***
Comment 20 Jeremy Katz 2005-07-26 00:19:09 EDT
*** Bug 164214 has been marked as a duplicate of this bug. ***
Comment 21 Jeremy Katz 2005-07-27 10:25:06 EDT
*** Bug 164360 has been marked as a duplicate of this bug. ***
Comment 22 Jeremy Katz 2005-07-29 11:17:38 EDT
*** Bug 160387 has been marked as a duplicate of this bug. ***
Comment 23 Jeremy Katz 2005-08-02 16:04:05 EDT
*** Bug 164923 has been marked as a duplicate of this bug. ***
Comment 24 Gerwin Krist 2005-08-03 02:02:29 EDT
*** Bug 164967 has been marked as a duplicate of this bug. ***
Comment 25 Gerwin Krist 2005-08-04 15:45:04 EDT
*** Bug 164994 has been marked as a duplicate of this bug. ***
Comment 26 Paul Johnson 2005-08-04 17:16:37 EDT
How do I install fc4 if I am afflicted by this bug?  Is there a new ISO file
somewhere?
Comment 27 Jon Burgess 2005-08-05 08:20:21 EDT
AFAIK there are no fixed iso's, but you shouldn't really need them. You've got a
couple of options to make the install work. If you've already tried the install
and had it fail once then simply repeating the install and choosing the same
disk partitioning options should make it work on the second attempt (the correct
partition table is written to the disk by the first install process and is used
successfully by the second install).

Alternatively you can zero the partition table before you start the install
using something like the rescue mode or a knoppix CD. e.g.
fdisk (empty the partition table with 'o' and then write with 'w') or by
overwriting the start of the disk,e.g. 
# dd if=/dev/zero of=/dev/hda bs=512 count=1 

Comment 28 Jeremy Katz 2005-08-22 13:17:41 EDT
*** Bug 166376 has been marked as a duplicate of this bug. ***
Comment 29 Jeremy Katz 2005-08-25 10:51:22 EDT
*** Bug 166703 has been marked as a duplicate of this bug. ***
Comment 30 Jeremy Katz 2005-09-06 11:16:17 EDT
*** Bug 167198 has been marked as a duplicate of this bug. ***
Comment 31 Jeremy Katz 2005-09-06 11:21:16 EDT
*** Bug 167550 has been marked as a duplicate of this bug. ***
Comment 32 Chris Lumens 2005-09-09 10:47:47 EDT
*** Bug 167855 has been marked as a duplicate of this bug. ***
Comment 33 Gerwin Krist 2005-09-10 07:48:32 EDT
*** Bug 167861 has been marked as a duplicate of this bug. ***
Comment 34 Jeremy Katz 2005-09-19 13:52:30 EDT
*** Bug 161004 has been marked as a duplicate of this bug. ***
Comment 35 Jeremy Katz 2005-09-19 14:11:29 EDT
*** Bug 168366 has been marked as a duplicate of this bug. ***
Comment 36 Jeremy Katz 2005-09-19 14:18:15 EDT
*** Bug 168521 has been marked as a duplicate of this bug. ***
Comment 37 Jeremy Katz 2005-09-19 15:36:42 EDT
*** Bug 168629 has been marked as a duplicate of this bug. ***
Comment 38 Jeremy Katz 2005-09-20 22:29:54 EDT
*** Bug 168900 has been marked as a duplicate of this bug. ***
Comment 39 Jeremy Katz 2005-10-03 13:43:10 EDT
*** Bug 169375 has been marked as a duplicate of this bug. ***
Comment 40 Jeremy Katz 2005-10-03 13:43:25 EDT
*** Bug 169354 has been marked as a duplicate of this bug. ***
Comment 41 Jeremy Katz 2005-10-03 14:07:19 EDT
*** Bug 169591 has been marked as a duplicate of this bug. ***
Comment 42 Jeremy Katz 2005-10-03 14:10:24 EDT
*** Bug 169630 has been marked as a duplicate of this bug. ***
Comment 43 Jeremy Katz 2005-10-03 14:10:48 EDT
*** Bug 160838 has been marked as a duplicate of this bug. ***
Comment 44 Chris Lumens 2005-10-10 10:16:16 EDT
*** Bug 170246 has been marked as a duplicate of this bug. ***
Comment 45 Chris Lumens 2005-10-10 11:04:02 EDT
*** Bug 170240 has been marked as a duplicate of this bug. ***
Comment 46 Jeremy Katz 2005-10-11 12:14:55 EDT
*** Bug 170104 has been marked as a duplicate of this bug. ***
Comment 47 Jeremy Katz 2005-10-11 12:19:56 EDT
*** Bug 170255 has been marked as a duplicate of this bug. ***
Comment 48 Sundar Pasupathy 2005-10-11 12:57:06 EDT
Hi,

  I want to close this request call for now, since I am not planning to use 
this version of Fedora now. Will wait for the next update. 

Comment 49 Chris Lumens 2005-10-13 09:34:09 EDT
*** Bug 170209 has been marked as a duplicate of this bug. ***
Comment 50 Frank Bowman 2005-10-13 22:03:43 EDT
Created attachment 119953 [details]
Anaconda Dump

Neither a re-install using the same partioning options or the zeroing of the
partion utilizing the Rescue mode solved errors being experienced. Every
installation attempt performed was made using the default options presented by
the installation gui. The attachment is a dump to floppy option presented
during the prompt when the error was experienced. The methodology of
utilization of the presented patch in an earlier response would be appreciated,
as experience levels vary among users.
Comment 51 Jeremy Katz 2005-10-15 11:07:44 EDT
*** Bug 170496 has been marked as a duplicate of this bug. ***
Comment 52 Chris Lumens 2005-10-17 10:07:32 EDT
*** Bug 170957 has been marked as a duplicate of this bug. ***
Comment 53 Chris Lumens 2005-10-18 09:43:16 EDT
*** Bug 171087 has been marked as a duplicate of this bug. ***
Comment 54 Chris Lumens 2005-10-18 09:46:17 EDT
*** Bug 171095 has been marked as a duplicate of this bug. ***
Comment 55 Jerry Roy 2005-10-18 15:57:19 EDT
(In reply to comment #50)
> Created an attachment (id=119953) [edit]
> Anaconda Dump
> Neither a re-install using the same partioning options or the zeroing of the
> partion utilizing the Rescue mode solved errors being experienced. Every
> installation attempt performed was made using the default options presented by
> the installation gui. The attachment is a dump to floppy option presented
> during the prompt when the error was experienced. The methodology of
> utilization of the presented patch in an earlier response would be 
appreciated,
> as experience levels vary among users.

So how do I fix this problem? I tried a re-install and it keeps repeating over 
and over.
Comment 56 Jon Burgess 2005-10-18 17:35:56 EDT
Based on the debugging I did when raising the original bug, i'd say that the
followings bugs might be caused by something other than this fault report.
I've scanned the debug output and my guess of what is wrong is as follows:

bug 171087 (Jerry Roy)
  The following error looks like the culprit: 
  "missing components of raid device md0.  The raid device needs 2 drive(s) and
only 1 (was/were) found. This raid device will not be started."

Was one of your partitions in a raid setup previously? 
If so then you may need to find some way of nuking the meta data from this
partition before trying the install (I think "mdadm --zero-superblock /dev/hdaX"
might do what you need).

Bug 169591 (Frank Bowman)
 In the attachment you made to this fault report (I notice that this is slightly
different to the one attached to your original fault) there are references to
VolGroup01 which looks a little odd to me. I was under the impression that the
default install created VolGroup00. There are signs that the installer tries to
destroy VolGroup01 in an effort to re-create it as VolGroup00 and it looks like
something goes wrong with this process.

You could try booting into the rescue mode and see whether this successfully
starts up the LVM. With this you could manually use remove and/or re-create the
LVM volumes before trying the install again (see man lvm). If all else fails you
could just completely blank the the whole disks (or just select partitions) with
"dd if=/dev/zero of=/dev/... ". The install really should work OK from
completely blank disks (and rules out any problems left over by previous installs).

If you're prepared to wait another month you could try the updated installer in
FC5-test1 (assuming it sticks to the published schedule). This includes the
patch to fix the original problem in this fault report.
Comment 57 Chris Lumens 2005-10-25 09:59:50 EDT
*** Bug 171673 has been marked as a duplicate of this bug. ***
Comment 58 Chris Lumens 2005-11-10 09:59:49 EST
*** Bug 172827 has been marked as a duplicate of this bug. ***
Comment 59 Jeremy Katz 2005-11-17 02:46:44 EST
*** Bug 173310 has been marked as a duplicate of this bug. ***
Comment 60 Jeremy Katz 2005-11-20 15:33:19 EST
*** Bug 173765 has been marked as a duplicate of this bug. ***
Comment 61 Jeremy Katz 2005-11-24 22:17:44 EST
*** Bug 174091 has been marked as a duplicate of this bug. ***
Comment 62 Jeremy Katz 2005-11-24 22:38:54 EST
*** Bug 174003 has been marked as a duplicate of this bug. ***
Comment 63 Jeremy Katz 2005-11-26 17:16:05 EST
*** Bug 174256 has been marked as a duplicate of this bug. ***
Comment 64 Jeremy Katz 2005-11-30 22:35:29 EST
*** Bug 174610 has been marked as a duplicate of this bug. ***
Comment 65 Jeremy Katz 2005-11-30 22:35:37 EST
*** Bug 174622 has been marked as a duplicate of this bug. ***
Comment 66 Jeremy Katz 2005-12-05 11:05:49 EST
*** Bug 174878 has been marked as a duplicate of this bug. ***
Comment 67 Jeremy Katz 2005-12-05 11:08:03 EST
*** Bug 174960 has been marked as a duplicate of this bug. ***
Comment 68 Chris Lumens 2005-12-06 09:40:27 EST
*** Bug 175069 has been marked as a duplicate of this bug. ***
Comment 69 Chris Lumens 2005-12-06 09:51:09 EST
*** Bug 175041 has been marked as a duplicate of this bug. ***
Comment 70 Chris Lumens 2005-12-14 09:50:25 EST
*** Bug 175678 has been marked as a duplicate of this bug. ***
Comment 71 Chris Lumens 2005-12-14 10:08:22 EST
*** Bug 175679 has been marked as a duplicate of this bug. ***
Comment 72 Jeremy Katz 2006-01-05 22:55:38 EST
*** Bug 176668 has been marked as a duplicate of this bug. ***
Comment 73 Jeremy Katz 2006-01-05 22:57:01 EST
*** Bug 176748 has been marked as a duplicate of this bug. ***
Comment 74 Jeremy Katz 2006-01-06 23:59:57 EST
*** Bug 177193 has been marked as a duplicate of this bug. ***
Comment 75 Terry Barnaby 2006-01-18 11:44:46 EST
I believe I have the same problem when installing on a dual processor SMP system
with twin SCSI disks using a number of RAID1 partitions. The system has FC3
already installed and running and all I want to do is install FC4 on the /
partition. I am only setting the partition mount points using the manual
partition table editor but I still get the "error informing kernel ..." bug.
As this is a file system server and a number of the partitions contain valuable
data I don't wan't to clear the partition table entries.

Is there an updated Fedora-4 boot.iso image that fixes this problem ?
Is there any other way I can install FC4 on this system ?
Comment 76 Terry Barnaby 2006-01-21 02:34:01 EST
I tried applying the Anaconda /tmp/biosdev patch as mentioned earlier in this
bug info to my FC4 installation images (stage2.img, netstg2.img and hdstg2.img).
This did not cure my problem with my problem system (Other systems I have
install fine).
In my case when the error "Error informing the kernel about modifications to
partition ..." occurs, the anaconda program has a file descriptor open to
/dev/sda (I have two SCSI disks /dev/sda and /dev/sdb). I have traced this "fd
leak" to
occuring just after the start installation screen, after "enablefilesystems" so
presumably in packages.py turnOnFilesystems().
I had to get my server working so I did not have time to trace this further.
In my case I was updaing a FC3 installation by just re-installing FC4 on an
existing partition and so no partition table changes were actually needed. So I
got around this bug by commenting out the line: "disk.commit()" in the
savePartitions() function in partedUtils.py.
A quick howto for those who want to do this is attached.
Comment 77 Terry Barnaby 2006-01-21 02:38:48 EST
Created attachment 123521 [details]
Micro Howto update Anaconda Install system
Comment 78 Chris Lumens 2006-01-22 22:44:19 EST
*** Bug 178635 has been marked as a duplicate of this bug. ***
Comment 79 Jeremy Katz 2006-01-28 00:34:38 EST
*** Bug 178693 has been marked as a duplicate of this bug. ***
Comment 80 Jeremy Katz 2006-01-28 00:44:01 EST
*** Bug 178987 has been marked as a duplicate of this bug. ***
Comment 81 Jeremy Katz 2006-02-03 11:14:09 EST
*** Bug 179833 has been marked as a duplicate of this bug. ***
Comment 82 Chris Lumens 2006-02-04 22:47:20 EST
*** Bug 180004 has been marked as a duplicate of this bug. ***
Comment 83 Jeremy Katz 2006-02-10 20:42:39 EST
*** Bug 180752 has been marked as a duplicate of this bug. ***
Comment 84 Jeremy Katz 2006-02-15 14:49:33 EST
*** Bug 181589 has been marked as a duplicate of this bug. ***
Comment 85 Jeremy Katz 2006-02-15 14:58:07 EST
*** Bug 181620 has been marked as a duplicate of this bug. ***
Comment 86 Jeremy Katz 2006-02-20 15:46:27 EST
*** Bug 181978 has been marked as a duplicate of this bug. ***
Comment 87 Jeremy Katz 2006-03-02 20:31:01 EST
*** Bug 183532 has been marked as a duplicate of this bug. ***
Comment 88 Chris Lumens 2006-03-06 09:59:53 EST
*** Bug 184062 has been marked as a duplicate of this bug. ***
Comment 89 Jeremy Katz 2006-03-06 12:04:03 EST
*** Bug 184046 has been marked as a duplicate of this bug. ***
Comment 90 Jeremy Katz 2006-03-07 10:17:54 EST
*** Bug 184218 has been marked as a duplicate of this bug. ***
Comment 91 Charles Elliott 2006-03-07 14:53:06 EST
(In reply to comment #27)
> AFAIK there are no fixed iso's, but you shouldn't really need them. You've 
got a
> couple of options to make the install work. If you've already tried the 
install
> and had it fail once then simply repeating the install and choosing the same
> disk partitioning options should make it work on the second attempt (the 
correct
> partition table is written to the disk by the first install process and is 
used
> successfully by the second install).
Nuts!  This simply does not work!  Redhat is required by its license to have a 
working distribution of any version it sells available for download.  And it 
does not.  Redhat needs the money it charges for a 64-bit version of Linux; it 
is not going to give away a working version of 64-bit Linux until the revenue 
picture clears up.
Comment 92 Jon Burgess 2006-03-07 15:37:55 EST
> Nuts!  This simply does not work!
> Redhat is required by its license to have a 
> working distribution of any version it sells available
> for download.  And it does not.

I wrote the original comment that you referenced I feel I should respond. 
I'll try to stick to the facts. I should start by saying that i've got no 
connection with RedHat except than to use Fedora on multiple machines 
on a daily basis.

The word I disagree with in your comment is "working". 
The sources to the shipping FC4 anaconda file are available, 
which fulfills the license terms. 

*No one* guarantees that it is bug free or will work for you.

> Redhat needs the money it charges for a 64-bit version of Linux;
> it is not going to give away a working version of 64-bit Linux 
> until the revenue picture clears up.

I'm writing this right now on my 64-bit FC4 machine
which has been working fine for me.

Redhat have fixed this bug in the FC5 tree and in an RHEL4 update.
Both of which are the next releases of the respective products.
The anaconda sources for both OS's are available for download.
Since FC5 hasn't been released yet, you'll have to grab them from
the development tree.

FWIW - I'd like to see fixed up FC4 ISO's available too,
but it won't happen.

If you read the archives of the Fedora mailing lists you'll see that the
trade-offs involved with re-spinning the ISO's vs waiting for the next release
have been discussed several times.
Comment 93 Jerry Roy 2006-03-07 16:29:26 EST
I have the FC5 Test 2 ISO's Will the fixes be in these disks? 

Since I am not a Linux Guru and cannot afford the time to learn all the issues 
right now. Can you help me?
I am not sure what I need off your site to get this working with the FC4. Can 
you tell me specifically what files I should download and where to download 
these from to fix this issue?

Thanks,

Jerry Roy
jroy@goremote.com
(In reply to comment #55)
> (In reply to comment #50)
> > Created an attachment (id=119953) [edit] [edit]
> > Anaconda Dump
> > Neither a re-install using the same partioning options or the zeroing of the
> > partion utilizing the Rescue mode solved errors being experienced. Every
> > installation attempt performed was made using the default options presented 
by
> > the installation gui. The attachment is a dump to floppy option presented
> > during the prompt when the error was experienced. The methodology of
> > utilization of the presented patch in an earlier response would be 
> appreciated,
> > as experience levels vary among users.
> So how do I fix this problem? I tried a re-install and it keeps repeating 
over 
> and over.

Comment 94 Jerry Roy 2006-03-07 16:30:10 EST
I have the FC5 Test 2 ISO's Will the fixes be in these disks? 

Since I am not a Linux Guru and cannot afford the time to learn all the issues 
right now. Can you help me?
I am not sure what I need off your site to get this working with the FC4. Can 
you tell me specifically what files I should download and where to download 
these from to fix this issue?

Thanks,

Jerry Roy
jroy@goremote.com
(In reply to comment #55)
> (In reply to comment #50)
> > Created an attachment (id=119953) [edit] [edit]
> > Anaconda Dump
> > Neither a re-install using the same partioning options or the zeroing of the
> > partion utilizing the Rescue mode solved errors being experienced. Every
> > installation attempt performed was made using the default options presented 
by
> > the installation gui. The attachment is a dump to floppy option presented
> > during the prompt when the error was experienced. The methodology of
> > utilization of the presented patch in an earlier response would be 
> appreciated,
> > as experience levels vary among users.
> So how do I fix this problem? I tried a re-install and it keeps repeating 
over 
> and over.

Comment 95 Jon Burgess 2006-03-07 17:19:22 EST
My best advice would be to wait a week for the formal FC5 release 
and then use that. This assumes things are still keeping to the
published schedule at http://fedora.redhat.com/About/schedule/

If you've not had any experience with installing a test releases
before then it is probably too late now to install it and hope 
to get any useful feedback for the FC5 release.

While it is possible to download the fixes and rebuild things 
yourself to fix FC4. I wouldn't advise doing it. 
I've not done it myself and i'm afraid I don't have the time
to try to discuss all the steps involved.

For one reference to someone that has done something like this see
http://www.redhat.com/archives/fedora-devel-list/2005-September/msg00314.html
You might find some of the replies interesting too.
Note: AFAICT these respun CD's DO NOT have the anaconda fix
for this bug, but they do have other bugs fixed.

Again, personally, i'd wait for FC5.
Comment 96 Chris Lumens 2006-03-13 11:14:30 EST
*** Bug 185159 has been marked as a duplicate of this bug. ***
Comment 97 Jeremy Katz 2006-03-13 13:55:56 EST
*** Bug 184093 has been marked as a duplicate of this bug. ***
Comment 98 Chris Lumens 2006-03-20 12:56:15 EST
*** Bug 185684 has been marked as a duplicate of this bug. ***
Comment 99 Jeremy Katz 2006-03-21 11:24:35 EST
*** Bug 185790 has been marked as a duplicate of this bug. ***
Comment 100 Richard Chaffer 2006-03-24 07:24:45 EST
*** Bug 186328 has been marked as a duplicate of this bug. ***
Comment 101 Chris Lumens 2006-05-30 11:28:10 EDT
*** Bug 193466 has been marked as a duplicate of this bug. ***
Comment 102 Jeremy Katz 2006-07-10 20:24:01 EDT
*** Bug 197756 has been marked as a duplicate of this bug. ***
Comment 103 Chris Lumens 2006-07-21 15:49:43 EDT
*** Bug 196683 has been marked as a duplicate of this bug. ***
Comment 104 Jeremy Katz 2007-01-03 13:55:13 EST
*** Bug 220801 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.