Bug 1611944 - [RGW:NFS] Using 'dd' for writing large files on the NFS, fails.
Summary: [RGW:NFS] Using 'dd' for writing large files on the NFS, fails.
Keywords:
Status: CLOSED DUPLICATE of bug 1418606
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: 4.0
Assignee: Matt Benjamin (redhat)
QA Contact: Vidushi Mishra
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-03 06:38 UTC by Vidushi Mishra
Modified: 2019-02-20 14:46 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-20 14:46:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vidushi Mishra 2018-08-03 06:38:49 UTC
Description of problem:

Cannot write a large size file on the NFS mount when using 'dd' utility. 

[root@host ubuntu]# mount -osync -t nfs -o nfsvers=4,noauto,soft,proto=tcp nfs_server:/ nfs1
[root@host ubuntu]# ls nfs1/cephobject/
cephnfs.bucky.0  cephnfs.bucky.1  test

[root@host cephobject]# cd test/
[root@host test]#  dd if=/dev/urandom of=file2 bs=10M count=300
dd: error writing ‘file2’: Input/output error
59+0 records in
58+0 records out
608174080 bytes (608 MB) copied, 29.4651 s, 20.6 MB/s



Version-Release number of selected component (if applicable):

ceph version 12.2.5-37.el7cp
nfs-ganesha-rgw-2.5.5-100.el7cp.x86_64
nfs-ganesha-2.5.5-100.el7cp.x86_64


How reproducible:
2/2

Steps to Reproduce:
1. Configure NFS server on an RGW  and configure NFS client and mount share with NFSv3 or NFSv4.
2. Create a file and write say 3G of data using 'dd'
3. Operation fails with IO error.

Comment 3 Drew Harris 2019-02-20 14:46:59 UTC

*** This bug has been marked as a duplicate of bug 1418606 ***


Note You need to log in before you can comment on or make changes to this bug.