Bug 1418606 - Decompressing files with GNU tar in NFS mount gives error
Summary: Decompressing files with GNU tar in NFS mount gives error
Status: ASSIGNED
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 5.0
Assignee: Matt Benjamin (redhat)
QA Contact: ceph-qe-bugs
Bara Ancincova
URL:
Whiteboard:
Keywords:
: 1611944 (view as bug list)
Depends On:
Blocks: 1412948 1437916 1494421
TreeView+ depends on / blocked
 
Reported: 2017-02-02 10:28 UTC by Ramakrishnan Periyasamy
Modified: 2019-03-25 18:55 UTC (History)
13 users (show)

(edit)
.The GNU tar utility currently cannot extract archives directly into the Ceph Object Gateway NFS mounted file systems 

The current version of the GNU tar utility makes overlapping write operations when extracting files. This behavior breaks the strict sequential write restriction in the current version of the Ceph Object Gateway NFS. In addition, GNU tar reports these errors in the usual way, but it also by default continues extracting the files after reporting the errors. As a result, the extracted files can contain incorrect data.

To work around this problem, use alternate programs to copy file hierarchies into the Ceph Object Gateway NFS. Recursive copying by using the `cp -r` command works correctly. Non-GNU archive utilities might be able to correctly extract the tar archives, but none have been verified.
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)

Description Ramakrishnan Periyasamy 2017-02-02 10:28:11 UTC
Description of problem:

Decompression of folder in NFS mount fails with errors.

Tried compressing files using zip and tar which worked but while trying to decompress the folder and files, they are decompressed but command gives error message. This problem is there with zip/tar files but there is no errors observed in normal Linux directory.

[ubuntu@host003 nfs_mount]$ tar -xvf old.tar 
old/
old/l
old/k
old/h
old/a
old/e
old/i
old/j
old/b
old/f
old/d
old/g
old/c
tar: old: Cannot utime: Input/output error
tar: Exiting with failure status due to previous errors

[ubuntu@host003 nfsuser_s3_dir]$ unzip old.zip
Archive:  old.zip
   creating: old/
chmod (directory attributes) error: Input/output error
warning:  cannot set modif./access times for old/
          Input/output error
warning:  cannot set permissions for old/
          Input/output error
warning:  set times/attribs failed for old/
     failed setting times/attribs for 1 dir entries[ubuntu@magna003 nfsuser_s3_dir]$ ls


Version-Release number of selected component (if applicable):
Ceph: 10.2.5-18.el7cp (6d6e431ef9e773beaa8ddc28b6c552d6f813b36a)
rgw: nfs-ganesha-rgw-2.4.2-1.el7cp.x86_64

How reproducible:
2/2

Steps to Reproduce:
1. Configure Ceph Cluster, RGW and NFS ganesha
2. Mount NFS mount to a client
3. Create some files and folders in NFS mount point
4. Compress one folder and decompress it using zip and tar.

Actual results:
decompression of folders and files works but there are error messages

Expected results:
There should not be any error message and data corruption

Additional info:
Do we have support for most options in zip ?, tried some options and its not compressing folder.

Comment 21 Drew Harris 2019-02-20 14:46:59 UTC
*** Bug 1611944 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.