Bug 161269 - minor regression in consolehelper behavior when running apps as root
minor regression in consolehelper behavior when running apps as root
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-21 18:11 EDT by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: pam-0.79-9.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-01 04:13:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2005-06-21 18:11:59 EDT
Description of problem:
open a terminal as a regular user
su   into root user account
run system-config-*  applications or anything else controlled by consolehelper
and receive X server connection errors

Seeing this on a updated fc4 machine
Not seeing this on an updated fc3 machine.
su -  has no problem, but thats because we end up seeing the actually binaries
in the sbin directories instead of the consolehelper symlinks in /usr/bin

Version-Release number of selected component (if applicable):
usermode-1.80-1

How reproducible:
everytime 

Steps to Reproduce:
1. login as user
2. open terminal
3. su 
4. >system-config-network

  
Actual results:
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

ERROR: Unable to initialize graphical environment. Most likely cause of failure
is that the tool was not run using a graphical environment. Please either start
your graphical user interface or set your DISPLAY variable.


Expected results:
should open up the networking app

Additional info:
works fine as a regular user, prompts for root password and away we go

Potentially related to the sudo issues raised in bug 142648 except i'm not
seeing this on my fc3 machines where the sudu bug originated.


Please inform me of any additional logging information to add or testing steps
you'd like me to perform.

-jef
Comment 1 Jef Spaleta 2005-06-21 20:01:31 EDT
Did some additional testing. I can not reproduce this problem on my rawhide
synced box, which is obstensibly the same exact version of usermode. I'm only
seeing it on my fresh install + updates fc4 boxes. I dont have a fresh install
without updates to test against.

I'm not sure where the difference between rawhide and fc4 could actually be.
Could it be the pam package?

-jef
Comment 2 Jindrich Novy 2005-06-22 09:08:54 EDT
Hello Jef,

I'm not quite sure userhelper is the culprit here. As far as I remember I saw a
similar behavior with broken sudo some time ago.

Karel, any words of wisdom?
Comment 3 Jef Spaleta 2005-06-22 09:23:37 EDT
so... is it possibly a broken  su from the coreutils package?

Hmmm let me see if i can get that rawhide coreutils installed on this fc4 box
nope  installing the rawhide coreutils doesn't make this go away.

hmmm let me see if i install pam from rawhide.
Holy bat guano!  installing pam-0.79-10  from the development tree makes the
issue go away. So I guess it should be filed as a pam bug.

Shall i reassign it?

-jef
Comment 4 Jindrich Novy 2005-06-22 09:38:27 EDT
This seems to be a good idea, reassigning to PAM.
Comment 5 Tomas Mraz 2005-06-22 15:10:56 EDT
Known bug. I'm still waiting for updated audit package in FC4 before rebuilding PAM.
Comment 6 Tomas Mraz 2005-07-01 04:13:21 EDT
Please update audit-libs and pam from updates-testing repo. The updated PAM
package should fix the problem.

Note You need to log in before you can comment on or make changes to this bug.