Bug 1612782 - creation of block volume is failing, but device storage is getting used
Summary: creation of block volume is failing, but device storage is getting used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: cns-3.10
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.10
Assignee: Madhu Rajanna
QA Contact: krishnaram Karthick
URL:
Whiteboard:
Depends On:
Blocks: 1568862
TreeView+ depends on / blocked
 
Reported: 2018-08-06 09:15 UTC by Madhu Rajanna
Modified: 2019-08-20 06:08 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, if the first block volume creation failed the block hosting volume was deleted but free space amount was not updated. This fix updates the free size if block volume creation fails.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:23:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
heketi_logs_after_blockvolumecreate_failed (34.46 KB, text/plain)
2018-08-16 18:15 UTC, krishnaram Karthick
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:25:05 UTC

Description Madhu Rajanna 2018-08-06 09:15:34 UTC
Description of problem:

creation of block volume is failing, but device storage is getting used


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.stop gluster-blockd service in gluster nodes(containers)
2.create block volumes


Actual results:

block volume creation is failing, but device space is getting utilized

Expected results:
if block volume creation fails, heketi should clean up the utilized bricks and reclaim device space


Additional info:

Comment 2 Madhu Rajanna 2018-08-06 09:17:34 UTC
upstream issue link https://github.com/heketi/heketi/issues/1258

upstream fix link https://github.com/heketi/heketi/pull/1295

Comment 9 krishnaram Karthick 2018-08-16 18:15:24 UTC
Created attachment 1476487 [details]
heketi_logs_after_blockvolumecreate_failed

Comment 10 Anjana KD 2018-08-31 00:21:27 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 11 Madhu Rajanna 2018-09-07 18:23:38 UTC
looks good to me

Comment 13 errata-xmlrpc 2018-09-12 09:23:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686


Note You need to log in before you can comment on or make changes to this bug.