Bug 1612784 - after node delete from heketi, mount point,backup-volfile-servers in volumes contains removed node IP
Summary: after node delete from heketi, mount point,backup-volfile-servers in volumes ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: cns-3.10
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.10
Assignee: Madhu Rajanna
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks: 1568862
TreeView+ depends on / blocked
 
Reported: 2018-08-06 09:21 UTC by Madhu Rajanna
Modified: 2019-08-20 06:08 UTC (History)
11 users (show)

Fixed In Version: heketi-7.0.0-6.el7rhgs
Doc Type: Bug Fix
Doc Text:
Previously, volume mount options were not updated to remove node references after removing a node from the heketi configuration. With this fix, references to remove nodes are removed from volume mount options and backup-volfile-servers options.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:23:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:24:40 UTC

Description Madhu Rajanna 2018-08-06 09:21:37 UTC
Description of problem:

after node delete from heketi. Hosts, mountpoint, and backup-volfile-servers fields in volumes info response contains removed node IP


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1)load topology in heketi (it has 3 nodes)
2)create 4 volumes
3)add a new node to heketi
4)disable one old node in heketi
5)remove the same node
6)remove devices
7)delete the node from heketi
8)check volume info on old volumes


Actual results:

volume info is having the deleted node IP

Expected results:

volume Info should be updated with new IP

Additional info:

Comment 2 Madhu Rajanna 2018-08-06 09:22:42 UTC
upstream issue link https://github.com/heketi/heketi/issues/1274
patch link https://github.com/heketi/heketi/pull/1294

Comment 10 Anjana KD 2018-08-31 00:26:47 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 12 Anjana KD 2018-09-07 18:06:57 UTC
Thankyou John, I have updated it.

Comment 14 errata-xmlrpc 2018-09-12 09:23:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686


Note You need to log in before you can comment on or make changes to this bug.