Bug 1612786 - Newly created block volume info showing deleted node IP
Summary: Newly created block volume info showing deleted node IP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: cns-3.10
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.10
Assignee: Madhu Rajanna
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks: 1568862
TreeView+ depends on / blocked
 
Reported: 2018-08-06 09:26 UTC by Madhu Rajanna
Modified: 2019-08-20 06:08 UTC (History)
12 users (show)

Fixed In Version: heketi-7.0.0-6.el7rhgs
Doc Type: Bug Fix
Doc Text:
Previously, if a node was removed from heketi management, that node was still considered for block volume creations because the node's status was not updated in the hosts of already created block volume. With this fix, once the node is deleted from heketi management, the hosts in all created block volumes are updated. This ensures only hosts present in heketi management are considered for block volume creation.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:23:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:24:40 UTC

Description Madhu Rajanna 2018-08-06 09:26:38 UTC
Description of problem:

I have done node deletion in heketi and created a new block volume, but new block volume info contains the removed node IP


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
`)add a new node to heketi
2)disable one old node in heketi
3)remove the same node
4)remove devices
5)delete the node from heketi
6)create the new volume (check vol info)



Actual results:
Newly created block volume is having removed node IP

Expected results:

heketi should pick up the node IP from the heketi cluster, newly created volume should have contains removed node IP

Additional info:

Comment 2 Madhu Rajanna 2018-08-06 09:27:45 UTC
upstream issue link: https://github.com/heketi/heketi/issues/1273
upstream patch link: https://github.com/heketi/heketi/pull/1294

Comment 9 Anjana KD 2018-08-31 00:29:40 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 10 Anjana KD 2018-09-07 12:31:58 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 11 Madhu Rajanna 2018-09-07 12:35:45 UTC
looks good for me

Comment 13 errata-xmlrpc 2018-09-12 09:23:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686


Note You need to log in before you can comment on or make changes to this bug.