Bug 161279 - distorted sound with es1371
distorted sound with es1371
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-21 19:31 EDT by nezihkartal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 02:58:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nezihkartal 2005-06-21 19:31:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 SUSE/1.0.4-1.1

Description of problem:
all actions i do (for example click to windows, maximize or minimize them, when browser is loading pages, scroll pages etc.), make a distortion when a player works. i've tried all outputs of xmms. i've tried all suggestions from forums, help ircs... that distortion really bothers me. i also experienced this problem in fc3 and so i've been using suse for a year, problemless. i've used suse 7.1~9.2, redhat 8 and 9, fedora 1-2, knoppix 3.2~3.9. i got this problem just on fc3 and fc4. i had counted days down from fc3 to fc4. that is to say fc4 gives my hopes up, too. maybe it can be solved, but i couldnt. please help me! i dont wanna use any other distro. i would love to use fedora...

amd athlon 1ghz
256mb ram
38gb seagate
ensoniq es1371 onboard
geforce2 mx 400 (asus 7100)

Version-Release number of selected component (if applicable):
alsa-lib-1.0.9rc4-2

How reproducible:
Always

Steps to Reproduce:
1.make a fresh install fc3 or fc4.
2.alt+tab, click, scroll pages or let a browser load a web page, during a music player works

Actual Results:  it bothers me.

Expected Results:  an action must not affect to another action. for example, browsing a site or browsing my files or working with openoffice.org, must not occur distortion during playing a music file. maybe it can make something else that i dont notice.

Additional info:
Comment 1 Martin Stransky 2005-06-22 04:49:17 EDT
I suppose you have tried to mute all recording channels, you have
examined all output channels (like headphone, line out...) and nothing
have helped you. 

You can try to spend more time with exploring all channels in
alsamixer or you can try to install old drivers for your card (from
FC2, it was alsa-drivers 1.0.2 or 1.0.3a), mybee it'll work better
than new ones.
Comment 2 nezihkartal 2005-06-22 07:35:45 EDT
(In reply to comment #1)
> I suppose you have tried to mute all recording channels, you have
> examined all output channels (like headphone, line out...) and nothing
> have helped you. 
> 
> You can try to spend more time with exploring all channels in
> alsamixer or you can try to install old drivers for your card (from
> FC2, it was alsa-drivers 1.0.2 or 1.0.3a), mybee it'll work better
> than new ones.

it looks like a downgrade. already, i'm not sure it's involved with alsa-lib,
alsa-driver, etc. maybe it's about x.org's nv driver???

ok i'll try. i'm using suse now. i must backup my files up and install fedora.
Comment 3 Herbert Rutledge 2005-06-23 18:58:30 EDT
I'm experiencing the same problem with the same sound card.  The symptom
resembles digital clipping when sound files are played back from within the
desktop.  It happens with sounds associated with desktop events and also sound
when played from within Firefox.  CDs play fine.  This happens regardless of
whether recording channels are active or muted.

Downgrading to the versions of alsa-lib and alsa-utils from FC2 solved the problem.

The .wav files in /usr/share/sounds play cleanly with the play command, and also
when the Play button is pressed from the Sound Events tab in the Sound
preferences window.

This also happened during FC4 Test 3 when the current alsa-lib and alsa-utils
packages were first released.  At that time, installing the libsamplerate and
libsndfile packages lessened, but did not entirely eliminate, the problem.  This
time, the installation of these two packages from Extras had no effect.

I created a test user, and experienced the same problem from that account, so I
don't think it is related to any previously existing GNOME settings.  
Comment 4 nezihkartal 2005-06-24 10:43:25 EDT
(In reply to comment #3)
> I'm experiencing the same problem with the same sound card.  The symptom
> resembles digital clipping when sound files are played back from within the
> desktop.  It happens with sounds associated with desktop events and also sound
> when played from within Firefox.  CDs play fine.  This happens regardless of
> whether recording channels are active or muted.
> 
> Downgrading to the versions of alsa-lib and alsa-utils from FC2 solved the
problem.
> 
> The .wav files in /usr/share/sounds play cleanly with the play command, and also
> when the Play button is pressed from the Sound Events tab in the Sound
> preferences window.
> 
> This also happened during FC4 Test 3 when the current alsa-lib and alsa-utils
> packages were first released.  At that time, installing the libsamplerate and
> libsndfile packages lessened, but did not entirely eliminate, the problem.  This
> time, the installation of these two packages from Extras had no effect.
> 
> I created a test user, and experienced the same problem from that account, so I
> don't think it is related to any previously existing GNOME settings.  
> 

hi, Herbert. my main language isn't english, and so i dont have a great english,
sorry. do you recommend just downgrading alsa-lib and alsa-utils to versions
like fc2's, or installing libsamplerate and libsndfile from extras of fc4? and
my second question is "have you ever tried alsa-lib and alsa-utils that in the
fc4 updates"? i didnt reinstall fc4 again. because i dont wanna to live the same
dissapointment. i'm waiting for an exact solve of my problem.

hi, Martin. do you think that you would release an update that solve this problem?

thanx for you...
Comment 5 Herbert Rutledge 2005-06-24 11:05:53 EDT
Install the following packages from FC2:

alsa-lib-1.0.3a-2.i386.rpm alsa-lib-devel-1.0.3a-2.i386.rpm
alsa-utils-1.0.3-1.i386.rpm

The libsamplerate and libsndfile packages have no effect, so I wouldn't
bother installing them.

The FC4 updated packages for alsa-lib and alsa-utils don't fix the
problem.
Comment 6 Martin Stransky 2005-06-27 11:06:54 EDT
Or you try to use old-style card config, it'll bypass dmix and it uses
only HW device. Remove all lines from /etc/asound.conf and write there:

pcm.!default { type hw card 0 }
ctl.!default { type hw card 0 }
Comment 7 nezihkartal 2005-06-27 13:08:04 EDT
i want innovation. all suggestions are DOWNgrade, OLD-style, FC2, FC1....

why did i download FC4 (and FC3 last year). i've a 256kb adsl line. they took my
a lot of time. did i download them for downgrading. you don't even aggre my
problem as a bug. i read fc5 news on these days.

http://distrowatch.com/weekly.php?issue=20050627#upcoming
http://www.fedoraproject.org/wiki/FC5Future

fix bugs, before release fc5. i'm downloading suse 9.3 now. i wont install fc4
until release an 'UP'date for my problem.
Comment 8 Bill Case 2005-07-01 16:16:56 EDT
I have the same problem with the same card, with the extra twist that
tvtime/bttv seems to take over my mixer and keeps returning line-in to unmuted.
 Although tvtimes is configured for PCM it only produces sound on line-in.  

Regards Bill
Comment 9 nezihkartal 2005-07-01 21:29:02 EDT
hi, i read alsa description of Suse 9.3 updates. description says "fixed noises
with dmix plugin and xmms" (in fact, i've never experienced that problem in
suse), but really alsa had that problem in previous versions. you can find that
text in this url :

http://www.novell.com/linux/download/updates/93_i386.html

why doesnt alsa 1.0.9 update of fedora 4, fix that problem?
Comment 10 Bill Case 2005-07-02 09:43:23 EDT
[additional info]  When I saw the amount of info being sent for this bug, I
thought I had better include all of mine.  So here goes:

My main specific problem is that I can't get some apps to use PCM and I believe
that that stems from the scratchy sound problem.

On 'line-in' my speakers hiss and squawk and the event sounds are terrible but I
have no background noise problems when 'line-in' is muted and PCM is open.
tvtimes keeps reverting to line-in.
Audacity gives error: "There was an error initializing the audio i/o layer. ..."
Every time I logon, PCM gets muted in my mixer gui.
CD's play fine.
My tvtimes configuration file /etc/tvtime/tvtime.xml is set to <option
name="MixerDevice" value="/dev/mixer:pcm"/>

Soundcard detection responds with the test sound + a very scratch background.

gstreamer-properties gui (Multimedia Systems Selector) test gives me the following:

With PCM on and 'line-in ' muted:
Output ALSA pipeline alsasink = good clear sound.
Input ALSA pipeline alsasrc = no sound (crashes gui)

With PCM muted and 'line-in ' on:
Output ALSA pipeline alsasink = sound + hissing background.
Input ALSA pipeline alsasrc = no sound (crashes gui)

When I run the above gstreamer-properties test as root user, I get no alsasink
or alsasrc recognition at all.

permissions on /dev/dsp /dev/audio /dev/mixer all  crw-------

At startup, from dmesg during udev initialization audio is intialized on bttv
and audio takes an ucommonly long time to get set.  
My understanding is that it should start with ALSA.

I have just clean installed Fedora Core 4 . Under FC3 I didn't have a memorable
sound problem, but, then I wasn't looking.

I am using P4 on a Intel 82850 motherboard, Ensoniq 5889 AudioPCI sound card and an
ATI TV Wonder tuner. Also listed is Brooktree Bt878 video capture and Bt878
audio capture.

I ran lsmod | grep ^snd and got the following:
snd_ens1371 31649 1
snd_rawmidi 30305 1 snd_ens1371
snd_ac97_codec 75961 1 snd_ens1371
snd_seq_dummy 3653 0
snd_seq_oss 37057 0
snd_seq_midi_event 9153 1 snd_seq_oss
snd_seq 62289 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 8781 4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 51185 0
snd_mixer_oss 17857 1 snd_pcm_oss
snd_pcm 100169 3 snd_ens1371,snd_ac97_codec,snd_pcm_oss
snd_timer 33605 2 snd_seq,snd_pcm
snd 57157 12 snd_ens1371,snd_rawmidi,snd_ac97_codec,snd_seq_oss
,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss, snd_pcm,snd_timer
snd_page_alloc 9669 1 snd_pcm

plus; soundcore 10913 1 snd

plus;
bt878 10457 0
tuner 27121 0
bttv 161393 1 bt878
video_buf 23749 1 bttv
i2c_algo_bit 9289 1 bttv
v4l2_common 5825 1 bttv
btcx_risc 4937 1 bttv
tveeprom 13017 1 bttv
videodev 9537 1 bttv

and; /dev/dsp /dev/mixer /dev/audio

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: AudioPCI [Ensoniq AudioPCI], device 1: ES1371/2 [ES1371 DAC1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 25 [81%] [on]
  Front Right: Playback 25 [81%] [on]
Simple mixer control 'Master Mono',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
Simple mixer control '3D Control - Switch',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control '3D Control Sigmatel - Depth',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Limits: 0 - 3
  Mono: 0 [0%]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 26 [84%] [on]
  Front Right: Playback 26 [84%] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [off] Capture [on]
  Front Right: Playback 0 [0%] [off] Capture [on]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [on] Capture [off]
  Front Right: Playback 0 [0%] [on] Capture [off]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Mic Select',0
  Capabilities:
  Mono:
Simple mixer control 'Video',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [on] Capture [off]
  Front Right: Playback 0 [0%] [on] Capture [off]
Simple mixer control 'Phone',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'PC Speaker',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 15
  Mono: Playback 0 [0%] [off]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [off] Capture [off]
  Front Right: Playback 0 [0%] [off] Capture [off]
Simple mixer control 'Mono Output Select',0
  Capabilities:
  Mono:
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [off]
  Front Right: Capture 0 [0%] [off]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Sigmatel 4-Speaker Stereo',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Sigmatel Surround Phase Inversion Playback ',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

I have moved my sound and TV cards to new slots and securely reset all my
speaker leads.  My Windows XP set up works perfectly with the following settings:

WindowsXP
Vol Control:  40%
Wave: 40%
SW Synth: 95%
Line-in: Mute
CD Audio: 50%

I have played around with my mixer settings so often I no longer remember the
original installed settings. 

I am flumexed.

Comment 11 Herbert Rutledge 2005-07-02 20:02:43 EDT
I simply modified asound.conf as suggested previously with:

pcm.!default { type hw card 0 }
ctl.!default { type hw card 0 }

This solved all problems.
Comment 12 nezihkartal 2005-07-03 00:42:06 EDT
(In reply to comment #11)
> I simply modified asound.conf as suggested previously with:
> 
> pcm.!default { type hw card 0 }
> ctl.!default { type hw card 0 }
> 
> This solved all problems.

did any difference occur in sound quality? i meant that if the sound quality
decrease?
Comment 13 Marc Williams 2005-07-17 09:03:30 EDT
Well I'll be!  Kindred spirits!

I too have the es1371 built-in motherboard on a new machine and have the exact
same symptoms as described in this bug.  Scratchy, distorted system sounds and
browser sounds.  I applied the asound.conf workaround described earlier and it
seems to have fixed the problem.  Unlike a couple others here, I don't recall
having this issue with FC3, just FC4.
Comment 14 Bill Case 2005-07-17 16:49:01 EDT
I too applied the assound.conf workaround and it fixed one of my sound problems
temporarily.  At the risk of looking real stupid, something keeps changing it
back.  I am not sure whether the revision is time driven or when I login in and
out.  I have not used system-config-soundcard which is supposed to set up
asound.conf.  Secondly, googleing tells me that I should have have PCM-2 for a
second PCM channel with Ensoniq 5880 but I can't seem to create it.  Thirdly the
ALSA site clearly states that I should 	chmod a+rw /dev/dsp /dev/mixer
/dev/sequencer /dev/midi to replace the crw---------.  This also keeps getting
changed back.

I have looked for a day for a permissions module that might be responsible, but
I am none the wiser. 
Comment 15 Martin Stransky 2005-08-02 02:42:02 EDT
Added new HW switch to c-s-c (in rawhide) to bypass dmix.
Comment 16 nezihkartal 2005-08-03 00:51:13 EDT
(In reply to comment #15)
> Added new HW switch to c-s-c (in rawhide) to bypass dmix.

hi,
where/what is rawhide? how can i use it?
Comment 17 nezihkartal 2005-08-09 05:43:38 EDT
six days passed after my last question, but noone hasnt reply about where i
could download the neccessary rpms, yet. or i'm not able to express myself, nor
noone wants to understand me!
Comment 18 nezihkartal 2005-08-14 16:34:24 EDT
please DO NOT close this bug, until anyone gives the exact address of alsa-lib's
fixed version that Nezih Kartal ( me ) can download!!!

i opened this bug. everyone who has this problem, solved their problems. but i
couldnt yet.

DO NOT write blank (blank is to say, which hasnt got the address of alsa-lib's
fixed rpms). or PLEASE erase this bug completely nor doesnt touch...
Comment 19 Martin Stransky 2005-08-16 06:26:28 EDT
rawhide is here: 

http://download.fedora.redhat.com/pub/fedora/linux/core/development/
Comment 20 Tommas Ip 2005-09-03 06:06:42 EDT
With my ES1371 on FC4, I have the same problem too (noise in left channel).

After googling, I found that the following blog provided another way to
solve the problem:
http://darkness.codefu.org/wordpress/2005/07/02/186

It generally does this:
1. Open  GNOME volume control applet
2. Edit->Preferences, check the IEC958
3. In the Switches tab, turn off IEC958

Now the noise is magically gone.
Comment 21 nezihkartal 2005-09-16 02:23:07 EDT
(In reply to comment #20)
> With my ES1371 on FC4, I have the same problem too (noise in left channel).
> 
> After googling, I found that the following blog provided another way to
> solve the problem:
> http://darkness.codefu.org/wordpress/2005/07/02/186
> 
> It generally does this:
> 1. Open  GNOME volume control applet
> 2. Edit->Preferences, check the IEC958
> 3. In the Switches tab, turn off IEC958
> 
> Now the noise is magically gone.


thanx but it was the first thing that i disabled.
Comment 22 nezihkartal 2006-02-19 22:57:07 EST
hello,
this is the first time that i install fc4, since you said you solved this
problem with making a new alsa rpms. firstly i download ;
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/i386/alsa-lib-1.0.10-3.FC4.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/i386/alsa-utils-1.0.10-1.FC4.i386.rpm
and install. because their dates are new. but the bug wasnt solved with these
rpms. problem is going on, fully... i couldnt find that switch among the switches...

"(In reply to comment #15)
> Added new HW switch to c-s-c (in rawhide) to bypass dmix."

after these, i tried to download and install these rpms ;
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/alsa-lib-1.0.11-3.rc2.2.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/alsa-utils-1.0.11-2.rc2.2.i386.rpm
the result is;

Failed dependencies:
        libc.so.6(GLIBC_2.4) is needed by alsa-lib-1.0.11-3.rc2.2.i386
        libc.so.6(GLIBC_2.4) is needed by alsa-utils-1.0.11-2.rc2.2.i386
        udev < 062 conflicts with alsa-utils-1.0.11-2.rc2.2.i386

i'll now try to change asound.conf that Herbert Rutledge suggests. thanx him.
but it's a temporary solve, if it works. do i have to change that file every
fedora installing? why dont you fix this bug. that rpms dont fix it. please fix
this problem...
Comment 23 nezihkartal 2006-02-19 23:04:56 EST
configuring asound.conf, didnt fix :(
Comment 24 Martin Stransky 2006-02-20 04:29:18 EST
download/install alsa-lib, alsa-utils ans system-config-soundcard packages from
FC4 update, run system-config-soundcard and disable support for dmix/dsnoop.
Comment 25 nezihkartal 2006-02-21 01:25:42 EST
i disabled software mixing (dmix, dsnoop). really, nothing changed. result is
the same :(
Comment 26 Martin Stransky 2006-02-21 02:58:27 EST
see this bug:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=139927

*** This bug has been marked as a duplicate of 139927 ***
Comment 27 nezihkartal 2006-03-21 04:25:43 EST
hey! i'm testing fedora core 5 now. and fc5 doesnt have this bug, even without
changing any sound card configuration :) i'm so happy. everyone who has this
bug, please make a fresh install fc5.

to me, new name of linux is FEDORA CORE 5 !!! i dont agree that i had been used
linux since fc2. because i dont like any other distros.

thanx to fedora developers... please dont stop supporting old hardwares ;) go on
doing it...

(i hope i wont get any problem about nvidia drivers and kernel or about another
bug... i'll try now)

see you...

Note You need to log in before you can comment on or make changes to this bug.