Bug 139927 - sound crackles, IEC958 muting no help, general volume adjustment has no effect
sound crackles, IEC958 muting no help, general volume adjustment has no effect
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2004-11-18 14:59 EST by mp
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 05:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mp 2004-11-18 14:59:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
sound is crackling very badly when playing MP3 from HDD;

less bad when playing .ogg. from HDD;

no sound from CD drive or video from HDD or CD/DVD (like Xine,
MPlayer) but images are fine;

ALL UPDATES DONE (18/11-04, 19.00 - GMT) INCL. KERNEL & XORG

issue is similar to the one in FC2, to which solution was to mute
various channels, particularly IEC958 channels. this does not work for
me in FC3 (but did in FC2) and even weirder?: if muting IEC958 Optical
Raw all sounds disappear completely. If all channels are muted, apart
from IEC958, the crackling sound is still there. The sliders of the
various channels have no effect. The only adjustment that seems to
work is inside XMMS?!

during initial fresh install the soundcard-config test returned fine
result! the box was working fine with RH9



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Play sound in any client/app
2. Fiddle with gnome-audio-control and change settings till the cows
come home
3. Hear the crackle
    

Actual Results:  the sound is very poor for mp3, better for .ogg and
absent for other media

Expected Results:  nice crisp audio entertainment, as it used to be
with RH9

Additional info:

tried this suggestion:
http://bugzilla.redhat.com/bugzilla/long_list.cgi#c6 :

[root@localhost ~]# /usr/sbin/alsactl restore -f /opt/asound.state
/usr/sbin/alsactl: set_control:805: warning: name mismatch (External
Amplifier/3D Control Sigmatel - Depth) for control #67
/usr/sbin/alsactl: set_control:892: bad control.67.value type

more info:
[root@localhost ~]# grep snd-card /etc/modprobe.conf
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0

[root@localhost ~]# /sbin/lspci -vv|grep Multi
00:0f.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 08)

[root@localhost ~]# /sbin/modinfo snd-emu10k1
filename:      
/lib/modules/2.6.9-1.678_FC3/kernel/sound/pci/emu10k1/snd-emu10k1.ko
author:         Jaroslav Kysela <perex@suse.cz>
description:    EMU10K1
license:        GPL
parm:           index:Index value for the EMU10K1 soundcard.
parm:           id:ID string for the EMU10K1 soundcard.
parm:           enable:Enable the EMU10K1 soundcard.
parm:           extin:Available external inputs for FX8010. Zero=default.
parm:           extout:Available external outputs for FX8010.
Zero=default.
parm:           seq_ports:Allocated sequencer ports for internal
synthesizer.
parm:           max_synth_voices:Maximum number of voices for WaveTable.
parm:           max_buffer_size:Maximum sample buffer size in MB.
parm:           enable_ir:Enable IR.
vermagic:       2.6.9-1.678_FC3 686 REGPARM 4KSTACKS gcc-3.4
depends:       
snd-pcm,snd-ac97-codec,snd-util-mem,snd-page-alloc,snd-rawmidi,snd,snd-hwdep,snd-seq-device
alias:          pci:v00001102d00000002sv*sd*bc*sc*i*
alias:          pci:v00001102d00000004sv*sd*bc*sc*i*
Comment 1 Sitsofe Wheeler 2004-11-20 10:05:17 EST
I assume you are playing music from the hard disk. Does copying a
music file to /dev/shm/ and playing it from there make any difference
(try to avoid accessing the disk while you are doing so)?
Comment 2 mp 2004-11-21 22:02:01 EST
it is the same thing: it is crackling, hissing horribly.

what i don't understand is (and it irritates me immensely, since i
still think that it likely to be some little thing, but i even tried
to run someones volume settings as noted above):

(i) that the problem whose solution, which worked for me, in FC2 was
to make sure that IEC958 channels were muted etc., has been changed to
a situation where muting IEC958 Optical Raw eliminates all sound?!

(ii) that what was a seemingly minor glitch and annoyance in FC2 is
now a full-featured malfunction in FC3.

It is, with all due respect, outrageous that sound is not immaculate
out-of-the-box in FC2/FC3 when it was just fine in FC1. Here i was,
looking forward to new kernel and alsa.........
Comment 3 Sitsofe Wheeler 2004-11-22 04:07:09 EST
Well there's no surprise that things changed after FC1 because of the
move from OSS to ALSA. Without enough testing hidious problems are
never ironed out in new things. Maybe no one else has the exact same
set up as you so how can they fix problems that only you have unless
you tell them?

However you are one of many emu10k1 owners complaing about sound
problems (I know another rev 05 emu10k1 owner who has sound cut out
prematurely before the end with a "click") so something funny has
happened. If you have the chops for it I suppose you start building
emu10k1 drivers from all the kernels between FC2 and FC3 and see if
you can track down when this problem was introduced...
Comment 4 Sitsofe Wheeler 2004-11-23 02:51:05 EST
BTW: mp did you mean to remove bbrock@redhat.com from the QAContact box?
Comment 5 mp 2004-11-24 10:54:41 EST
huh? no, i didnt mean to remove anything/one?!?!?
Comment 6 mp 2004-11-24 11:20:34 EST
i loaded an Ubuntu Live-CD onto the machine with the said issues and
it turns out that in Gnome-Alsa-Mixer there are now two main tabs and
no crackles!!

However, the volume control sliders still have no effect, but the
audio is very loud, clear and spot on (but can only be regulated
externally!)

The added tab is called "Soundblaster Live! (Alsa Mixer)" and the
"old" tab, which in FC3 was labbelled "SigmaTel STAC9721/23" has had
this added: "(OSS Mixer)" - does this suggest that in FC3 Alsa wasn't
active at all?

Neither of them can actually control the volume, as far as I have been
able to determine, but like I said the sound in Ubuntu is very good
and loud.

I appreciate that a lot of testing is needed, but I am sure that there
are many SB LIVE! cards out there and that this persisting sound
problem, through FC2 to FC3, turn many ppl away. I use my box for
music a lot when I work (academic writing) and have been using RH/FC
since RH 7.3 and would like to continue, but I have no time, energy
and desire to start incremental compilation of kernels from 2.6.x to
2.6.y - so I wonder if I just have to leave the sinking ship and go
to, for instance, Ubuntu, revert to FC1, or whether there is a
solution on the horizon....!?!??



Comment 7 Sitsofe Wheeler 2004-11-24 14:47:18 EST
Yes, I suspect part of the problem is that not SB Live card setups are
the same...

Anyway, do the steps given in bug 138423#c6 change the type of crackle
you get?
Comment 8 mp 2004-11-24 21:51:55 EST
The steps in that report, as far as i can see, I tried and reported in
the original post above. Downloaded a volume setting script, but it
returned error message.

I think that at this stage of a bug report, from the user perspective,
it would be useful, comforting, re-assuring if someone said something
authoritative, whether it be: (i) "we'll sort that out, hold on, i'll
need this and that info", or (ii) "sorry, we cannot promise this will
be solved and are sorry for your inconvenience" if this distro and the
free software movement generally wants to move beyond male, white,
middle class geek state and into a wider audience.

Giving feedback is fine, if you get recursive feedback - which is to
say mutual recognition is nice and, maybe, essential in community
building.

Sorry to be frustrated, but I am!
Comment 9 Sitsofe Wheeler 2004-11-25 05:00:30 EST
mp, I am only a random user who happened across your bug. I'm afraid I
don't know why your card is having problems even though some other SB
Live owners have no problems. I was merely trying to help but your
last comment was rather alienating.

Since I have no authority, rather than frustrate you any more (and
possibly make things worse) I shall remove myself from this bug.
Comment 10 mp 2004-11-25 11:14:34 EST
sorry, this was no intended - i should have made it clear that I am
very happy that you are helping!!!! no personal comments at all..... i
apologise for not clarifying that...

Comment 11 Dave Jones 2005-07-15 13:40:44 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 12 Dave Jones 2005-08-09 16:46:40 EDT
can you try adding -r 48000 to the /etc/esd.conf file on the line that starts
with spawn_options=
Comment 13 mp 2005-08-11 08:44:00 EDT
have updated to FC4 where the problem does not occur in the same manner, but
there is nevertheless a sound issue: when clickin on a link in Firefox browser
there is a crackling sound while the new page is loading - it is a minor
crackle, but it is very similar to the one that was persistent in FC2/3. This is
using FC4 with the latest kernel: 2.6.12-1.1398_FC4 (it was the same with the
previous kernels).
Comment 14 mp 2005-09-01 15:06:55 EDT
hm...strange!! the crackling become permanent suddenly in FC4! It just
happened!?!? - ok, after adding:

-r 48000 to the /etc/esd.conf file on the line that starts with spawn_options=
as suggested above in comment #12

and rebooting it has gone away - but when scrolling in browser or in other
windows (evolition/email folder scroll for instance) the crackling persists -
now also in FC4 (also did before adding the line above!)

presumably the redrawing of the screen is what intereferes?!  it also happened
that the auto screen saver went on and the crackling became permanent until
reboot!..... 

Currently:
2.6.12-1.1420_FC4 and there is no difference to the previous kernel (1420 is in
test IIRC)

Therefore I should change this bug to FC4 - is that correctly understood?
Comment 15 mp 2005-09-01 16:00:32 EDT
AS stated in comment 14 above, this bug has been changed from FC3 to FC4,
because the problem persists in some permutated form described in that comments.
Comment 16 Gabriel Ramirez 2005-09-16 20:38:00 EDT
Hello, 

I have running fc4 with:

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)

running kernel 2.6.12-1.1447_FC4 and alsa-lib version 1.0.9rf release 2.FC4 and
KDE and I have the same crackling sound all the time, well only when the sound
is at top level if I lower a little the volume the crackling dissapears well
exactly I can't hear it , but the cracking sound exists, 

I don't have esd running so adding the -r 4800 don't help me.

some days ago when I was searching about this bug and seems fixed in 1.0.10rc1,
I tried to find 1.0.10rc1 in rawhide to rebuild them in fc4 to test them, but
seems that rawhide have the same version as fc4
Comment 17 mp 2005-09-16 22:12:02 EDT
(In reply to comment #16)

welcome to the crackling bug :)
Comment 18 Dave Jones 2005-09-30 02:09:42 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 19 Gabriel Ramirez 2005-10-02 17:27:48 EDT
I updated to 2.6.13-1.1526_FC4 and sound crackles continues, so I think it's not
the kernel but alsa-lib

besides that the kernel 2.6.13-1.1526_FC4 is running fine in three machines

(In reply to comment #18)
> Mass update to all FC4 bugs:
> 
> An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
> kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
> previous kernel, it's possible your bug has been fixed already.
> 
> Please retest with this update, and update this bug if necessary.
> 
> Thanks.
> 

Comment 20 mp 2005-10-02 20:31:30 EDT
The crackle  is reproducable by scrolling up and down in either email client
(like down the inbox in Evolution) or long web pages - and also the screen saver
has interfered at points, as if it had to do with (re-)drawing??


(In reply to comment #19)
> I updated to 2.6.13-1.1526_FC4 and sound crackles continues, so I think it's not
> the kernel but alsa-lib
> 
> besides that the kernel 2.6.13-1.1526_FC4 is running fine in three machines
> 
> (In reply to comment #18)
> > Mass update to all FC4 bugs:
> > 
> > An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
> > kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
> > previous kernel, it's possible your bug has been fixed already.
> > 
> > Please retest with this update, and update this bug if necessary.
> > 
> > Thanks.
> > 
> 
> 

Comment 21 Martin Stransky 2005-12-30 07:40:59 EST
Could you please check this alsa-lib package?

http://people.redhat.com/stransky/alsa-lib-1.0.10-1.FC4.test.src.rpm

(You have to remove the old one first and install this)
Comment 22 Gabriel Ramirez 2005-12-30 10:06:58 EST
i'm in hollidays , I don't get to my FC computer until tuesday, so i will be a
little slow in reporting back

btw the rpm is a source rpm, not a problem for me if it rebuilds easily with
rpmbuild.
Comment 23 Martin Stransky 2006-01-03 08:28:49 EST
Could you please check sound only on command-line? Whether it works fine when
you don't use any X-window...
Comment 24 Martin Stransky 2006-01-03 10:33:28 EST
Some how-to for the latest alsa-driver and FC4 is here:
http://people.redhat.com/stransky/alsa/
Comment 25 Sitsofe Wheeler 2006-01-04 14:04:05 EST
mp@aktivix.org:

Can you indicate what motherboard you are using (in fact can you add the output
of /sbin/lspci ...)
Comment 26 mp 2006-01-05 07:23:11 EST
/me is using an ABIT KT7-RAID w/Athlon T-Bird 800Mhz:

lspci -v

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 02)
        Subsystem: ABIT Computer Corp. KT7/KT7-RAID/KT7A/KT7A-RAID Mainboard
        Flags: bus master, medium devsel, latency 8
        Memory at e0000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 2.0
        Capabilities: [c0] Power Management version 2

00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
(prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 00009000-00009fff
        Memory behind bridge: e8000000-e9ffffff
        Prefetchable memory behind bridge: e4000000-e7ffffff
        Capabilities: [80] Power Management version 2

00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 22)
        Subsystem: ABIT Computer Corp.: Unknown device 0000
        Flags: bus master, stepping, medium devsel, latency 0

00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 10) (prog-if 8a
[Master SecP PriP])
        Subsystem: VIA Technologies, Inc.
VT82C586/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE
        Flags: bus master, medium devsel, latency 32
        I/O ports at a000 [size=16]
        Capabilities: [c0] Power Management version 2

00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 10) (prog-if 00 [UHCI])
        Subsystem: VIA Technologies, Inc. (Wrong ID) USB Controller
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at a400 [size=32]
        Capabilities: [80] Power Management version 2

00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 10) (prog-if 00 [UHCI])
        Subsystem: VIA Technologies, Inc. (Wrong ID) USB Controller
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at a800 [size=32]
        Capabilities: [80] Power Management version 2

00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
        Subsystem: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]
        Flags: medium devsel, IRQ 11
        Capabilities: [68] Power Management version 2

00:09.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08)
        Subsystem: Creative Labs CT4760 SBLive!
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at ac00 [size=32]
        Capabilities: [dc] Power Management version 1

00:09.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 08)
        Subsystem: Creative Labs Gameport Joystick
        Flags: bus master, medium devsel, latency 32
        I/O ports at b000 [size=8]
        Capabilities: [dc] Power Management version 1

00:0b.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 43)
        Subsystem: D-Link System Inc DFE-530TX rev A
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at b400 [size=256]
        Memory at eb000000 (32-bit, non-prefetchable) [size=256]
        [virtual] Expansion ROM at 40020000 [disabled] [size=64K]
        Capabilities: [40] Power Management version 2

00:0d.0 USB Controller: NEC Corporation USB (rev 43) (prog-if 10 [OHCI])
        Subsystem: D-Link System Inc: Unknown device 0035
        Flags: bus master, medium devsel, latency 32, IRQ 10
        Memory at eb001000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [40] Power Management version 2

00:0d.1 USB Controller: NEC Corporation USB (rev 43) (prog-if 10 [OHCI])
        Subsystem: D-Link System Inc: Unknown device 0035
        Flags: bus master, medium devsel, latency 32, IRQ 5
        Memory at eb002000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [40] Power Management version 2

00:0d.2 USB Controller: NEC Corporation USB 2.0 (rev 04) (prog-if 20 [EHCI])
        Subsystem: D-Link System Inc: Unknown device f101
        Flags: bus master, medium devsel, latency 32, IRQ 10
        Memory at eb003000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [40] Power Management version 2

00:13.0 Mass storage controller: Triones Technologies, Inc.
HPT366/368/370/370A/372/372N (rev 03)
        Subsystem: Triones Technologies, Inc. HPT370A
        Flags: bus master, 66Mhz, medium devsel, latency 120, IRQ 11
        I/O ports at b800 [size=8]
        I/O ports at bc00 [size=4]
        I/O ports at c000 [size=8]
        I/O ports at c400 [size=4]
        I/O ports at c800 [size=256]
        Expansion ROM at 40000000 [size=128K]
        Capabilities: [60] Power Management version 2

01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 PF/PRO AGP 4x
TMDS (prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc Rage 128 Pro AIW AGP
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 32, IRQ 5
        Memory at e4000000 (32-bit, prefetchable) [size=64M]
        I/O ports at 9000 [size=256]
        Memory at e9000000 (32-bit, non-prefetchable) [size=16K]
        [virtual] Expansion ROM at e8000000 [disabled] [size=128K]
        Capabilities: [50] AGP version 2.0
        Capabilities: [5c] Power Management version 2
Comment 27 Sitsofe Wheeler 2006-01-05 14:17:06 EST
Aha! I thought so:
KT133/KM133

Welcome to the world of pain caused by loose specs from which your BIOS may be
the only means of escape mp@aktivix.org.

Short version: (Some?) SBLives on certain motherboards cause bus problems (even
corruption!) and VIA/Creative point fingers at each other as to whose fault it
was (here's a hard won link where VIA points at Creative
http://web.archive.org/web/20040202025440/http://www.viaarena.com/?PageID=26 ).
More links: http://www.ussg.iu.edu/hypermail/linux/kernel/0201.3/1079.html
(kernel mailing list including work arounds later in the thread) and here:
http://alive.singnet.com.sg/tech/click.htm (talks about the different ways the
problems manifest and workarounds) and possibly bug #53803 too.
Comment 28 Gabriel Ramirez 2006-01-07 16:28:11 EST
I rebuiild and install with:
rpm -Uhv --oldpackage alsa-lib-1.0.10-1.FC4.test.i386.rpm and rebooted in runlevel 3

I tried run alsamixer with a user account but it shows the following error:
alsamixer
ALSA lib control.c:782:(snd_ctl_open_conf) Cannot open shared library
/usr/lib/alsa-lib/libasound_module_ctl_plug.so
ALSA lib control.c:785:(snd_ctl_open_conf) symbol _snd_ctl_plug_open is not
defined inside /usr/lib/alsa-lib/libasound_module_ctl_plug.so
Segmentation fault

but running alsamixer as root , brings alsamixer ok, I max all volumes and I was
unable to hear any sounds crackles, I play a ogg file with alsaplayer and sounds
good and no crackles.

so I rebooted in userlevel 5 and logged with a user account in kde , and I don't
hear any sound crackles , I was listening to music via xmms and its good

so for my chipset:
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
        Subsystem: IBM NetVista A30p
        Flags: bus master, medium devsel, latency 0, IRQ 9
        I/O ports at 1c00 [size=256]
        I/O ports at 18c0 [size=64]
        Memory at c0000c00 (32-bit, non-prefetchable) [size=512]
        Memory at c0000800 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

this bug is fixed. thanks

I have too updated the kernels since october last year  to 

kernel-2.6.14-1.1656_FC4

do you want I open a bug about alsamixer running under a user account?

regards
Comment 29 mp 2006-01-09 09:59:27 EST
response to Comment #27 - Aha! I thought so: KT133/KM133

hhmm...this is just great. After more than five years of happy using my computer
is suddenly useless. Somehow the 2.6 kernel has brought this about and it is
escalating - the computer now crashes regularly with a loud beeping sound.

So my options are to either revert to 2.4 kernel or to get rid of the soundcard?

Comment 30 mp 2006-01-09 10:00:28 EST
response to Comment #27 - Aha! I thought so: KT133/KM133

hhmm...this is just great. After more than five years of happy using my computer
is suddenly useless. Somehow the 2.6 kernel has brought this about and it is
escalating - the computer now crashes regularly with a loud beeping sound.

So my options are to either revert to 2.4 kernel or to get rid of the soundcard,
if playing with BIOS yields no solution?
Comment 31 Sitsofe Wheeler 2006-01-09 17:28:23 EST
mp:
I'm out of ideas other than those in the links provided (I've never tested them
as I had the controls after a BIOS update a few years ago). Anything else I
could mention would be just superstition that I read elsewhere - I only know
that changing the PCI Latency in my BIOS made the horific problems go away. I
suppose you can try the usual voodoo dances if your BIOS lacks the option but I
don't fancy your chances. I suppose you can also try and track down whoever
wrote the KT133 workaround a few years ago too.
Comment 32 Sitsofe Wheeler 2006-01-22 17:40:26 EST
(I had cause to look at SBLive crackling today so I'm just going to jot down a
few more links)
http://alive.singnet.com.sg/tech/via.htm - accusations as to who caused the
problem and lots of comments from sufferers. 
Winamp thread of FAQs dedicated to Creative cards -
http://forums.winamp.com/showthread.php?threadid=72515 (includes some whacky
workrounds)
http://tinyurl.com/ah3wd - Creative FAQ taling about settings to "optimise" the
system for better sound performance
http://www.georgebreese.com/net/software/ - tool for setting pci latency in
Windows. Contains details in the readme of which registers are being set so it
may be possible to do something similar under Linux using setpci (might be
dangerous)
Comment 33 Martin Stransky 2006-02-21 02:58:29 EST
*** Bug 161279 has been marked as a duplicate of this bug. ***
Comment 34 nezihkartal 2006-02-22 13:55:41 EST
hello! does anyone make somethings for this bug? at least, it will be fixed
until fc5. otherwise, i will be compelled to return to windows, permanently.
because, i can't even use suse 10 because of refresh problem of my monitor (lg
f700b). i can't use any other distribution for some reasons. for example;
mandrake's versions are buggy (and already mandrake imitates xp), ubuntu's
packages are not up to date, in gentoo installing a package takes several
hours... i stick on suse 9.3. i cant move ahead. these are arousing hatred on
me. the best was fedora core, but it has an unfixable bug that targets me... i
hope you will success.

Note You need to log in before you can comment on or make changes to this bug.