Bug 161511 - Import bookmark wizard is broken
Import bookmark wizard is broken
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: 165927 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2005-06-23 16:12 EDT by axgrau
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-23 15:56:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description axgrau 2005-06-23 16:12:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
It's not possible to import bookmarks.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Bookmarks->Manage Bookmarks

Actual Results:  The import wizard is unusable. There are three buttons at the bottom with no text and nothing happens by clicking them. 

Additional info:
Comment 1 David Anderson 2005-07-14 04:27:55 EDT
Me too. The three buttons at the bottom have no text, and pressing them does 
Comment 2 John Mahowald 2005-07-22 13:37:46 EDT
Works for me with firefox-1.0.6-1.1.fc4. Update firefox and see if it presists.
Comment 3 David Anderson 2005-07-25 10:55:18 EDT
No, still not working with firefox-1.0.6-1.1.fc4. 
Comment 4 axgrau 2005-07-25 15:20:49 EDT
Same here. Still not working.
Comment 5 David Anderson 2005-07-25 15:31:12 EDT
I was using gtk-qt-engine at first, but that caused problems with openoffice. 
Now I'm using clearlooks GTK theme, so it doesn't seem to be caused by 
gtk-qt-engine, unless it's some side effect that still hangs around after 
disabling it. Are you using gtk-qt-engine, axgrau? 
Comment 6 axgrau 2005-07-26 02:55:45 EDT
No, I am not using gtk-qt-engine. Never installed. I normally use KDE, but I
have the same problem if I run Firefox in GNOME.
Comment 7 Peter Wainwright 2005-08-02 03:10:40 EDT
I've had the same problems, both with 1.0.4 and 1.0.6. However, it goes away if
I unset the "LANG" environment variable before running firefox. This seems like
the same bug Ubuntu users have reported, see:


Comment 8 Peter Wainwright 2005-08-02 03:25:10 EDT
Sorry, I forgot some useful information:
As you may guess from my email, I'm using the locale setting
When using this setting, I get the following in the JavaScript console when I
pop up the "Import" dialog:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/bindings/wizard.xml :: _initWizardButton :: line 333" 
data: no]
Like the Ubuntu users, I get 3 buttons with icons but no labels, the middle
(back) button is greyed out, but none of them do anything when pressed.
Comment 9 David Anderson 2005-08-06 09:00:51 EDT
Same here as #7, #8 - unsetting LANG (from en_GB.UTF-8) both makes the 
dialogue work, and prevents the JavaScript console error. 
Comment 10 Peter Wainwright 2005-08-08 10:27:25 EDT
The problem seems to be some missing settings in the file 
locale/global/wizard.properties, which lives in the archive

Comparing this file with the en-US version shows:

[prw@desdemona tmp]$ diff -u en-{GB,US}/locale/global/wizard.properties
--- en-GB/locale/global/wizard.properties       2004-11-02 04:54:08.000000000 +0000
+++ en-US/locale/global/wizard.properties       2004-08-15 05:10:33.000000000 +0100
@@ -2,6 +2,10 @@
 button-next=Next >
 default-first-title=Welcome to the %S
 default-last-title=Completing the %S

The "button-*-gnome" settings are required.
Comment 11 Kevin R. Page 2005-10-07 10:39:37 EDT
This problem afflicts the plugin finder dialog too.
Comment 12 Kevin R. Page 2005-10-07 10:41:01 EDT
*** Bug 165927 has been marked as a duplicate of this bug. ***
Comment 13 Christian Iseli 2007-01-22 05:13:43 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 14 Kevin R. Page 2007-01-22 18:23:46 EST
I'm no longer experiencing this problem: firefox-

Note You need to log in before you can comment on or make changes to this bug.