Bug 161759 - Installer hangs loading USB module
Installer hangs loading USB module
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks: FCMETA_INSTALL
  Show dependency treegraph
 
Reported: 2005-06-26 21:55 EDT by Wayne Carruthers
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 19:52:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Carruthers 2005-06-26 21:55:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.7.3) Gecko/20040910

Description of problem:
Installer hangs at USB module load & does not recover or time-out when installing onto a PC Chips M925 motherboard

By way of background the M925 is a P4 Socket 478 all in one motherboard using VIA P4M266A Northbridge & VT8235 Southbridge

The system concerned has FC3 installed & is still fully operational & patched to latest updates. This clean install to another partition was to test FC4
Tried an upgrade & same result

A similar problem occurs with this MBoard installing Gentoo 2005 which loses the interrupt for LAN (finds LAN then later reports interrupt "ignored, no one cares") Gentoo 2004/1 & 2 also loads/runs OK

Suspect it is to do with a newer handler for the VIA chipset but not sure what further data to provide to assist in determining cause.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install from distribution CD
2.
3.
  

Actual Results:  HANGS

Additional info:
Comment 1 Pete Zaitcev 2005-06-27 17:01:54 EDT
Before I take this, I need to know if this is USB or some generic problem
with interrupts routing, interrupt storm, or other.

Please install an FC4 kernel on top of working FC3 with rpm -i (do not use
rpm -U), and verify that it fails.
Comment 2 Wayne Carruthers 2005-06-27 22:35:52 EDT
Installed FC4 Kernel as per request and all ok, boots, USB,LAN etc all operational
No errrors onscreen during boot

Had to remove selinux policy prior to kernel install due error shown below

rpm -i kernel*.rpm
error: Failed dependencies: selinux-policy-targeted < 1.23.16-1 conflicts with
kernel-2.6.11-1.1369_ FC4.i686

Let me know what other tests I can do to assist
Comment 3 Wayne Carruthers 2005-06-28 01:10:37 EDT
Went back & looked closer

Deactivated USB in BIOS & ran clean install to spare partition, all ran OK
reboot & complete firstboot all ok, reactivated USB in BIOS & reboot, all OK
Kudzu did not pop up & say new hardware, but USB configured & working

Ran installer again with USB active & it gets to the blue screen driver install
stage, says loading usb-storage driver, goes to loading aic7xxx driver, then
returns to loading usb-storage driver screen & hangs

It seems the problem is in the installer script only and is a conflict between
the aix7xxx driver for our Adaptec 2940 SCSI card & the USB, which does not
happen in the FC3 install, nor happen post install with all active

System now happily upgraded with USB deactivated during install, SCSI, scanner &
USB reactivated & all OK

Have spare partition for further tests if I can be of assistance in proving any
 installer script changes

Comment 4 Dave Jones 2005-07-15 17:50:10 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.

Note You need to log in before you can comment on or make changes to this bug.