Bug 1618794 - Autologin fails on Workstation live in Fedora-Rawhide-20180817.n.1
Summary: Autologin fails on Workstation live in Fedora-Rawhide-20180817.n.1
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1618910 (view as bug list)
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-08-17 15:30 UTC by Adam Williamson
Modified: 2018-08-27 05:20 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-24 17:50:26 UTC


Attachments (Terms of Use)

Description Adam Williamson 2018-08-17 15:30:14 UTC
In the latest Rawhide compose, Fedora-Rawhide-20180817.n.1, autologin seems to fail for the Workstation live image. They boot to GDM with 'Live System User' showing, rather than booting to the desktop as they should.

Unfortunately I'm at a conference right now so haven't been able to download the image and poke into this manually, but you can grab the logs from an openQA failure here:

https://openqa.fedoraproject.org/tests/266328/file/_boot_to_anaconda-var_log.tar.gz

I see a bunch of AVCs for dbus, which could *possibly* be related, also some errors from the new grub 'mark boot as successful' stuff. Will try and look into it further if I can.

I'm not sure that this actually violates the release criteria, so not proposing it as a blocker yet.

Comment 1 Hans de Goede 2018-08-19 08:46:34 UTC
Hi,

I doubt that this is related to the grub hide-menu stuff. More likely this is one of the first composes to have gdm-3.29.90, which has changes to kill the greeter gnome-shell session when it is no longer necessary, freeing about 250M of RAM.

I suspect that the kill greeter when no longer necessary changes may have broken autologin.

Regards,

Hans

Comment 2 Adam Williamson 2018-08-19 16:12:02 UTC
That sounds very plausible! Let's check. The previous successful compose was 20180813.n.0, all the ones between failed. And that compose had gdm-3.28.2-2.fc29.x86_64.rpm (see https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20180813.n.0/compose/Everything/x86_64/os/Packages/g/ ). And indeed, 20180817.n.1 has gdm-3.29.90-1.fc29.x86_64.rpm (see https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20180817.n.1/compose/Everything/x86_64/os/Packages/g/ ).

So, that sure adds up. Thanks for the pointer.

Comment 3 Fedora Update System 2018-08-23 20:38:30 UTC
gdm-3.28.4-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f0de6c872c

Comment 4 Fedora Update System 2018-08-24 08:44:13 UTC
gdm-3.28.4-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f0de6c872c

Comment 5 lnie 2018-08-24 10:34:33 UTC
*** Bug 1618910 has been marked as a duplicate of this bug. ***

Comment 6 Adam Williamson 2018-08-24 16:09:11 UTC
This was reported against Rawhide, not F28. (It also affects F29 of course). Can you please send builds for Rawhide and F29 before marking this as fixed? Thanks.

Comment 7 Ray Strode [halfline] 2018-08-24 17:50:26 UTC
oops that fix was meant for bug 1618582.  anyway i built what i think should fix this bug now into rawhide. please reopen if i'm wrong.

Comment 8 Adam Williamson 2018-08-27 05:20:24 UTC
This does seem to be fixed in today's Rawhide and F29 composes. However, I suspect something similar affects gnome-initial-setup, as after a successful install (on F29...install fails on Rawhide for other reasons), the installed system doesn't boot properly, it boots to a kinda blank desktop:

https://openqa.fedoraproject.org/tests/269891#step/_graphical_wait_login/9

I'll file a new bug on that.


Note You need to log in before you can comment on or make changes to this bug.