Bug 1619866 - IO-Threads is enabled inadvertently by editing unrelated configuration
Summary: IO-Threads is enabled inadvertently by editing unrelated configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.5
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ovirt-4.3.0
: 4.3.0
Assignee: Arik
QA Contact: Liran Rotenberg
URL:
Whiteboard:
Depends On:
Blocks: 1622994
TreeView+ depends on / blocked
 
Reported: 2018-08-22 00:31 UTC by Germano Veit Michel
Modified: 2019-05-08 12:38 UTC (History)
11 users (show)

Fixed In Version: ovirt-engine-4.3.0_alpha
Doc Type: Bug Fix
Doc Text:
This release ensures that if a request occurs to disable I/O threads of a running VM, the I/O threads setting remains disabled when changing unrelated properties of a running VM.
Clone Of:
: 1622994 (view as bug list)
Environment:
Last Closed: 2019-05-08 12:38:08 UTC
oVirt Team: Virt
Target Upstream Version:
ahadas: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1619474 0 urgent CLOSED Pending change IO thread disable is not applied on shutdown 2021-02-22 00:41:40 UTC
Red Hat Knowledge Base (Solution) 3572221 0 None None None 2018-08-22 04:18:07 UTC
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:38:29 UTC
oVirt gerrit 93854 0 master MERGED core: always write num of i/o threads to ovf 2020-07-15 03:11:25 UTC
oVirt gerrit 93858 0 ovirt-engine-4.2 MERGED core: always write num of i/o threads to ovf 2020-07-15 03:11:25 UTC

Internal Links: 1619474

Description Germano Veit Michel 2018-08-22 00:31:33 UTC
Description of problem:

We have a report of a customer that does not wish to use IO-Threads and after upgrade to 4.2.5 all VMs are getting randomly IO-Threads enabled.

To reproduce:
1. Create VM with IO Threads Disabled
2. Power up the VM
3. Edit the VM, i.e. disable Memory Baloon*
4. Click OK
RESULT: IO Threads is enabled for the next-run

* Any config that triggers next-run config seems to do it. Only seem to happen if the VM is up.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.5.3-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
As above

Actual results:
IO Threads Enabled

Expected results:
IO Threads Disabled

Comment 4 Michal Skrivanek 2018-08-22 06:36:20 UTC
it should be the same root cause (and same fix eventually) as bug 1619474
But I would prefer to keep this bug opened to independently verify both flows

Comment 5 Liran Rotenberg 2018-08-26 12:16:15 UTC
Verified on:
ovirt-engine-4.2.6.4-0.0.master.20180823141941.gitb3a5b18.el7.noarch

Steps of verification:
1. Create a new VM with IO-Threads disabled.
2. Start the VM.
3. Change a VM property - for example disabled ballooning (confirm that the change require VM restart).
4. Check the VM configuration for next-run (IO-Threads should be disabled).
4. Restart the VM.
5. Check the VM IO-Threads.

Results:
The VM IO-Threads was disabled all along and didn't change when editing other VM property.

Comment 9 errata-xmlrpc 2019-05-08 12:38:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.